Anfänger versucht ISDN-Routing

Benninger

Newbie
Hallo zusammen,

ich such mir noch nen Wolf - vielleicht könnt Ihr helfen:

Ich versuche einen Suse-"Router" zusammenzubasteln, der folgendes hat / können soll:

1x eth0 auf 192.168.92.6
1x AVM B1
LAN: 192.168.92.0

Auf den LAN-PC's liegt eine statische Route zu 194.76.98.0, welche als Gateway die 192.168.92.6 nutzt. Defaultgateway auf den LAN-PC's ist unser "echter" Router ins Internet.

Der Suse-Rechner soll nun, wenn er Anfragen ins 194.76.98.0er-Netz erhält, sich per ISDN zur Gegenstelle (RAS-Server) einwählen. Danach können die Windows-LAN-PC's auf IP-Adressen (reines IP, DNS nicht notwendig) des Netzes 194.76.98.0 zugreifen können.

Eine FLI4L-Diskette funzt seit Monaten. Jetzt wollte ich das Ganze unter Suse 9.0 pro machen.

Heute morgen hat das Ganze kurz funktioniert. Allerdings hatte ich das default-Gateway des Suse-Rechners rausgenommen. Soll aber nicht sein.

Geplant ist zukünftig ein Squid auf der Suse-Kiste und eben die Router-Funktionalität zu einem Kundennetzwerk.

Habt Ihr Tipps, wo ich nachschauen kann, warum es nicht läuft?
Braucht Ihr weitere Angaben?

Ich hoffe, Ihr könnt mir helfen!

Der Benninger
 

Benninger

Newbie
Neues von der Front:

Ich habe es soweit hinbekommen:
Auf dem Suse-Router geht ein ping auf www.irgendwo.de über unsere Standard-Internetverbindung (anderer Router).
Ein Ping auf 194.76.98.0 (Kundennetzwerk) baut nun eine ISDN-Verbindung auf, aber es gibt kein Reply.

Was kann das jetzt sein? BTW: Die anderen Rechner im LAN (192.168.92.0) kommen trotz ihrer statischen Route nicht über den Linuxserver
 

Bonsai

Advanced Hacker
Standardgateway kann doch nur in einem direkt zugänglichen Subnetz liegen? Oder hab ich da was verpennt?
 

Benninger

Newbie
Vielleicht ist genau das mein Problem?

Nochmal:
Das Standardgateway in der Firma (für alle PC's) ist ein Router, der A) Zugang zum Internet vermittelt und B) nicht mein Problem an dieser Stelle ist.
Es gibt ein 2. Firmennetzwerk, in das sich eine zur Zeit ein FLI4L bei Bedarf einwählt - also routet.
Wenn ich von meinem PC (192.168.92.8) ein Ping auf 194.76.98.160 absetze, zieht meine feste Route am PC:
194.76.98.0 255.255.255.0 192.168.92.6 1
Wobei 192.168.92.6 der Linux-Rechner mit ISDN-Karte ist.
Dieser baut dann DoD eine ISDN-Verbindung auf und voilà: Das Remotenetzwerk steht mit zur Verfügung.

Das frisch installierte Suse 9.0 pro bekomme ich leider nicht so weit.
Heute morgen hat es mal geklappt, aber leider weiss ich nicht mehr, an welcher Schraube ich gedreht habe...
 

Bonsai

Advanced Hacker
Ist das leerzeichen bei der 61 zum Schluß ein Tippväller oder steht das mit in der Route?
194.76.98.0 255.255.255.0 192.168.92.6 1
 

Benninger

Newbie
Ja, die Route ist bekannt. Ich schrieb ja auch, dass es mit FLI4L funktioniert...
Nein, das ist kein Tippfehlen,
aber zwischen 192.168.92.6 und 1 steht ein Leerzeichen (für die Metric)
 

jado

Member
Du hast aber auch geschrieben, dass es kurz funktioniert hat und jetzt nicht mehr... Routen gehen ja manchmal auch verloren :?

Und ist "ip_forwarding" aktiviert? ... "/etc/sysconfig/sysctl"
 

Benninger

Newbie
Die Route im (entfernten) Kundennetz funktioniert noch. Ein Test mit FLI4L zeigt das.

Könnt Ihr mir vielleicht sagen, wie die Vorgehensweise "ab Null" ist?
Also Standardroute für Suse-PC (192.168.92.6) setzen (192.168.92.253), dann Route setzen für Zugriff aufs Kundennetzwerk (194.76.98.0) und diese Route dann für LAN-PC's (192.168.92.0) "freigeben"?

Wäre echt super!
 
Oben