Gelöst Bildschirm friert unter 15.4 ein

Lurchi

Hacker
Guten Abend..

Leider kann ich bezüglich 15 4 bis jetzt nichts Gutes berichten...
Leider friert bei mir wie unter 15.3 nach einigen Mausbewegungen wieder der Bildschirm ein.
Unter 15.3 musste ich einen anderen Kernel nehmen...
Hat jemand eine Idee?
 

HPF-84E

Member
Hi,
das hatte ich leider auch zu vermelden. Erst habe ich ein Upgrade gemacht von 15.3 auf 15-4. Da habe ich mich schon gefreut das endlich meine Hardware richtig erkannt wird aber da hatte ich wohl Sand dran. Bildschirm ist immer wieder eingefroren aus unerfindlichen Gründen.
Letztendlich habe ich 15.4 neu installiert mit dem gleichen Ergebnis.
Aus Frust habe ich mal das neueste Fedora-Spin mit XFCE und Kernel 5.17.xxx und nach Upgrade Kernel 5.18.xx installiert und da ein ähnliches Ergebnis.
Dabei ist mir aber aufgefallen das der Treiber für meinen Kombi-Chip für WLan und Bluetooth daran Schuld ist.
Code:
inxi -F
System:
  Host: localhost.localdomain Kernel: 5.14.21-150400.22-default x86_64
  bits: 64 Desktop: Xfce 4.16.0 Distro: openSUSE Leap 15.4
Machine:
  Type: Desktop System: HP product: HP Slim Desktop 290-p0xxx v: N/A
  serial: <superuser required>
  Mobo: HP model: 843F v: 00 serial: <superuser required> UEFI: AMI v: F.20
  date: 11/01/2018
CPU:
  Info: Quad Core model: Intel Core i3-8100 bits: 64 type: MCP cache:
  L2: 6 MiB
  Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800
  3: 819 4: 800
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: AMD Jet PRO [Radeon R5 M230 / R7 M260DX / Radeon 520 Mobile]
  driver: radeon v: kernel
  Display: x11 server: X.org 1.20.3 driver: loaded: ati,modesetting,radeon
  unloaded: fbdev,vesa resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.4
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.14.21-150400.22-default running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: eth0 state: down mac: f4:39:09:43:04:a8
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  driver: rtw_8821ce
  IF: wlan0 state: down mac: 3a:20:27:86:00:62
  Device-3: Netgear WPN111 RangeMax Wireless USB 2.0 Adapter type: USB
  driver: ar5523
  IF: wlan1 state: up mac: 00:18:4d:d9:3e:8f
Bluetooth:
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
  bt-service: enabled,running rfk-block: hardware: no software: yes
  address: 0C:96:E6:73:6B:1E
Drives:
  Local Storage: total: 1.14 TiB used: 435.92 GiB (37.3%)
  ID-1: /dev/nvme0n1 vendor: Western Digital
  model: PC SN520 SDAPNUW-256G-1006 size: 238.47 GiB
  ID-2: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
Partition:
  ID-1: / size: 233.19 GiB used: 6.13 GiB (2.6%) fs: ext4
  dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 499.7 MiB used: 4.9 MiB (1.0%) fs: vfat
  dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 42.0 C mobo: 27.8 C gpu: radeon temp: 27.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 223 Uptime: 0h 13m Memory: 7.6 GiB used: 1.4 GiB (18.4%)
  Shell: Bash inxi: 3.3.07

Also habe ich einfach wie schon unter opensuse 15.3 wieder meinen Wlan-Dongle in Benutzung und habe das erste Upgrade von opensuse 15.4 schon bei der Installation durchgezogen.
Jetzt läuft es erst einmal aber ...
Freezer habe ich noch bei KeepassXC ohne Browser-PlugIn und mein MusikPlayer Guayadeque stürzt immer ab.
Mir fehlt aber die Zeit mich intensiver damit zu Beschäftigen und hoffe halt das sich das durch Updates verbessert.
Lustig fand ich nur das zwar mit Fedora und Kernel 5.18.xxx keine Freezes mehr auftauchen aber die WLan-verbindung immer wieder neu startet.
Mehr kann ich dazu erst einmal nicht beitragen.:rolleyes:
Aber vielleicht findest du ja noch mehr Baustellen wie z.B. der Xserver oder AMD Grafik oder ...
 
OP
Lurchi

Lurchi

Hacker
Hi,
das hatte ich leider auch zu vermelden. Erst habe ich ein Upgrade gemacht von 15.3 auf 15-4. Da habe ich mich schon gefreut das endlich meine Hardware richtig erkannt wird aber da hatte ich wohl Sand dran. Bildschirm ist immer wieder eingefroren aus unerfindlichen Gründen.
Letztendlich habe ich 15.4 neu installiert mit dem gleichen Ergebnis.
Aus Frust habe ich mal das neueste Fedora-Spin mit XFCE und Kernel 5.17.xxx und nach Upgrade Kernel 5.18.xx installiert und da ein ähnliches Ergebnis.
Dabei ist mir aber aufgefallen das der Treiber für meinen Kombi-Chip für WLan und Bluetooth daran Schuld ist.
Code:
inxi -F
System:
  Host: localhost.localdomain Kernel: 5.14.21-150400.22-default x86_64
  bits: 64 Desktop: Xfce 4.16.0 Distro: openSUSE Leap 15.4
Machine:
  Type: Desktop System: HP product: HP Slim Desktop 290-p0xxx v: N/A
  serial: <superuser required>
  Mobo: HP model: 843F v: 00 serial: <superuser required> UEFI: AMI v: F.20
  date: 11/01/2018
CPU:
  Info: Quad Core model: Intel Core i3-8100 bits: 64 type: MCP cache:
  L2: 6 MiB
  Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800
  3: 819 4: 800
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: AMD Jet PRO [Radeon R5 M230 / R7 M260DX / Radeon 520 Mobile]
  driver: radeon v: kernel
  Display: x11 server: X.org 1.20.3 driver: loaded: ati,modesetting,radeon
  unloaded: fbdev,vesa resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.4
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.14.21-150400.22-default running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: eth0 state: down mac: f4:39:09:43:04:a8
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  driver: rtw_8821ce
  IF: wlan0 state: down mac: 3a:20:27:86:00:62
  Device-3: Netgear WPN111 RangeMax Wireless USB 2.0 Adapter type: USB
  driver: ar5523
  IF: wlan1 state: up mac: 00:18:4d:d9:3e:8f
Bluetooth:
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
  bt-service: enabled,running rfk-block: hardware: no software: yes
  address: 0C:96:E6:73:6B:1E
Drives:
  Local Storage: total: 1.14 TiB used: 435.92 GiB (37.3%)
  ID-1: /dev/nvme0n1 vendor: Western Digital
  model: PC SN520 SDAPNUW-256G-1006 size: 238.47 GiB
  ID-2: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
Partition:
  ID-1: / size: 233.19 GiB used: 6.13 GiB (2.6%) fs: ext4
  dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 499.7 MiB used: 4.9 MiB (1.0%) fs: vfat
  dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 42.0 C mobo: 27.8 C gpu: radeon temp: 27.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 223 Uptime: 0h 13m Memory: 7.6 GiB used: 1.4 GiB (18.4%)
  Shell: Bash inxi: 3.3.07

Also habe ich einfach wie schon unter opensuse 15.3 wieder meinen Wlan-Dongle in Benutzung und habe das erste Upgrade von opensuse 15.4 schon bei der Installation durchgezogen.
Jetzt läuft es erst einmal aber ...
Freezer habe ich noch bei KeepassXC ohne Browser-PlugIn und mein MusikPlayer Guayadeque stürzt immer ab.
Mir fehlt aber die Zeit mich intensiver damit zu Beschäftigen und hoffe halt das sich das durch Updates verbessert.
Lustig fand ich nur das zwar mit Fedora und Kernel 5.18.xxx keine Freezes mehr auftauchen aber die WLan-verbindung immer wieder neu startet.
Mehr kann ich dazu erst einmal nicht beitragen.:rolleyes:
Aber vielleicht findest du ja noch mehr Baustellen wie z.B. der Xserver oder AMD Grafik oder ...
Hallöchen....

Was hat Dein WLAN mit meinem Thema überhaupt zu tun? Sehe keine Relevanz.

Während der Neuinstallation von 15.4 habe ich auch aktualisiert und trotzdem friert der Bildschirm bei mir ein...

@Sauerland..
Könnte der aktuelle Kernel das Problem sein? Unter 15.3 habe ich anfänglich das gleiche Problem gehabt und habe ein Version darunter genommen..
 
Könnte der aktuelle Kernel das Problem sein? Unter 15.3 habe ich anfänglich das gleiche Problem gehabt und habe ein Version darunter genommen..
Ja, hast du es mal mit kernel:stable:backport versucht?

Leap 15.4 hat einen Kernelversion 5.14 (backported 5.15), in kernel:stable:backport liegt zur Zeit ein Kernel 5.18
 

HPF-84E

Member
Hallöchen....

Was hat Dein WLAN mit meinem Thema überhaupt zu tun? Sehe keine Relevanz.

Während der Neuinstallation von 15.4 habe ich auch aktualisiert und trotzdem friert der Bildschirm bei mir ein...

@Sauerland..
Könnte der aktuelle Kernel das Problem sein? Unter 15.3 habe ich anfänglich das gleiche Problem gehabt und habe ein Version darunter genommen..
Du hast eine allgemeine Frage gestellt und ich habe Dir eine entsprechende Antwort gegeben. Bei mir war es halt der Realtek Treiber.

Wenn du keine entsprechenden Hinweise( Infos zum PC) und Infos (z.B. journalctl -f) bezüglich deines System lieferst brauchst du dich nicht wundern.

Auch wenn Sauerland mir ganz nebenbei einen Tipp gegeben hat hat hier keiner vor deinen Thread zu entführen. Wenn dann würde ich einen eigenen erstellen.

Ich kann aber deine schlechte Laune verstehen wenn der PC so überhaupt nicht will.
Versuch einfach Cool zu bleiben.
 
OP
Lurchi

Lurchi

Hacker
Ja, hast du es mal mit kernel:stable:backport versucht?

Leap 15.4 hat einen Kernelversion 5.14 (backported 5.15), in kernel:stable:backport liegt zur Zeit ein Kernel 5.18
Hi...

Ich habe ein rtl8821 Chipsatz für WLAN und Bluetooth, der auch als Modul unter 15.4 mit 5.14 gebaut wurde .

Falls ich einen höheren Kernel nehme sollte, laufe ich nicht in Gefahr das dieses Modul nicht mehr erkannt und gebaut werden kann...
Oder sollte ich dann lieber Deine Quellen nehmen?
 
OP
Lurchi

Lurchi

Hacker
Du hast eine allgemeine Frage gestellt und ich habe Dir eine entsprechende Antwort gegeben. Bei mir war es halt der Realtek Treiber.

Wenn du keine entsprechenden Hinweise( Infos zum PC) und Infos (z.B. journalctl -f) bezüglich deines System lieferst brauchst du dich nicht wundern.

Auch wenn Sauerland mir ganz nebenbei einen Tipp gegeben hat hat hier keiner vor deinen Thread zu entführen. Wenn dann würde ich einen eigenen erstellen.

Ich kann aber deine schlechte Laune verstehen wenn der PC so überhaupt nicht will.
Versuch einfach Cool zu bleiben.
Moins...

Mit der Antwort "Habe ähnliches erfahren " kann ich leider nichts anfangen.
Ich bin Dir wirklich nicht böse.
 
Ich habe ein rtl8821 Chipsatz für WLAN und Bluetooth, der auch als Modul unter 15.4 mit 5.14 gebaut wurde .

Falls ich einen höheren Kernel nehme sollte, laufe ich nicht in Gefahr das dieses Modul nicht mehr erkannt und gebaut werden kann...
Oder sollte ich dann lieber Deine Quellen nehmen?
ne, der läuft ab Kernel 5.12 out-of-the-box mit rtw88......

Code:
zypper se -si rtw88 rtl8821
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Keine passenden Objekte gefunden.
Kein extra kmp installiert.
Code:
/sbin/lspci -nnk | grep -iA3 net
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
        Subsystem: Hewlett-Packard Company Device [103c:84a6]
        Kernel driver in use: r8169
        Kernel modules: r8169
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
        Subsystem: Hewlett-Packard Company Device [103c:831a]
        Kernel driver in use: rtw_8821ce
        Kernel modules: rtw88_8821ce

Code:
lsb-release -id && uname -a
Distributor ID: openSUSE
Description:    openSUSE Leap 15.4
Linux laptop 5.14.21-150400.22-default #1 SMP PREEMPT_DYNAMIC Wed May 11 06:57:18 UTC 2022 (49db222) x86_64 x86_64 x86_64 GNU/Linux

Hier ist zwar der Kernel aus Leap installiert, aber mit kernel:stable:backports läuft es auch.
 
OP
Lurchi

Lurchi

Hacker
Moins...
Welchen Kernel nehme ich dann. 5.15...5.18..?

Ja, hast du es mal mit kernel:stable:backport versucht?

Leap 15.4 hat einen Kernelversion 5.14 (backported 5.15), in kernel:stable:backport liegt zur Zeit ein Kernel 5.18
Kannst Du mir bitte den absoluten Pfad schicken?
Danke.
 
Zuletzt bearbeitet von einem Moderator:
OP
Lurchi

Lurchi

Hacker
Hallo Leute.

Der 5.18er Kernel brachte den Durchbruch. Alles läuft wieder. Kein Einfrieren..Hardware wird korrekt erkannt...
Danke noch mal an alle.
 

Christina

Moderator
Teammitglied
Magst du uns vielleicht noch etwas zur Hardware sagen? Für Andere hier, die ähnliche Probleme haben, ist das immer hilfreich.
inxi -MCGz
 
OP
Lurchi

Lurchi

Hacker
Magst du uns vielleicht noch etwas zur Hardware sagen? Für Andere hier, die ähnliche Probleme haben, ist das immer hilfreich.
inxi -MCGz
Guten Abend ...

Jetzt habe ich etwas Luft ...

Kommando ergab:
Code:
Passwort:
localhost:~ # inxi -MCGz
Machine:   Type: Laptop System: HP product: HP Laptop 17-by3xxx v: N/A serial: <filter>
           Mobo: HP model: 868E v: 65.13 serial: <filter> UEFI: AMI v: F.06 date: 05/19/2020
CPU:       Info: Dual Core model: Intel Core i3-1005G1 bits: 64 type: MT MCP cache: L2: 4 MiB
           Speed: 960 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 960 2: 1100 3: 1100 4: 1095
Graphics:  Device-1: Intel Iris Plus Graphics G1 driver: i915 v: kernel
           Device-2: Chicony HP Webcam type: USB driver: uvcvideo
           Display: server: X.Org 1.20.3 driver: loaded: modesetting unloaded: fbdev,vesa
           resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.2.4
localhost:~ #

Lapi läuft tadellos mit dem 5.18er .
:)
 
Oben