epson stylus c64 ?

rue.fr

Member
Habe da ein problem mit diesem Drucker bin schon fast am verzweifeln er ist an den parallelen Port angeschlossen und ich dachte ich bekomme das treiberproblem mit dem generischen treiber hin aber denkste. habe mir jetzt bei epkowa die rpm pakete gezogen und die für cubs lassen sich nicht installieren wegen zwei fehlenden lip dateien kann mir jemand sagen wo ich die herbekomme?

Fehler: Failed dependencies:
libcrypto.so.0.9.6 is needed by pips-sc64_63s-cups-2.6.2-1
libssl.so.0.9.6 is needed by pips-sc64_63s-cups-2.6.2-1

oder mache ich was falsch? Achso ich habe suse 9.0 ist ja ganz wichtig zu wissen.
 
Hallo rue.fr gehe zur rpm Suchmaschiene www.rpmseek.de und gib deine fehlenden libs ein.
Gehe dann zu deiner Distri und Version und lade sie dir runter fertig.

:lol:
 
A

Anonymous

Gast
die beiden Dateien gehören irgendwie zum openssl paket muss ich mal ausprobieren :)

diese rpm datenbank ist einfach spitze guter TIP
 

rue.fr

Member
Hallo leute :lol:

habe mir die packete der beiden libs geholt sie gehören zu oppen ssl 096 in suse 9.0 ist aber schon die version 097 drin und jetzt vertragen sich die beiden sachen nicht. habe die installation erzwungen und der rechner taucht jetzt auch in den cubs treibern unter jast auf aber es funzt eben immer noch nicht wenn ich auf testseite drucken gehe dann passiert nichts diese ganze druckerangelegenheit scheint sich doch etwas problematischen zu gestallten als ich dachte kann mir mal einen eine anleitung geben nach welchen einstellungen ich in den einzelnen dateien schauen muss?
 

wolfi_z

Hacker
Hallo,

Also, ich habe nun auch so einen Epson Stylus C64.
PROBLEM: Laut Linuxprinting brauche ich gimp-print 4.2.6.
Das habe ich jetzt schon mal installiert (hab ein rpm fuer RHFC gefunden), danach auch noch libgimpprint-4.2.5 deinstalliert (das ist die Version, die bei SuSE 9.0 dabei ist). Da ich gimp-print 4.2.6 habe, ging die Deinstallation von libgimpprint-4.2.5 auch ohne grosse Mecker von YaST2 ueber die Buehne, denn das 'provides' ist bei beiden das gleiche (offensichtlich heisst wohl gimp-print bei SuSE libgimpprint). Dann habe ich cups neu gestartet, aber ich bekomme immer noch die libgimpprint-4.2.5 drivers gelistet, was ich seltsam finde. :?: Also ist logischerweise der Epson Stylus C64 nicht gelistet.
Andere Frage, hast Du einen Link fuer dieses Paket pips-sc64_63s-cups-2.6.2-1 ?? Vielleicht hilft das. Den Versionskonflikt der erwaehnten openssl-Dateien wuerde ich auf die harte Tour loesen:
ln -sf blabla-so.0.9.7 blabla-so.0.9.6
erzeugt die Version 0.9.6 als Link auf die Version 0.9.7 - ich weiss nicht, ob das OK ist, hat aber bisher in derlei Situationen immer geholfen.
 

rue.fr

Member
da habe ich auch alles gefunden das mit dem link auf die neue version von openssl funzt nicht schade werde wohl warten müssen bis einer dieses druckteil unterstützt :lol:


Ok viel spass
 

wolfi_z

Hacker
Also, Update nach den Bemuehungen der vergangenen Nacht.
Das Gimp-Print Paket hatte ich ja schon auf 4.2.6 upgedatet. Inzwischen bin ich auch auf cups-1.1.20 gegangen, die Pakete kann man hier runterladen. So, nun habe ich also im Konfigurationsmenue bei YaST die Option, den Drucker tatsaechlich als Epson C63 / C64 zu konfigurieren. Funktionieren tut er dann allerdings immer noch nicht :?: :?: :roll: Konkret heisst das, er reagiert einfach ueberhaupt nicht :x
Soweit bis jetzt. Wir werden sehen :shock:
Uebrigens hilft das Web-Interface (http://localhost:631) im Moment gar nicht weiter. Dort ist seltsamerweise der Epson Stylus C63 / C64 im Gegensatz zu YaST nicht mal gelistet :roll: :?:
 

wolfi_z

Hacker
So, Freunde der Sonne, der Papa hat's hingekriegt.
Folgendes:
Installation von cups-1.1.20 wie beschrieben.
Installation von gimp-print-4.2.6 wie beschrieben.
Wie ich inzwischen per Installation auf meinem Laptop nachgeprueft habe, sind diese beiden Updates wohl optional! Auf meinem Laptop habe ich nur ein per YOU gepatchtes Standard-cups. Trotzdem geht der Drucker auch hier
Installation von diesem pips-Paket mit rpm -Uvh --force --nodeps. Nach der Installation dieses Pakets die Messages befolgen, und das 'Setup' durchfuehren.
Dann die Geschichte mit den Libraries, die rue.fr schon angesprochen hat, wird geloest wie folgt:
149790:/usr/lib # ln -sf libcrypto.so.0.9.7 libcrypto.so.0.9.6
149790:/usr/lib # ln -sf libssl.so.0.9.7 libssl.so.0.9.6
Der Drucker kann in YaST mit dem korrekten Treiber installiert werden. Und nun geht er auch :D :D :D :D :D
Wichtig ist noch, dass man den Drucker ueber /dev/usb/lp0 ansteuert. YaST kommt da immer mit der Option //EPSON/..&& irgendwas daher. Damit klappt die Verbindung nicht. Ja klar, und logischerweise habe ich den Drucker ueber USB angeschlossen, ueber Parport kann ich also gar nix aussagen
 

wolfi_z

Hacker
Ich gehe mal davon aus, dass die o.g. Vorgehensweise auch fuer andere Epson Drucker funktioniert, die 'zu neu' sind fuer das gerade aktuelle SuSE Linux :D :D
 
A

Anonymous

Gast
Hallo,
startet der ekpd bei dir automatisch? Weil ich hab mir da erst noch so ein rc.d script geschrieben, damit der drucker auch sicher funktioniert... leider hab ich den PC nicht mehr hier... sonst koennte ich es genauer nachvollziehen.
siehe dazu auch meinen Thread hier: http://www.h-mpeg.de/forum/viewtopic.php?t=124
Oder hab ich mir da mehr muehe gemacht als eigentlich noetig? Oder braucht man diesen Daemon etwa nur, um den Tintenstand abzufragen?
Gruss,
Jacob

http://www.h-mpeg.de der open source mp3 player...
 

wolfi_z

Hacker
Oder hab ich mir da mehr muehe gemacht als eigentlich noetig?
Ja, so klingt mir das :shock:
Also Du brauchst da gar nix starten, das Programm musst Du einmal installieren, dann das setup machen, dann hast Du Dein ppd-file, und das sagt dem cups wie es mit dem Drucker umgehen muss.
Tintenstand?? Keine Ahnung. Also so ein Feature ist ja interessant, aber nicht fuer mich. Das geht mir zu weit.
Damit der Drucker sicher funktioniert, reicht es bei mir seit der o.g. Installation, ihn von hinten ans 230 Volt-Netz zu haengen, von links ein USB-Kabel in das dazugehoerige Loch zu stecken und von oben Papier reinzustopfen :D 8)
 

feldsee

Newbie
Also ich habe jetzt alle hier beschriebenen Schritte nachvollzogen ... mein C64 druckt nur Postscript-Quellcode :shock:

Was kann da noch falsch sein?
 

oktobaer

Newbie
Hallo!

Dank der Einträge hier habe ich es tatsächlich geschafft den Epson C64 zum drucken zu bringen - vielen Dank!
Nochmals die Schritte als "Kochrezept":

1.) Runterladen des Treibers von:
http://www.epkowa.co.jp/english/linux_e/DL1_ink_e.html
2.) Konsole öffnen und als root anmelden <su passwort>
3.) in das Verzeichnis wechseln wo der Treiber liegt <cd pfad>
4.) rpm Paket installieren <rpm -Uvh --force --nodeps pips-sc64_63s-cups-2.6.2-1.i386.rpm>
5.) Die Ausgabe der obigen Installation beachten und das setup in dem angegeben Pfad starten
6.) Die vorgegebenen Angaben bzw. Optionen habe ich immer abgetippt und bestätigt
7.) Dann in das Verzeichnis /usr/lib wechseln <cd /usr/lib>
8.) 1. Link setzen <ln -sf libcrypto.so.0.9.7 libcrypto.so.0.9.6>
9.) 2. Link setzen <ln -sf libssl.so.0.9.7 libssl.so.0.9.6>
10.) YASt starten und den neuen Drucker installieren
11.) dabei auf der Seite "Konfiguration bearbeiten" den "Anschluss" unbedingt auf </dev/usb/lp0> abändern
12.) abschließend noch den "Test"-Button rechts unten drücken und auf das "süße" Druckgeräusch warten!
13.) -> OK !?

Wenn man es ein paarmal gemacht hat geht es flott, Punkt 5 und 11 habe ich jedoch anfangs nicht beachtet und deshalb mit einigen Stunden "bezahlt". :(

Oktogrüße
 

oktobaer

Newbie
... ein paar Fragen habe ich aber auch noch:

1.) Ich finde keine Möglichkeit den Drucker auf verschiedene Medien (Fotopapier, Transparentfolien) einzustellen
2.) Kann man auch einen tintensparenden "Eco"-Farbmodus einstellen? (nicht Graustufen)
3.) Wenn der Drucker ausgeschaltet ist wenn ein Druckauftrag gestartet wird, dann steht er in der Warteschlange und druckt auch nicht wenn der Drucker eingeschaltet wird. Wie schaffe ich das?


Oktogrüße
 

feldsee

Newbie
Mit der neuesten Version von Turboprint geht es ganz zwanglos: http://www.turboprint.de/turboprint-1.87-1.i386.rpm

Das gibt es aber erst seit ein paar Tagen 8)
 

oktobaer

Newbie
... super!

Turboprint ist schon ein Schritt nach vorne :D
-
Bleibt noch eine Frage offen:
Wie startet man den Ausdruck, wenn er in der Warteschlange steht und man dummerweise vergessen hat den Drucker rechtzeitig einzuschalten?
Nach dem Einschalten läßt er sich aus dem Druckermenü heraus mit keiner Aktion dazu bewegen den Druck zu starten!!!

Oktogrüße
 

wolfi_z

Hacker
oktobaer schrieb:
Nach dem Einschalten läßt er sich aus dem Druckermenü heraus mit keiner Aktion dazu bewegen den Druck zu starten!!!
Ueber cups geht das im Web Interface http://localhost:631 ueber die Schaltflaeche 'Start Printer' ... ggf. musst Du nochmal aus- und einschalten, der beruechtigte USB-Pieps muss zu hoeren sein :D :)
 
Oben