[gelöst] bringe php nicht zum laufen

mymanner

Newbie
ich hab jetzt apache / php / mysql installiert und kann auch localhost öffnen...

doch wenn ich eine *.php datei öffnen will, kommt ein neues fenster in dem steht, dass mozilla nicht weiß was es mit der datei anfangen soll. ich kann dann auf speichern oder öffnen mit klicken...

ich hoffe mir kann jemand helfen, vielen dank im voraus

michi
 

mymanner

Newbie
ich hab die php datei in folgendem ordner gespeichert:

file:/srv/www/htdocs

aber er kann die datei ja auch unter localhost/info.php finden... nur eben nicht öffnen!
 
Wenn der Browser fragt wo der Browser die Datei speichern soll, ist das bei SuSE meist ein Zeichen, das PhP nicht installiert ist. Der Webserver kennt den "Mime" Typ nicht und weiß nicht das er Dateien mit der Endung .php, etc als PhP Script ausführen soll und sendet es einfach wie eine .exe Datei an den Browser.

Ich selber hatte das Problem, als ich PhP deinstallierte. Nach der Neuinstallation funktionierte PhP auch nicht mehr.

Ich habe das Problem mit einer Neuinstallation gelöst :?
 

Bonsai

Advanced Hacker
Wenn ich mich richtig erinnere (schon ein Jahr her), waren ein zwei Parameter des ellenlangen apache.conf zu php einzustellen. Durchsuch die Datei mal nach php!
 
Oben