(gelöst) Problem bei Installation von UT

Status
Für weitere Antworten geschlossen.

bluejg

Member
Hallo,
wahrscheinlich eine blöde Frage.
Ich habe auf meinem Rechner UT (nicht 2003 oder 2004, die laufen) in /usr/local/games/ut installiert.
Beim Aufruf aus der Konsole bekomme ich die Fehlermeldung
Code:
@linux:~/bin> /usr/local/games/ut/ut
Unreal engine initialized
Bound to SDLDrv.so
Joystick [0] : Unknown Joystick
SDLClient initialized.
Bound to Render.so
Lighting subsystem initialized
Rendering initialized
LoadMap: Entry
Failed to load 'Entry': Can't find file 'Entry'
Failed to load 'Level None.MyLevel': Can't find file 'Entry'
appError called:
Failed to enter Entry: Can't find file 'Entry'
Executing UObject::StaticShutdownAfterError
Executing USDLClient::ShutdownAfterError
Signal: SIGIOT [iot trap]
Aborting.
Exiting.
Name subsystem shut down
Starte ich nur mit ut, erhalte ich
Code:
@linux:~> ut
dirname: missing operand
„dirname --help“ gibt weitere Informationen.
Couldn't run Unreal Tournament (ut-bin). Is UT_DATA_PATH set?
Wie setze ich nun UT_DATA_PATH, da UT ja seine Verzeichnisse nicht finden kann? Set UT_DATA_PATH /usr/local/games/ut hat nicht funktioniert.

Gruß
bluejg
 

Anubid

Hacker
der Installer entpackt komischerweise die Map-dateien nicht. Lösen kann man das problem, in dem man entpackte Maps aus einer anderen UT installation ins UT-Installationsverzeichnis rüberkopiert
 
A

Anonymous

Gast
Hallo habe auch seit einiger Zeit UT2004. Leider krieg ichs net zum laufen!!

Ich habs zwar mit dem installieren hingekriegt *stolz*, aber leider schaff ich es nicht zu starten nach dem Startfenster bricht er ab, ohne Meldung.

wenn ich es aber aus der Konsole aus starte kommt folgendes:

Code:
linux:/usr/local/games/ut2004 # ./ut2004
WARNING: ALC_EXT_capture is subject to change!
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
X Error of failed request:  BadColor (invalid Colormap parameter)
  Major opcode of failed request:  79 (X_FreeColormap)
  Resource id in failed request:  0x380000c
  Serial number of failed request:  114
  Current serial number in output stream:  116

Leider sagt mir das alles nichts!!

Bei windoof hatte es auch getan (liegt also net an der Hardware)

Hier noch etwas zu meinem Rechner:

AMD 1,8 GHz/Suse Linux 9.3
NVidia GeForce 6200 (Leider klappt das aktivieren der 3-D Beschleunigung nicht, nach der aktivierung sieht man beim Test-Server nix. Liegts daran??)

Ausserdem hatte ich es bereits mit dem NVidia Grafiktreiber versucht welchen man vom Suse Server über den Susewatcher sich holen konnte, leider konnte man nach dem Booten überhaupt nix sehen aber des hat sich inzwischen behoben.

Und der originale NVidia Linux Grafiktreiber will sich auch net installieren er meint immer mein Kernel würde das nicht unterstützen, und leider kann der Treiber auch keinen passenden Kernel herunterladen/finden...


Mensch des is n Roman. Also trotz meiner schlechten Schrift und meiner wenigen Erfahrung hoffe ich das mir trotzdem irgendjemand helfen kann.

Vielen Dank schonmal im Vorraus!!!

Edit: Ein Bekannter hat mir geraten glx zu installieren, inzwischen habe ich dass mal in angriff genommen aber das glx braucht ja unzählige zusatzpakete. Gibt es vllt da eine etwas schnellere Lösung?Oder ist glx das falsche?
 

INA_Medick

Member
> NVidia GeForce 6200 (Leider klappt das aktivieren der 3-D Beschleunigung nicht, nach der aktivierung sieht man beim Test-Server nix. Liegts daran??)
Wie willst du ein 3D-Spiel ohne 3D-Beschleunigung spielen?

>Und der originale NVidia Linux Grafiktreiber will sich auch net installieren er meint
>immer mein Kernel würde das nicht unterstützen, und leider kann der Treiber auch
>keinen passenden Kernel herunterladen/finden...
Dann musst du das Kernelmodul halt kompilieren lassen.
Auf der NVidia-Seite findest du ein Howto zur Installation der Treibers.

> Ein Bekannter hat mir geraten glx zu installieren
GLX ist doch kein Ersatz für den NVidia-Treiber.
 
A

Anonymous

Gast
VIELEN DANK "INA_Medick" du hast soeben meinen Horizont erweitert!!!
Nein, im Ernst,

UT2004 tut jetzt!! *freu*

Ich habe das HOWTO auf der NVidia Seite befolgt und den treiber so installiert wie beschrieben die letzten paar male als ich es versuchte wollte er einfach den kernel net kompilieren...

Ist ja auch egal auf jeden fall hats geholfen und des mit dem glx war blödsinn!!!

([Noch etwas, so schwer wars garnet :D ])

Vielen Dank nochmal an alle
 
Status
Für weitere Antworten geschlossen.
Oben