*.htm-Dateien öffnen mit FF 1.5.0.1

beliebiges dir im Konqueror geöffnet,
dort sind *.htm-Seiten die mit Firefox angezeigt werden sollen
auf Seite mit rechter Maustaste und FF auswählen oder öffnen mit... FF
1. wenn Seitenname z.B. 'Linux-Suse_irgend-was.htm' dann wird angezeigt

2. wenn Seitenname z.B. 'Linux Suse_irgend-was.htm' dann wird nicht angezeigt

und Meldung: Fehler: Datei nicht gefunden (Seitenfehler).

Das Problem tritt schon auf wenn der Ordnername mit Leerzeichen ist.

Im geöffneten FF 'Datei öffnen' dann werden beide Varianten geöffnet
auch wenn Ordner Leerzeichen hat.

Wie kann man es ändern. Wer weiß es?

mfg Peter i.d.R
 

nollsa

Advanced Hacker
In einer Url gibt es grundsätzlich keine Leerzeichen und Umlaute. In Dateibezeichnungen und Ordnerbezeichnungen können Leerzeichen enthalten sein.
 
OP
P

Peter i.d.R.

Newbie
Dieses Prob noch mal genauer untersucht und zu den folgenden Erkenntnissen gekommen:

unter XP:
=========

Alle Dateien mit Zeichenkodierung Westlich(ISO 8859-1) lassen sich mit FF 1.5.0.1
in den Varianten
- Zeichenkodierung Westlich(ISO 8859-1)
- Ordner mit Leerzeichen
- Dateiname mit Leerzeichen
- Dateiname ohne Leerzeichen
- Ordner ohne Leerzeichen
- Dateiname mit Leerzeichen
- Dateiname ohne Leerzeichen
durch Rechtsklick auf die Datei *htm. und 'öffnen mit...' 'FF' durch FF anzeigen.
Dabei spielt es keine Rolle ob im Dateinamen zusätzlich noch Umlaute enthalten sind.
(nebenbei: IE machts auch)
So sollte es auch mit FF unter Suse 10.0 funktionieren.
Mit dem Web-Browser Konqueror funktioniert es ja dort auch.
Leider bringt bei Verwendung des FF dieser dann immer die Seitenfehlermeldung
und zeigt ausser dieser in einigen Tabs nichts weiter an.

Es handelt sich ausschliesslich um abgelegte htm-Seiten in Ordnern und nicht um url's.

unter Suse 10.0:
================

Dateien befinden sich auf einer fat32 Partition (Datenschaukel).

/windows/L/www/iso/Neuer_Ordner/Leerzeichen/htm-Dateien öffnen mit FF 1_5_0_1.htm
==> Konqueror-OK;
==> FF-keine Anzeige, Ladefehler;5x

/windows/L/www/iso/Neuer_Ordner/ohneLeerzeichen/htm-Dateien_öffnen_mit_FF_1_5_0_1.htm
==> Konqueror-OK;
==> FF-OK;
==> Umlaut im Dateinamen stört nicht


/windows/L/www/iso/Neuer Ordner/ohneLeerzeichen/htm-Dateien_öffnen_mit_FF_1_5_0_1.htm
==> Konqueror-OK;
==> FF-keine Anzeige, Ladefehler;2x

/windows/L/www/iso/Neuer Ordner/Leerzeichen/htm-Dateien öffnen mit FF 1_5_0_1.htm
==> Konqueror-OK;
==> FF-keine Anzeige, Ladefehler;6x


Ladefehler: immer Anzahl der Leerzeichen + 1
+1 könnte hier Umlaut sei?

andersrum:

Im geöffneten FF aufrufen: 'Datei/Datei öffnen...'
/windows/L/www/iso/Neuer Ordner/Leerzeichen/htm-Dateien öffnen mit FF 1_5_0_1.htm

==> Hier wird die aufgerufene Datei wie folgt angezeigt:
#file:///windows/L/www/iso/Neuer%20Ordner/Leerzeichen/htm-Dateien%20%C3%B6ffnen%20mit%20FF%201_5_0_1.htm#
# sonst erscheint als Link!

Im geöffneten Konqueror aufrufen: 'Dokument/Adresse aufrufen...'
/windows/L/www/iso/Neuer Ordner/Leerzeichen/htm-Dateien öffnen mit FF 1_5_0_1.htm

==> Hier wird die aufgerufene Datei wie folgt angezeigt:
/windows/L/www/iso/Neuer Ordner/Leerzeichen/htm-Dateien öffnen mit FF 1_5_0_1.htm

Weshalb kanns der Konqueror und der FF unter XP und FF unter Suse 10.0 nicht!
Das war meine Frage.

Kanns an der Installation von FF liegen die als user durchgeführt wurde.
Aber da wurde ja auch root verlangt.
Übrigens als root erscheint der FF trotz Translationpack nur in englisch.
Muss dass so sein?

Danke für Antworten
mfg Peter i.d.R. :D
 

Grothesk

Ultimate Guru
Übrigens als root erscheint der FF trotz Translationpack nur in englisch.
Muss dass so sein?
Warum merkst du das überhaupt? Es ist verdammt nochmal egal, in welcher Sprache der root-Firefox läuft, weil du den Firefox NIEMALS als root benutzen wirst!
 

panamajo

Guru
Peter i.d.R. schrieb:
Übrigens als root erscheint der FF trotz Translationpack nur in englisch.
Muss dass so sein?

Es muss nicht so sein, ist aber sinnvoll.
Die Default Sprache für root ist en da diverse Administrationsdienste durch andere Lokalität Probleme bekommen könnten (Datumsformat etc.)
 
OP
P

Peter i.d.R.

Newbie
Das mit root war mir nur aufgefallen als linux-newbie.

Mit FF und/oder als root geht man nicht ins WEB, ist mir schon klar gewesen.

Die anderen Sachen wären mir wichtiger.

Danke für die Hinweise!
mfg Peter i.d.R.
 
Oben