Kernel 2.6.4 + Sound + sysfs

trooperle

Newbie
Tach zusammen,
hab nun auch auf den Kernel 2.6.4 upgedatet, hat sogar gut funktioniert ( am Wochenende bin ich noch am 2.6.3er verzweifelt )

Booten klappt auch so mehr oder weniger gut, hab folgende Pakete noch upgedatet

module-init-tools
LVM 2.0
mkinitrd-1.0.130
device-mapper

Auch das sysfs konnte ich beim ersten mal problemlos mounten, hab es wie folgt in der fstab eingetragen
sysfs /sys sysfs defaults 0 0

Leider kommt beim booten die Fehlermeldung
mount: sysfs already mounted or /sys busy

kann es auch manuell nachher nicht mounten, aber ein fuser auf /sys liefert mir keine prozesse die darauf zugreifen.
Vermutung: Der LVM-Treiber greift wahrscheinlich vor dem mount bereits drauf zu obwohl es nicht gemountet ist. Die Verzeichnisstruktur unter /sys existiert auch...
Irgendwelche Ideen:

Was anderes: Das Sound-Modul kann ich ned laden, ich hab nachgesehen, der Name hat sich nicht geändert

modprobe snd_intel8x0 liefert
WARNING: Error inserting snd (/lib/modules/2.6.4-0-athlon/kernel/sound/core/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_seq_device (/lib/modules/2.6.4-0-athlon/kernel/sound/core/seq/snd-seq-device.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_rawmidi (/lib/modules/2.6.4-0-athlon/kernel/sound/core/snd-rawmidi.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_mpu401_uart (/lib/modules/2.6.4-0-athlon/kernel/sound/drivers/mpu401/snd-mpu401-uart.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.4-0-athlon/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.4-0-athlon/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.4-0-athlon/kernel/sound/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.4-0-athlon/kernel/sound/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg liefert ziemlich viel Output, siehe Textdatei unter

http://www.huepffrosch.de/tmp.txt


Jemand ne Idee wie ich den sound wieder ans rennen krieg?
Hab mir die Howtos von Thomas Hertweck und das Post-Halloween Dokument schon durchgelesen und nix gefunden, aber vielleicht hab ich ja auch was übersehn.

Muss sonst noch was an Paketen aktualisiert werden? Hab ich irgendwas übersehen?

Bestenk Dank vorab
Trooperle
 
A

Anonymous

Gast
Ich glaube, eine Sache hast du bei Thomas Hertweck übersehen. Hab zwar keine Ahnung ob dir das weiterhilft, aber mal sehen:

Nach Umstellung von Kernel 2.4 auf 2.6 funktioniert der Sound/USB/Firewire nicht mehr:
Dieses Problem wird eventuell durch falsche Namen oder Optionen in der Datei /etc/modprobe.conf verursacht. Wie bereits früher erwähnt, bedarf es unter Umständen nach dem Konvertieren der Datei modules.conf einer manuellen Anpassung von /etc/modprobe.conf. Dabei sind z.B. alle Präfixe "snd_" bei den Optionen zu ALSA-Modulen zu entfernen. USB- oder Firewire-Module haben teilweise ihre Namen geändert.

Gruss,

Markus
 

Gimpel

Guru
hi!

für sysfs brauchst du keinen eintrag in der fstab, einfach ordner anlegen--fertig! das liegt ja im / und ist damit bereits gemountet!

übrigens funktioniert derzeit nur das paket von kraxel! das bis auf den bootsplash 1a..
die von mantel funzen nicht richtig (sound ssh...)

überhaupt: hast du ein rpm-paket genommen, die quellen vom mantel, oder hast du dir nen vanilla-kernel zusammegeschraubt? bei letzterem viel spass auf suse!

und bitte lies das howto richtig!!! da steht geschrieben dass man bei allem was alsa betrifft das führende "snd_" aus der /etc/modprobe.config händisch löschen muss, dann funzt das (und zwar saugeil...find den 2.6.4er echt klasse...bootet bei mir fehlerfrei)
das steht auch im zitat von markus! der hats gleich gefunden...

lies einfach das howto nochmal richtig!

:wink:
 

jbjoret

Newbie
Gimpel schrieb:
hi!

für sysfs brauchst du keinen eintrag in der fstab, einfach ordner anlegen--fertig! das liegt ja im / und ist damit bereits gemountet!

übrigens funktioniert derzeit nur das paket von kraxel! das bis auf den bootsplash 1a..
die von mantel funzen nicht richtig (sound ssh...)

überhaupt: hast du ein rpm-paket genommen, die quellen vom mantel, oder hast du dir nen vanilla-kernel zusammegeschraubt? bei letzterem viel spass auf suse!

und bitte lies das howto richtig!!! da steht geschrieben dass man bei allem was alsa betrifft das führende "snd_" aus der /etc/modprobe.config händisch löschen muss, dann funzt das (und zwar saugeil...find den 2.6.4er echt klasse...bootet bei mir fehlerfrei)
das steht auch im zitat von markus! der hats gleich gefunden...

lies einfach das howto nochmal richtig!

:wink:

Welches how-to ? Unter Mantel finde ich nichts, was wie ein how-to aussieht. Ist das mit "snd_" das einzige was zu tun ist ? Ausser Ton ging bei mit das Updaten auf 2.6.4-0 sehr gut
 

trooperle

Newbie
Jajaja, wer lesen kann ist klar im Vorteil.

Ich dachte ich müsste den snd- Präfix bei den modulen entfernen, aber dann fand er die modole ned mehr :oops:

Klappt jetzt fast wunderbar.
Einziges Problem: Mein System bootet nimmer, da ich Probleme mit LVM kriege.. aber dazu gibts gleich nen anderes Posting :) ( bzw ich such erstmal was hier im Forum rum )

Trooperle
 
Oben