• Der Linux-Club wurde auf eine modernere Forensoftware umgestellt und hat auch optisch einen neuen Anstrich erhalten. Weitere Details findest du im Beitrag "Update der Forensoftware 2022".

PPTPD mit Windows Netzwerkumgebung

Spunky

Newbie
Nach dem ich das Problem mit MPPE unter Suse 8.1 gelöst hatte stehe ich nun vor einem neuen Problem!

Unter Suse 9.0 hatte ich in meiner Samba- Konfiguration den WINS-Support aktiviert! und in der PPTPD - config die IP meines Rechners für den Wins-Server angegeben, damit man sich auch per Namen suchen kann und nicht nur per IP.

Unter Suse 8.1 funzt das aber nicht obwohl ich die Configs alles so übernommen habe und es sich bei PPTPD auch um die gleiche Version handelt!

Ich habe herausgefunden das PPTPD unter 8.1 keinen "arp-Eintrag" schreibt obwohl "proxyarp" eingeschaltet ist.

Unter linuxquestions.org meinte mal jemand man müsste "bcrelay" aktiviert haben um in der Netzwerkumgebung nach Namen suchen zu können. Das akzeptiert PPTPD bei mir aber nicht und gibt eine Fehlermeldung aus! Außerdem habe ich es unter SuSE 9.0 auch nicht aktiviert.

Ich vermute das es an dem "arp-Eintrag" liegt und deswegen der WINS-Server nicht gefunden wird. Weiss jemand wodran es liegt und wieso dieser Eintrag nicht geschrieben wird ?
 

Bonsai

Advanced Hacker
Mache in der Sektion Samba mal einen neuen Thread, da gehört er hin, und gib vor allem mal Deine Sambaversion an.
 

jado

Member
Ich geh mal davon aus, dass hier der SAMBA-Wins-Server läuft
und nur die Clients, die sich über das VPN einwählen, den Wins-Server
nicht finden.
Wenn dem so ist, dann ist es ein generelles Netzwerkproblem und
kein Samba-spezifisches.

@Spunky: können deine Clients den Wins-Server pingen??


greez
 

Spunky

Newbie
Das Problem hat sich bereits gelöst. Es lag tatsächlich nicht an Samba sondern einfach nur daran das die Netzwerkkarte noch eine zweite IP im gleichen Adressbereich wie die VPN-Clients benötigte! Jetzt funzt alles wunderbar !
 
Oben