Scanner PRIMAX 4800 Direct

Hayabusa

Newbie
Hi,

Gibt es eine Möglichkeit den Scanner dazu zu bewegen das zu tun was er soll, nämlich scannen. Habe schon alles versucht. SANE neu installiert, KOOKA insatlliert, Plustek Treiber installiert. Ich finde aber die dazugehörigen "Backend" Ordner nicht, in dem die Konfigurationsdatei ist.

Eine zweite Möglichkeit wäre den Scanner zu wechseln - SCSI Scanner Mustek MFS 6000CX - da habe ich aber das Problem, dass er an der SCSI Schnittstelle nicht erkannt wird.

Vielleicht kann mir wer helfen einen der beiden zum Laufen zu bringen. Bin erst seit 4 Wochen auf LINUX SUSE 9.0 umgestiegen und habe über Euer Forum das System für meine Bedürfnisse hergerichtet, nur bei den Scannern muss ich leider passen. :cry:

Liebe Grüße Hayabusa
 

misiu

Moderator
Teammitglied
Hayabusa schrieb:
Hi,

Gibt es eine Möglichkeit den Scanner dazu zu bewegen das zu tun was er soll, nämlich scannen. Habe schon alles versucht. SANE neu installiert, KOOKA insatlliert, Plustek Treiber installiert. Ich finde aber die dazugehörigen "Backend" Ordner nicht, in dem die Konfigurationsdatei ist.

Eine zweite Möglichkeit wäre den Scanner zu wechseln - SCSI Scanner Mustek MFS 6000CX - da habe ich aber das Problem, dass er an der SCSI Schnittstelle nicht erkannt wird.

Vielleicht kann mir wer helfen einen der beiden zum Laufen zu bringen. Bin erst seit 4 Wochen auf LINUX SUSE 9.0 umgestiegen und habe über Euer Forum das System für meine Bedürfnisse hergerichtet, nur bei den Scannern muss ich leider passen. :cry:

Liebe Grüße Hayabusa

Bei SuSE: /etc/sane.d
/etc/sane.d/plustek.conf

Ist der Primax USB oder Parallelport?
Hier ist der in der Liste durfte also funktionieren
(warscheinlich mit dem Plustek-Treiber)
http://www.gjaeger.de/scanner/plustek.html

MfG
misiu
 

Timemaster

Member
Ist der Primax USB oder Parallelport?

Parallel. Ist ein Uralt-Teil - damals gab's noch gar kein USB.

Hier ist der in der Liste durfte also funktionieren
(warscheinlich mit dem Plustek-Treiber)

Wie kommt man denn an diesen Treiber?

Wenn ich versuche, den über YaST (SuSE 9.0) einzurichten, wird kein SCSI-Scaner erkannt und YaST sagt, ich soll aus der "unten angezeigten Liste" wählen... das Feld, wo die Liste sein soll, ist aber leer. :-/

Tim
 

misiu

Moderator
Teammitglied
Timemaster schrieb:
Ist der Primax USB oder Parallelport?

Parallel. Ist ein Uralt-Teil - damals gab's noch gar kein USB.

Hier ist der in der Liste durfte also funktionieren
(warscheinlich mit dem Plustek-Treiber)

Wie kommt man denn an diesen Treiber?

Wenn ich versuche, den über YaST (SuSE 9.0) einzurichten, wird kein SCSI-Scaner erkannt und YaST sagt, ich soll aus der "unten angezeigten Liste" wählen... das Feld, wo die Liste sein soll, ist aber leer. :-/

Tim

Das ist alles schon drin, muss nur auskommentiert werden.
erst in /etc/sane.d/dll.conf:
#
#
# SANE Dynamic library loader config
# written by YaST2, Mon Feb 2 22:22:24 2004
#........den Doppelkreuz rausnehmen
plustek
#primax
# scanwit
# v4l2
# viceo

# EOF

Dann evtl. die editieren:
/etc/sane.d/plustek.conf

Weitere Infos:
http://www.gjaeger.de/scanner/howtos/Installationsanweisung.txt
http://www.gjaeger.de/scanner/plustek.html
http://portal.suse.com/sdb/de/1997/03/scanner.html

evtl. müssen noch Module geladen weden
in /etc/modules.conf

MfG
misiu
 

Timemaster

Member
Das ist alles schon drin, muss nur auskommentiert werden.
erst in /etc/sane.d/dll.conf:

Okay, das habe ich gefunden und "plustek" auskommentiert. "primax" ist aber nicht in der Liste.

Ändern tut das allerdings nichts. YaST erkennt nach wie vor keinen SCSI Scanner, und die Auswahlliste ist und belibt leer.

Dann evtl. die editieren:
/etc/sane.d/plustek.conf

Was genau müßte man denn da ändern?

evtl. müssen noch Module geladen weden
in /etc/modules.conf

Gleiche Frage: was genau müßte da editiert werden?

Thx,
Tim
 

Timemaster

Member
Timemaster schrieb:
YaST erkennt nach wie vor keinen SCSI Scanner, und die Auswahlliste ist und bleibt leer.

Okay, ich gebe zu, hier zeigt sich, daß ich Newbie bin... Habe jetzt auch kapiert, daß Parallel-Port und SCSI nicht dasselbe ist (was davon ausgegegangen, weil YaST nur dies alternativ zu USB anbietet) - und daß Parallel sich nicht automatisch erkennen läßt.

Dennoch die Frage (mal ausgehend davon, daß der Treieber installiert ist) - wie scanne ich mit mit meinem "Primax 4800 direct 30 bit"?

Tim
 
Hallo,

Timemaster schrieb:
Dennoch die Frage (mal ausgehend davon, daß der Treieber installiert ist) - wie scanne ich mit mit meinem "Primax 4800 direct 30 bit"?

erstmal, bei solchen Scannern, vergiss YAST. Wenn du es
tatsächlich geschafft hast, den Treiber richtig zu laden, sollte
es relativ einfach sein mit z.b. xscanimage zu scannen.

wie bereits oben beschrieben, muss in Deiner
/etc/sane.d/dll.conf die Linie
plustek ohne führendes # stehen.

Wenn der Treiber pt_drv richtig geladen worden ist, solltes Du unter
/proc/pt_drv einige Einträge finden UND scanimage -L sollte
die sagen, dass der Scanner da ist. Kannst Du alle Punkte als
abgehakt betrachten, ruf einfach mal xscanimage auf...

Viel Erfolg,
Gerhard
 

Timemaster

Member
Moin!

erstmal, bei solchen Scannern, vergiss YAST.

Okaaay...

Wenn du es
tatsächlich geschafft hast, den Treiber richtig zu laden

Wie schaffe ich das denn?

wie bereits oben beschrieben, muss in Deiner
/etc/sane.d/dll.conf die Linie
plustek ohne führendes # stehen.

Ist der Fall.

Wenn der Treiber pt_drv richtig geladen worden ist

Ist offenbar nicht der Fall, denn...

solltes Du unter
/proc/pt_drv einige Einträge finden

Es gibt kein pt_drv

UND scanimage -L sollte
die sagen, dass der Scanner da ist.

Es sagt mir:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


Danke... aber ich fürchte, es hilft nur zurück zu Windoof oder zu Geld kommen & neuen Scanner kaufen. :-/

Tim
 
Timemaster schrieb:
Wenn du es
tatsächlich geschafft hast, den Treiber richtig zu laden
Wie schaffe ich das denn?

Also im Prinzip ist das nicht so schwer, schau mal unter:
http://www.gjaeger.de/scanner/misc/plustek-old.html

dort speziell die Downloads Sektion und natürlich die Installations Sektion.
Evtl. solltest Du das folgende auch mal lesen:
http://www.gjaeger.de/scanner/howtos/InstallationsanweisungDe/InstallationsanweisungDe.html

Da ist viel Info enthalten, wie Du weiterkommen kannst. Leider steht
nirgends was für einen Kernel und welche SANE Version Du hast...


Danke... aber ich fürchte, es hilft nur zurück zu Windoof oder zu Geld kommen & neuen Scanner kaufen. :-/

Naja, ein Fehler wäre es nicht, aber gleich aufgeben ;)

Grüsse,
Gerhard
 

Timemaster

Member
scanner_freak schrieb:
Also im Prinzip ist das nicht so schwer

Offenbar doch...


Danke für die Links, aber die stehen oben schon. Helfen mir leider kein Stück weiter, sonst hätte ich hier sicher nicht gefragt.

Leider steht
nirgends was für einen Kernel und welche SANE Version Du hast...

Wurde bisher auch nicht nach gefragt.
SANE: 1.0.10-243
Kernel: 2.4.21-226

Naja, ein Fehler wäre es nicht, aber gleich aufgeben ;)

Je nun, ich gebe ja nicht "gleich" auf sondern nachdem ich alles mir mögliche probiert habe und selbst Experten keinen Rat wissen.

Gruß,
Tim
 
Moin,

Timemaster schrieb:
Danke für die Links, aber die stehen oben schon. Helfen mir leider kein Stück weiter, sonst hätte ich hier sicher nicht gefragt.
wo hängst Du genau?

Timemaster schrieb:
Wurde bisher auch nicht nach gefragt.
SANE: 1.0.10-243
Kernel: 2.4.21-226

Also laut Liste sollte das Modul mit der Nummer 0_42_9 zu deiner SANE
Installation passen, also das Teilherunterladen.

dann:

Code:
grml@pappnase:~>cd /tmp
grml@pappnase:/tmp>mkdir scanner
grml@pappnase:/tmp/>cd scanner
grml@pappnase:/tmp/scanner>

den Tar-Ball nach /tmp/scanner kopieren, dann

Code:
grml@pappnase:/tmp/scanner>tar -xvzf plustek-module-0_42_9.tar.gz
plustek_driver/src/dac.c
plustek_driver/src/detect.c
plustek_driver/src/genericio.c
plustek_driver/src/image.c
plustek_driver/src/io.c
plustek_driver/src/map.c
plustek_driver/src/misc.c
plustek_driver/src/models.c
plustek_driver/src/motor.c
plustek_driver/src/p12.c
plustek_driver/src/p12ccd.c
plustek_driver/src/p48xx.c
plustek_driver/src/p9636.c
plustek_driver/src/procfs.c
plustek_driver/src/ptdrv.c
plustek_driver/src/scale.c
plustek_driver/src/tpa.c
plustek_driver/h/plustek_dbg.h
plustek_driver/h/plustek_hwdefs.h
plustek_driver/h/plustek_procs.h
plustek_driver/h/plustek_scan.h
plustek_driver/h/plustek_scandata.h
plustek_driver/h/plustek_sysdep.h
plustek_driver/h/plustek_types.h
plustek_driver/COPYING
plustek_driver/ChangeLog
plustek_driver/INSTALL
plustek_driver/INSTALL.GER
plustek_driver/FAQ
plustek_driver/README
plustek_driver/BUILD
plustek_driver/TEST.txt
plustek_driver/TODO
plustek_driver/Makefile
plustek_driver/VERSION0
plustek_driver/VERSION1
./plustek-share.h

grml@pappnase:/tmp/scanner>cd plustek_driver
grml@pappnase:/tmp/scanner/plustek_driver>make all

dann wird der Treiber erstellt, Du solltest aber die Kernelquellen
installiert haben!!!
Die weiteren Schritte musst Du als Root User durchführen:

Code:
grml@pappnase:/tmp/scanner/plustek_driver# make install
mkdir -p /lib/modules/2.4.21/misc
install -c -m "644" pt_drv.o /lib/modules/2.4.21/misc
/sbin/depmod -a
grml@pappnase:/tmp/scanner/plustek_driver# make load

So das wars, der Scanner muss angeschlossen sein, der Port
sich im EPP oder SPP Modus befinden (kein ECP)...

Grüsse,
Gerhard
 
Oben