[solved] Kompilieren verweigert?

A

Anonymous

Gast
Hallo

folgendes Problem bei Suse 9.0 Prof:

Als Root eingelogt und egal in welchen verzeichnis. habe /local ... /home /root und auch dort in dem ich es als final installieren wollte getestet /usr/local/share.

Programm kompilieren mit ./configure anstosse kommt:
Permission denied!

Rechte überprüfung alles auff 777 gesetzt Ausführrechte.

gruppe root
users root

Das passiert bei mehreren Programmen auch mit sh./configure

Permission denied.

Das kann ja nicht sein das SUSE hier verweigert als root Programme zu kompilieren.
 

moenk

Administrator
Teammitglied
Nö, also kompilieren und installieren aus Tarballs geht wohl. Ich mache das immer so dass ich mir die im /root entpacke weil ich das ja eh als root machen muss. Schreib doch mal was Du da genau entpackst und was Du dann noch so eingibst.
 

willy101

Newbie
Hallo Gast,

hm..., nur so ne Idee ...

Ist dein /usr/local/share bzw. das Verzeichnis in dem du ./configure ausführst auf einer eigenen Festplatte/Partition?

wenn ja, hat der entsprechende Eintrag in der /etc/fstab ein "exec" ?

Kannst du andere Programme bzw. Skripte in diesem Verzeichnis starten oder funktioniert nur das ./configure nicht?

willy
 
OP
A

Anonymous

Gast
Also meine konfiguration sieht folgendermassen aus:

Laptop 600mhz 128MB
40GB Platte

350 Swap Primär
5000MB Root Primär
6000MB Home Logisch
10000MB usr Logisch
rest local Logisch

und egal wo ich versuche zu Kompilieren eine der Fehlermeldungen ist C-Compiler fehler und die andere Permission denied als Root.

Versuche den genauen Wortlaut nochmal zu bekommen Sorry...
 

nny

Member
zufällig gefunden, vielleicht hilft das ja
http://www.linuxquestions.org/questions/archive/1/2003/10/4/107075
 

darthmaul

Newbie
Hiernochmal die genaue ausgabe an der Console:


coruscant:/local/cdshare/Software_INet/pwm2/pwm # ls
. INSTALL TODO configure mkrun subdirs
.. Makefile.am VERSION configure.files po
AUTHORS Makefile.cvs acinclude.m4 configure.in pwm
BUGS Makefile.in aclocal.m4 configure.in.in pwm.lsm
COPYING NEWS admin doc pwm.spec
ChangeLog README config.h.in fileformat stamp-h.in
coruscant:/local/cdshare/Software_INet/pwm2/pwm # ./configure
bash: ./configure: /bin/sh: bad interpreter: Permission denied
coruscant:/local/cdshare/Software_INet/pwm2/pwm #

oder aber mit dem anderen befehl
##################################################################
coruscant:/local/cdshare/Software_INet/pwm2/pwm # sh ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs
.If you meant to cross compile, use `--host'.
See `config.log' for more details.
coruscant:/local/cdshare/Software_INet/pwm2/pwm #

Hoffe es kann jemand damit was anfangen, ich jedenfals bin momentan verzweifelt
 

darthmaul

Newbie
Thanx nny

dein tipp hab ich zu spät gesehn schaut mich aber gut an muss ich probieren nochmals vielen dank :D
 

willy101

Newbie
Hallo darthmaul,

/local/cdshare/Software_INet/pwm2/pwm

cdshare ? Ist das eventuell read only gemounted?
Wenn du das Problem mit dem Tip von nny nicht lösen kannst poste doch mal deine /etc/fstab.

willy
 
OP
A

Anonymous

Gast
willy101 schrieb:
Ist dein /usr/local/share bzw. das Verzeichnis in dem du ./configure ausführst auf einer eigenen Festplatte/Partition?
wenn ja, hat der entsprechende Eintrag in der /etc/fstab ein "exec" ?
Kannst du andere Programme bzw. Skripte in diesem Verzeichnis starten oder funktioniert nur das ./configure nicht?

Dein Tipp hat bei mir geholfen:
ich konnte ebenfalls keine selbstkompilierten Programme als auch Skripte ausführen, trotz Dateirechten 777 und auch nicht als root.

Der Tipp unter dieser URL brachte keinen Erfolg
http://www.linuxquestions.org/questions/archive/1/2003/10/4/107075

Auf deinen Hinweis, die /etc/fstab zu überprüfen, wär ich wohl nie gekommen.

Vielen Dank, endlich funzt das wieder :D :D :D
 
OP
A

Anonymous

Gast
hi,

hast du die sh installiert? bzw ist die sh in /usr/bin/sh ? Tipp mal whereis sh ein

mfg

Andy
 

Chrittig

Newbie
Hi

also ich habe dasselbe Problem unter Suse 8.2 den tipp unter dem angegeben link habe ich auch ausprobiert.
das hilft bei mir aber nicht

nen freund hat mir folgendes empfohlen:
cd /bin
ln -s bash sh

das hat mich insofern weitergebracht, dass er jetzt sagt: datei oder Verzeichnis nciht gefunden.
ein whereis sh
gibt als antwort

sh: /bin/sh


Was sagt mir das jetzt??

Gruss
Chrittig
 

Chrittig

Newbie
Nur fürs Protokoll:

die lösung war dann ganz einfach: man muss die archive neu entpacken udn dann gehts...

(i9n der Hoffnung das andere vo r dieser Dummheit bewahrt bleiben)

Gruss
Chrittig
 
Oben