[solved] Probleme bei MPlayer installation !?

thomas_g

Newbie
Ich habe mir unter (http://packman.links2linux.de/) den MPlayer als rpm-Paket runtergeladen und bei der Installation bekomme ich immer die Fehlermeldung: libxvidcore.so.4 fehlt !
Wo bekomme ich diese Datei her ? Auf der packman-Homepage gibtst die nicht und auf anderen Seiten z.B. rpmseek.com bin ich auch nicht fündig geworden.

Kann mir jemand einen Tipp geben...

Gruss
Thomas
Mein System: SuSE9.0, i686
 

Bender

Newbie
Bei mir will es nicht so recht klappen. Habe mir diese Datei runtergeladen:

MPlayer-1.0pre3-pm.1.i686.rpm

er sagt ihm fehlen folgende Sachen:

Fehler: Failed dependencies:
libdivxdecore.so.0 is needed by MPlayer-1.0pre3-pm.1
libdivxencore.so.0 is needed by MPlayer-1.0pre3-pm.1
liblzo.so.1 is needed by MPlayer-1.0pre3-pm.1
libsmbclient.so.0 is needed by MPlayer-1.0pre3-pm.1
libtheora.so.0 is needed by MPlayer-1.0pre3-pm.1

nach der installation von:

divx4linux-20030428-0.pm.0.i386.rpm
lzo-1.08-1.pm.0.i586.rpm

sagt er halt folgendes:

Fehler: Failed dependencies:
libsmbclient.so.0 is needed by MPlayer-1.0pre3-pm.1
libtheora.so.0 is needed by MPlayer-1.0pre3-pm.1

Die erste lib kann ich nicht finden und die zweite sagt:

Fehler: Failed dependencies:
libogg >= 1.1 is needed by libtheora-0.0cvs20031122-0.pm.0

Ich also:

linux:/home/bender/Downloads # rpm -i libogg-1.1-0.pm.0.i686.rpm
file /usr/lib/libogg.so.0 from install of libogg-1.1-0.pm.0 conflicts with file from package libogg-1.0-192

Ich dreh bald am Rad... warum ist das so kompliziert?? Oder mache ich was falsch? :)
(Die drei oben genannte Pakete hab' ich auch installiert)
Ich bitte verzweifelt um Hilfe...

Gruß, Bender

edit: Benutze Suse9.0 mit einem Athlon 1000. Da ist i686 doch das Richtige, oder?
 

Andi1

Newbie
Hast du auch vorher alle Binärpakete installiert bevor du MPlayer installiert hast und alle Abhängigkeiten aufgelöst? Bei mir war das auch anfangs, dass dass mit den Abhängigkeiten in einem Teufelskreis endete. Ich habe das dann nur durch systematische Installation hingekriegt und jetz läufts... Pakete die bei Packman nicht erhältlich waren hab ich mir bei rpmseek geholt.
 
hab auch so meine probs , yast installiert die rpm`s nicht mehr , bekomme nur das fenster mit der suchleiste , und das war`s . installationen starten nur noch ab und an mal .. und zu rpmseek , für die meissten sachen gibt`s ja nix für suse 9.0 ... kann ich andere pakete nehmen ?? mplayer ist zwar schon irgendwo auf meinem rechner ... also root installiert , aber woo???
 

Bender

Newbie
@Andi1:

auf rpmseek hab' ich die noch fehlende lib gefunden. Nur wenn ich die installieren will, verlangt er weitere 6 libs, die ich nicht auf den SuSE cds finden kann.
Welche Binärpakete meinst du? Und wie löst man Abhängigkeiten auf? Was ist damit gemeint?
Ich würde mich sehr freuen, wenn du mir auf die Sprünge helfen könntest :D

@torsten1977he:

ich gebe dann immer in der Suchleiste nochmal den Namen des Paketes ein. Dann zeigt er es an und man kann es installieren. Wenn der mplayer schon installiert ist, müsstest du ihn über die konsole einfach starten können.
 
A

Anonymous

Gast
@ Bender

zwecks installation von libogg

nimm mal den befehl
Code:
rpm -Uvh libogg.rpm
(U wie update!!)
:wink:
 

Gimpel

Guru
ooops..der login!

noch @torsten1977he

nimm keine anderen pakete! suse ist da etwas eigen

haut euch mal apt/synaptic drauf, da kann mann packman als quelle hinzufügen und dann hat sich der act mit den abhängigkeiten erledigt
:wink:
 

Andi1

Newbie
@Bender:

Die Binärpakete sind auch bei Packman zu finden. Wenn du bei Packman auf die Seite von Mplayer gehst, dann sind dort unten auf der Seite noch weitere Pakete die du benötigst. Diese solltest du vor der Installation von Mplayer installieren. Mit Abhängigkeiten sind die Dateien gemeint, die bei der Installation in Yast noch fehlen. Das meldet dir ja Yast bei der Installation dass diese u diese Abhängigkeiten nicht erfüllt sind. Des ganze installieren der libs kann schon etwas unübersichtlich werden, da oft neue Abhängigkeiten dazukommen! Da muss man sich einfach durchkämpfen! Nach den fehlenden libs kannst du ja bei Packman und RPMSEEK suchen, aber bevorzugt die libs von Packman nehmen, hatte mit diversen anderen Libs z. B. von Suse so meine Probs! Und wenn du das ganze Abhängigkeitszeugs sparen willst, dann versuch des mal so wie´s Gimpel beschrieben hat, des werde ich jetz dann auch gleich mal testen! :lol: Hoffe geholfen zu haben!
 

ronnebabe

Newbie
Hallo ihr fröhlichen linuxer....!!

habe mir den Mplayer geladen und auch mit allen plugins installiert nur wie starte ich ihn und wo finde ich ihn ......doofe frage ich weiß !!!
habe ihn per RPM installiert Verzeichnisse sind auch alle da nur wie start ich ihn?? kann da jemand helfen??

gruß ronnebabe
 
Oben