[solved] "Spulen" in Videos bei mplayer

wendland

Newbie
Hallo Leute,

mir ist es gelungen, mit mencoder und meiner terratec TV-Karte Fernsehprogramm aufzuzeichnen.
Das Problem ist: Die Videos laufen zwar mit mplayer, lassen sich jedoch nicht "spulen". Mplayer "weiß" nicht, wie lang die Videos sind, liegt es möglicherweise daran? Und wenn ja, wie kann man das ändern? Gibt's eine Möglichkeit, die Meta-Info zu verändern?

Merci
Pascal
 
Teste mal einen anderen Player (z.B. Kaffeine).
Tritt der Fehler dort auch auf?
Damit ich das richtig verstehe, Mplayer erkennt weder, wie lange das Video dauert, noch kannst du die Position im Video mit dem Schieberegler verändern?

Nachtrag: Es scheint bei Packman (hast du überhaupt Suse?) einen defekten Mplayer zu geben, der hier schon häufiger Probleme bereitete:
http://www.linux-club.de/viewtopic.php?t=55766
http://www.linux-club.de/viewtopic.php?t=51937

Nimm ggf. einen anderen Player. Zum Glück gibt es in der Linux-Welt eine reichhaltige Auswahl. Wie wäre es z.B. mit Kaffeine?
 
wendland schrieb:
mir ist es gelungen, mit mencoder und meiner terratec TV-Karte Fernsehprogramm aufzuzeichnen.
Das Problem ist: Die Videos laufen zwar mit mplayer, lassen sich jedoch nicht "spulen". Mplayer "weiß" nicht, wie lang die Videos sind, liegt es möglicherweise daran? Und wenn ja, wie kann man das ändern? Gibt's eine Möglichkeit, die Meta-Info zu verändern?
Nach Aufnehmen des Streams einfach noch nen Index generieren:
Code:
mencoder stream.avi -oac copy -ovc copy -forceidx -o stream-mit-index.avi
Sollte klappen... muss ich immer machen, wenn man SVCDs in AVI kopiert.
 

wendland

Newbie
Griffin schrieb:
Damit ich das richtig verstehe, Mplayer erkennt weder, wie lange das Video dauert, noch kannst du die Position im Video mit dem Schieberegler verändern?

So war es, auch in Kaffeine.
Aber der Tipp mit dem Index anlegen war goldrichtig.
Danke an jengelh :D
 
Oben