[solved] Stapelverarbeitung --> Linux 9.1

pburri

Member
Also, ich hab mal versucht ne stapelverarbeitungs Textdatei zu erstellen... habe ihm die chmod rechte gegeben...
Ausführen tuch ich die ja, wenn ich einfach den Dateiname schreibe...

zB. bei der datei hallo
Code:
$> hallo

Leider funktionierts nicht! Bei den älteren Versionen hats geklappt! Hab ich irgend ein Paket vergessen zu installieren?

Bitte helft mir!
 

admine

Administrator
Teammitglied
Bedeutet, dass das Programm aus dem aktuellen Pfad heraus gestartet wird.
Das Proggi wird nicht auf Grund der Path-Variable gesucht.
 
OP
P

pburri

Member
Ok, jetzt wirds noch a bissel komplizierter:

Laut Hersteller ist das Programm so installiert...Das ganze liegt im verzeichnis /usr/lbin/ .Im nächsten schritt sagt der Hersteller:

Um das Programm auszuführen muss man es einfach aufrufen. Die Datei heisst im Ordner: TD33 und das heisst das ich mit dem Befehl

Code:
TD33

Das Programm starte. Nur das Problem ist, wenn ich dies tue, wird folgendes ausgegeben:

Code:
bash: TD33: Command not found

Muss ich irgendwo noch welche Variablen oder Einträge machen oder so? Ist der Befehl überhaupt richtig? Wie gesagt, eigentlich ist das Programm für eine ältere SuSE Version geschrieben...
 

admine

Administrator
Teammitglied
Schau doch mal, ob /usr/bin in deiner Path-Variable steht.
Wenn nicht, dann ergänzen in der .profile des Users oder in /etc/profile mit

Code:
PATH=$PATH:/usr/bin
export PATH
 
OP
P

pburri

Member
K habs gemacht ^^ Jetzt sagt er:

Code:
bash: usr/lbin/TD33: Datei oder Verzeichnis nicht gefunden

OBWOHL sich die Datei darin befindet...
 
OP
P

pburri

Member
Er sagt immer: Die Datei oder Verzeichnis wurde nicht gefunden... Aber die Datei liegt da drin... Das habe ich noch nie erlebt ehrlich ^^
 

admine

Administrator
Teammitglied
pburri schrieb:
Er sagt immer: Die Datei oder Verzeichnis wurde nicht gefunden... Aber die Datei liegt da drin... Das habe ich noch nie erlebt ehrlich ^^

Was genau hast du noch gemacht ??
Hast du das Script evt. irgendwohin kopiert ??
=> hat es wieder Ausführrechte erhalten?
 
OP
P

pburri

Member
Ich habe:

1. alles installiert
2. alles überprüft
3. pfad gesetzt

sonst nix... hab nix darum herumgefummelt...
Ja, es ist ausführbar!
 
OP
P

pburri

Member
Code:
/usr/sbin:/bin:/usr/bin:/sbin:/usr/X11R6/bin:/usr/lbin:/usr/lbin/TD33

So sieht $PATH aus...
 
Moin pburri,

versuchst Du das Ganze als User aufzurufen? Geh mal als root in das Verzeichniß und führ mal ls -la TD33 aus (wenn die Datei denn so heißt). Dadurch erfährst Du wer Besitzer und Gruppe ist und auch welche Rechte gesetzt sind.
Sollte er dir da erzählen, das die Datei nicht gefunden werden konnte, ist der Name verkehrt geschrieben. Dann schau mit ls -la * welche Dateien oder auch Verzeichniße sich in dem Verzeichniß befinden.
 
OP
P

pburri

Member
Huhu! Also wegen den Rechten hab ich schon geguggt :wink:

Code:
-rwxr-xr-x 1 nobody nogroup 2272740 2000-02-24 16:01 TD33

nobody & nogroup heisst ja das dies jeder benutzer und jede gruppe ausführen kann... oda etwa net? :roll:
 

admine

Administrator
Teammitglied
pburri schrieb:
nobody & nogroup heisst ja das dies jeder benutzer und jede gruppe ausführen kann... oda etwa net? :roll:

Wie ist denn das entstanden ??
Bei der Installation ??
Kannst ja mal mit "chown" einem anderen normalen User+Gruppe das File übergeben.
Mit root kannst es ja dann trotzdem ausführen.

Weiß aber nicht, ob dann was anderes wieder nicht funzt ... :roll:
 
OP
P

pburri

Member
Jo, is während der installation so gegeben...
Mit chown & chgrp hab ich auch schon versucht ^^ Bringt alles nix :roll:
 
Oben