SuSE 10 Pro als Knotenpunkt zwischen Hotspot und Client

tux86

Newbie
Hallöchen.

Erstmal etwas zur Veranschaulichung, damit ihr meine nachfolgenden Wünsche und Probleme verstehen könnt.

problem-linuxclub.png


Nochmal zur deutlicheren Erklärung der bunten Kisten:
  • 1.) Das "Zielobjekt" - derzeit eine Etage tiefer
    2.) Mein PC, der als Gateway/Router wirken soll, an dem ich gerade sitze
    3.) Steht rechts neben mir und ist ein W-LAN Accesspoint (D-Link DWL-2100AP)
    4.) Symbolisch für mehrere Clients. Ein Testobjekt - das Notebook meines Vaters - steht hinter mir auf meinem Tisch

Kommen wir zu den Verbindungen:

  • Mein Rechner (2) ist mit dem W-Lan Router (1) über meinen W-Lan-Stick verbunden -- das funktioniert (sonst könnte ich ja nicht hier posten ;) )
    Mein Rechner (2) ist über ein CAT5-Ethernetkabel mit dem Accesspoint (3) verbunden -- Verbindung stimmt (kann den Router konfigurieren)
    Ein Client (4) ist über eine W-Lan-Karte mit dem Accesspoint (3) verbunden -- funktioniert aber nicht so ganz (= Knackpunkt)

Und nun endlich mein Ziel und das Problem:
Mein PC (2) soll mit einem W-Lan-Router/Hotspot verbunden werden. Das geschieht über den W-Lan-Stick. An meinem PC (2) ist dann der Accesspoint (3) angeschlossen, mit dem sich ein Client (4) verbinden und dadurch im Internet surfen können soll.

Das Problem ist:
Anfangs konnte ich mich noch mit dem Client-Notebook am Accesspoint anmelden und immerhin schonmal auf den lokalen Apache-Server auf meinem PC (2) zugreifen - Internet ging nicht. Jetzt hat sich das alles irgendwie verändert: ich kann mich auch nicht mehr beim Accesspoint anmelden. Ich bräuchte also einen kleinen (und vor allem schnellen) Crashkurs darin, wie ich meiner SuSE das routen beibringe.
Jemand der mir helfen kann? Wenn da noch fragen offen sind: ruhig fragen. Es ist eine total wichtige Sache!

Gruß.

Valentin.
 
Oben