andere Oberflächen auswählen

Hallo,

ich verwende SuSE 9.1 personal (das zum Downloaden) und habe mir mit Yast den xfc-WM geholt.

Leider habe ich bei der grafischen Linux-Anmeldung keine Wahl, welchen WM ich starten will.

Ich habe schon in /etc/sysconfig/windowmanager den eintrag SUSEWM_WM="all" hinzugefügt, was aber auch nichts gebracht hat. Andere passende Einstellungen in Yast habe ich leider auch nicht gefunden.

Bei anderen Linux-Versionen besteht die Möglichkeit, bei der Anmeldung den WM zu wählen. WIe kann ich das bei SuSE einstellen?
 

BirgerS

Member
Ich VERMUTE mal, daß bei dieser "1-CD-Version" keine weiteren WMs dabei sind, oder daß Du nicht alle installiert hast. Schau mal in Yast, ob Du da mehr Möglichkeiten hast - oder such da mal nach anderen WMs.
 
OP
H

Herr Heimlich

Newbie
Danke für die Tipps, aber leider funktioniert das bei mir so nicht :-(

Ich wollte es so machen, wie's in dem anderen Forum beschrieben ist.
Dumm nur, dass es in meiner /etc/opt/kde3/share/config/kdm/kdmrc keinen Eintrag
"HideMenu=True" gibt, den ich dann auf False setzen könnte.
Naja macht ja nichts, hab ich den halt einfach an die entsprechende Stelle hinzugefügt.

Und die /usr/X11R6/lib/X11/xdm/Xsession sieht bei mir auch ein wenig anders aus als dort beschrieben.
Ich hab z.B. einen "*)" - Eintrag. Soll ich den dann rausmachen, so dass an der Stelle nur noch "kde)" und "xfc)" dortsteht?

Schade, dass man das Verhalten von diesem kdm nicht einfach im Kontrollzentrum einstellen kann :-(
 

oc2pus

Ultimate Guru
aus /etc/sysconfig/windowmanager
## Type: string
## Default: all
#
# This is the (space separated) list of window managers for which you
# want to generate the config file. Valid values are:
# "kde", "gnome", "windowmaker", "blackbox", "fvwm", "fvwm2",
# "fvwm95", "bowman", "mwm", "ctwm", "all".
# Default setting is "all" which is for generating files for all wms.
#
SUSEWM_WM="all"

dort trage alle deine WM ein die du haben willst

xfce wird von SuSE etwas stiefmütterlich behandelt und deshalb ist der so nicht integrierbar.
Xfce4 starten
Benutzen Sie startxfce4 um eine Xfce Sitzung zu starten; das beinhaltet das Panel, den Fenstermanager und die Desktophintergrund-Verwaltung. Alle Programme, oder symbolische Links zu Programmen, die sich in ~/Desktop/Autostart/ befinden, werden automatisch von startxfce4 mitgestartet.

Um startxfce4 anzupassen, kopieren Sie ${sysconfdir}/xfce4/xinitrc in Ihren eigenen ~/.xfce4/ Ordner und passen diese Datei an. Wenn Sie aus dem Quellcode installieren, zeigt ${sysconfdir} auf /usr/local/etc, bei binären Paketen ist es oft /etc.

Alternativ können Sie auch Ihr eigene ~/.xinitrc bzw. ~/.xsession Datei erstellen, wenn Sie einen grafischen Loginmanager nutzen.

d.h du kannst in deiner ~/.xinitrc den xfce eintragen (schau dir die anderen Einträge an) WINDOWMANAGER=xfce ==> startxfce wird aufgerufen ;)
 

Yogibär

Member
Habe ein ähnliches Problem wie Herr Heimlich Nachdem ich den KDE
auf 3.4 geupdated habe, erschien beim Anmeldebildschirm nicht mehr Gnome zur Auswahl. Gnome war aber vorhanden, denn nach - startx gnome - konnte ich Gnome auch starten, es fehlte aber wie gesagt der Eintrag des Login-Managers.
Ich kann mich erinnern, dass ich bei SuSE 8.xx über Yast auch andere Windowmanager komfortabel eintragen konnte,bei SUSE 9.2 habe ich aber bisher nichts gefunden. Vielleicht sehe ich aber den Wald vor lauter Bäumen nicht.
Kann übrigens die nächsten 14 Tage wegen Urlaubs nicht antworten!

Gruß an alle Linuxer!

Pentium 4 3,0 GHz - 1024 MB RAM - Asus Geforce 6600 GT - SuSE 9.2
 

Yehudi

Guru
Hallo beim Benutzerwechsel, wird Gnome und KDE nicht mehr aufgeführt.
Es werden folgende Möglichkeiten angeboten: Standard, Benutzerdefiniert (vorherige), MWM,TWM.
Das war es. IhmSelbst seinen Befehl habe ich schon ausgeführt, oc2pus seine oben aufgeführte Zeile kann ich jedoch nicht finden. (MC)
 
Oben