• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

Gelöst Bluetooth Kopfhörer erscheint nicht als Ausgabegerät

marbas13

Hacker
Hallo!
ich nutze openSUSE Tumbleweed mit KDE.
Aktuell kann ich meinen über Bluettoth verbundenen Kopfhörer nicht als Audiogerät auswählen also kein Audio über den Kopfhörer abspielen.
Ich habe den Kopfhörer aus der Bluetoothgeräteliste entfernt und neu verbunden.
"Früher" (ich weiß nicht mehr wann, aber auf dem gleichen System) hat sich die Soundausgabe automatisch von Line-out auf Kopfhörer umgestellt, wenn ich ihn verbunden habe.
Ich habe ihn länger nicht benutzt, daher weiß ich nicht seit wann das Problem existiert.
Hat jemand einen Tipp für mich, wie ich den Kopfhörer als Ausgabegerät hinzufügen kann?
Vielen dank und viele Grüße
 

susejunky

Moderator
Teammitglied
Hallo marbas13,

verwendest Du pulseaudio oder pipewire als Sound-Server?

Bitte zeige das Ergebnis von
Code:
inxi -A -xxx

Sollte inxi auf Deinem System noch nicht installiert sein, kannst Du es (als "root" in einer Konsole) mit
Code:
zypper in inxi
installieren.

Viele Grüße

susejunky
 
OP
M

marbas13

Hacker
@susejunky
Code:
inxi -A -xxx
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 9 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
    class-ID: 0403
  Sound API: ALSA v: k6.1.2-1-default running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Offenbar beides?!
 
Zuletzt bearbeitet:

susejunky

Moderator
Teammitglied
Hallo marbas13,

Offenbar beides?!

das ist seltsam.

Wenn ich mich richtig erinnere, dann musste ich pulseaudio deinstallieren, um pipewire installieren zu können. Allerdings bin ich schon auf pipewire umgestiegen, bevor es zum Standard-Audioserver in Tumbleweed wurde.

Auf meinem System ist nur pipewire als Sound-Server aktiv:
Code:
> inxi -A
Audio:
  Device-1: Intel CM238 HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.2-1-default running: yes
  Sound Server-1: PipeWire v: 0.3.63 running: yes
>

Zur Steuerung der Audio-Geräte verwende ich pavucontrol-qt.

Meine Bluetooth-Headsets lassen sich problemlos koppeln und ich kann in pavucontrol-qt zwischen den Ausgabegeräten eingebauter Lautsprecher und Headset wählen.

Ich denke es wäre einen Versuch wert, sich für einen Sound-Server (pulseaudio ODER pipewire) zu entscheiden und den anderen zu deinstallieren.

Viele Grüße

susejunky
 
OP
M

marbas13

Hacker
Hallo @susejunky ,
wie deinstalliere ich denn einen der beiden Sound-Server und welchen soll ich am besten de-installieren?
Viele Grüße
Marco
 

susejunky

Moderator
Teammitglied
Hallo marbas13 ,

... welchen soll ich am besten de-installieren?

ich selbst habe keine besonderen Anforderungen an Audio, daher kann ich Dir nicht sagen, welcher Sound-Server der "bessere" ist.

Mit
Code:
zypper rm pulseaudio
bzw.
Code:
zypper rm pipewire
kannst Du (als "root" in einer Konsole) einen der Sound-Server entfernen. Wenn Du alle, aufgrund des Löschens nicht mehr benötigten Pakete mit löschen willst, dann verwende
Code:
zypper rm -u PAKETNAME

Viele Grüße

susejunky
 
Guck mal ob bei dir pipewire-pulse (heißt zumindest unter debian so) installiert ist. Das würde zumindest erklären warum bei dir beides aufgelistet ist. Wenn bei dir auch pavucontrol installiert ist, kannst Du den verwenden um Audio zu steuern. Schau mal im Soundmixer unter "Ausgabegeräte" nach ob da evtl. dein Bluetooth auftaucht, ansonsten auch mal unter "Konfiguration". Achso und libspa-0.2-bluetooth und pipewire-audio-client-libraries (so zumindest unter debian benannt) könnten helfen.
 
OP
M

marbas13

Hacker
@Geier0815
1. pipewire-pulse ist nicht installiert
2. pavucontrol-qt habe ich susejunkys post installiert.
Wenn ich es aufrufe, sehe ich aber nur
  • Internes Audio Analog Stereo (ausgewählt)
  • Internes Audio Digital Stereo (HDMI)
  • Simultaneous output to Internes Audio Digital Stereo (HDMI), Internes Audio Analog Stereo
aber keines für Headphone oder Bluetooth
3. libspa-0.2-bluetooth und pipewire-audio-client-libraries finde ich nicht zum Installieren in YAST.
In wiefern können die helfen?
Wie kann ich sie finden, damit ich sie installieren kann, wenn das
 

Anhänge

  • Screenshot_20230107_204500.png
    Screenshot_20230107_204500.png
    51,2 KB · Aufrufe: 2

tomm.fa

???
Teammitglied
Da hier alles funktioniert, könnten wir mal einen Vergleich starten. Hier meine Daten dazu:

Code:
cat /etc/os-release 
NAME="openSUSE Tumbleweed"
# VERSION="20230106"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20230106"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20230106"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
DOCUMENTATION_URL="https://en.opensuse.org/Portal:Tumbleweed"
LOGO="distributor-logo-Tumbleweed"
Code:
/usr/sbin/rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
Code:
inxi -A -xxx
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Fujitsu
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71
class-ID: 0403
Sound API: ALSA v: k6.1.3-1-default running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Code:
zypper se -si pipewire pulse alsa bluetooth
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                           | Type  | Version      | Arch   | Repository
---+--------------------------------+-------+--------------+--------+-----------------------
i | alsa | Paket | 1.2.8-1.1    | x86_64 | Haupt-Repository (OSS)
i | alsa-oss | Paket | 1.1.8-5.1    | x86_64 | Haupt-Repository (OSS)
i | alsa-plugins | Paket | 1.2.7.1-4.1  | x86_64 | Haupt-Repository (OSS)
i | alsa-plugins-speexrate | Paket | 1.2.7.1-4.1  | x86_64 | Haupt-Repository (OSS)
i | alsa-plugins-upmix | Paket | 1.2.7.1-4.1  | x86_64 | Haupt-Repository (OSS)
i | alsa-topology-conf | Paket | 1.2.5.1-1.5  | noarch | Haupt-Repository (OSS)
i | alsa-ucm-conf | Paket | 1.2.8-1.1    | noarch | Haupt-Repository (OSS)
i | alsa-utils | Paket | 1.2.8-1.1    | x86_64 | Haupt-Repository (OSS)
i | gnome-bluetooth | Paket | 42.5-1.1     | x86_64 | Haupt-Repository (OSS)
i | gnome-bluetooth-lang | Paket | 42.5-1.1     | noarch | Haupt-Repository (OSS)
i | gstreamer-plugin-pipewire | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | kernel-firmware-bluetooth | Paket | 20221216-1.1 | noarch | Haupt-Repository (OSS)
i | kpipewire-imports | Paket | 5.26.5-1.1   | x86_64 | Haupt-Repository (OSS)
i | libbluetooth3 | Paket | 5.66-1.3     | x86_64 | Haupt-Repository (OSS)
i | libgnome-bluetooth-3_0-13 | Paket | 42.5-1.1     | x86_64 | Haupt-Repository (OSS)
i | libgnome-bluetooth-ui-3_0-13 | Paket | 42.5-1.1     | x86_64 | Haupt-Repository (OSS)
i | libKPipeWire5 | Paket | 5.26.5-1.1   | x86_64 | Haupt-Repository (OSS)
i | libKPipeWire5-lang | Paket | 5.26.5-1.1   | noarch | Haupt-Repository (OSS)
i | libKPipeWireRecord5 | Paket | 5.26.5-1.1   | x86_64 | Haupt-Repository (OSS)
i | libpipewire-0_3-0 | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | libpulse-mainloop-glib0 | Paket | 16.1-1.4     | x86_64 | Haupt-Repository (OSS)
i | libpulse0 | Paket | 16.1-1.4     | x86_64 | Haupt-Repository (OSS)
i | NetworkManager-bluetooth | Paket | 1.40.8-1.1   | x86_64 | Haupt-Repository (OSS)
i | pipewire | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | pipewire-alsa | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i+ | pipewire-aptx | Paket | 0.3.63-1.1   | x86_64 | PackMan Repositorium
i | pipewire-lang | Paket | 0.3.63-3.1   | noarch | Haupt-Repository (OSS)
i | pipewire-modules-0_3 | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | pipewire-pulseaudio | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | pipewire-spa-plugins-0_2 | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | pipewire-spa-tools | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | pipewire-tools | Paket | 0.3.63-3.1   | x86_64 | Haupt-Repository (OSS)
i | pulseaudio-setup | Paket | 16.1-1.4     | x86_64 | Haupt-Repository (OSS)
i | pulseaudio-utils | Paket | 16.1-1.4     | x86_64 | Haupt-Repository (OSS)
i | system-user-pulse | Paket | 16.1-1.4     | noarch | Haupt-Repository (OSS)
i | typelib-1_0-GnomeBluetooth-3_0 | Paket | 42.5-1.1     | x86_64 | Haupt-Repository (OSS)

Da ich eigentlich meist GNOME verwende, musste ich erst KDE/Plasma nachinstallieren und die zuvor angezeigten GNOME-Pakete dürften daher nicht von Interesse sein.

Screenshot_20230107_235945.png
 
Zuletzt bearbeitet:

susejunky

Moderator
Teammitglied
Hallo marbas13,

für welchen Sound-Server (pulseaudio ODER pipewire) hast Du Dich entschieden?

Falls Du Dich für pipewire entschieden hast, benötigst Du, zusätzlich zu den von @tomm.fa genannten Paketen, meines Wissens auch noch
Code:
S  | Name              | Type  | Version    | Arch   | Repository
---+-------------------+-------+------------+--------+------------------------
i  | wireplumber       | Paket | 0.4.13-1.1 | x86_64 | openSUSE Tumbleweed Oss
i+ | wireplumber-audio | Paket | 0.4.13-1.1 | noarch | openSUSE Tumbleweed Oss
i  | wireplumber-lang  | Paket | 0.4.13-1.1 | noarch | openSUSE Tumbleweed Oss

Mit
Code:
> systemctl --user status pipewire.service
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: disabled)
     Active: active (running) since Sun 2023-01-08 12:41:36 CET; 2h 48min ago
TriggeredBy: ● pipewire.socket
   Main PID: 1579 (pipewire)
      Tasks: 2 (limit: 4915)
     Memory: 32.7M
        CPU: 8.195s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1579 /usr/bin/pipewire

Jan 08 12:41:36 SYSTEM01 systemd[1269]: Started PipeWire Multimedia Service.
>
kannst Du den Status von pipewire überprüfen und mit
Code:
systemctl --user enable pipewire.service
legst Du fest, dass pipewire bei jedem Login des Benutzers automatisch gestartet wird.

Viele Grüße

susejunky
 

susejunky

Moderator
Teammitglied
Hallo marbas13,

... pavucontrol-qt habe ich installiert.

Wenn ich es aufrufe, sehe ich aber nur
  • Internes Audio Analog Stereo (ausgewählt)
  • Internes Audio Digital Stereo (HDMI)
  • Simultaneous output to Internes Audio Digital Stereo (HDMI), Internes Audio Analog Stereo
welche Geräte zeigt Dir pavucontrol-qt unter dem Reiter "Ausgabegeräte" an (wenn Dein Headset über Bluetooth erfolgreich gekoppelt ist)?

Viele Grüße

susejunky
 
OP
M

marbas13

Hacker
Eigentlich wollte ich gestern Abend gemütlich Tatort gucken und dann war ich so leichtsinnig und habe mich für pipewire entschieden und das pulseaudio Paket entfernt - keine gute Idee;)
Ich habe dann auch nur ein bisschen länger als der Tatort gebraucht, bis ich wieder Ton hatte.
Pulseaudio war wohl sehr tief im System verankert, etliche Programme hatten sich beschwert, dass sie keine Verbindung zum Audioserver mehr herstellen können, es war auch keine Audiokonfiguration mehr möglich.
Ich habe dann auch pipewire deinstalliert und pulseaudio neu installiert.
Nach ein paar Widrigkeiten hatte ich dann wieder Ton mit dem schönen Nebeneffekt, dass auch die Ausgabe über den Bluetooth Kopfhörer wieder geht. Die Ausgabe schaltet nicht wie früher automatisch auf Kopfhörer um, wenn ich ihn verbinde, aber das ist nicht schlimm und kann wahrscheinlich sogar irgendwo konfiguriert werden.
Lessons learned - nicht einfach mal so nebenbei was machen, sondern sich vorher damit auseinander setzen.
@susejunky @Geier0815 @tomm.fa
Danke für eure Hilfe!🍾

Da pipewire das bessere System sein soll: Gibt es eine Anleitung wie man von pulseaudio auf pipewire wechselt?
Nur wenn jemand z.B. einen Link parat hat - ich habe noch nicht danach gesucht.
 
Oben