Cygwin windows client für Linux terminal?

cygent

Newbie
Hallo Leute!
Habe Eure Einträge durchgelesen.
Kann jedoch den Cygwin client nicht zum Laufen bringen.
Habe auf einer Seite XP auf der anderen SuSe 8.0

gdm
xdm

Packete sind installiert. Cygwin runtergeladen und installiert.
Dann folgendes gemacht:
Code:
(1) Auf der Linuxkiste 
-  in /etc/X11/xdm/Xservers eingetragen:
"192.168.1.1:0 foreign"
- in /etc/X11/xdm/Xaccess habe ich folgende Zeile stehen
"* CHOOSER BROADCAST      #blablabla"
- "DisplayManager.requestPort: 0" in /etc/X11/xdm/xdm-config mit ! auskommentiert
- in /etc/X11/gdm/gdm.conf im Abschnitt [xdmcp] die Zeile "Enable=false" zu "Enable=true" ändern 
- X Server beendet und neu startet (mit "init 3" & "init 5") 

(2) Unter Windows 
- Cygwin unter D:\cygwin installiert
- In die PATH Variable den Pfad zu den Cygwin DLLS einfügt(D:\cygwin\bin)

Habe dann startxwin.bat mit folgenden Konfigurationen probiert:
1) start XWin -rootless -nowinkill -unixkill -screen 0 1024x768 -query 192.168.1.5

2) start XWin -screen 0 1024x768 -query 192.168.1.5

3) start XWin

Es wird ein X Fenster gestartet. Das bleibt aber grau mit dem X-Mauszeiger. Sonst kommt nichts. Die obere Leiste von X-Fenster enthält noch den Eintrag "Cygwin/XFree86 - 192.168.1.5"

Das selbe passiert, wenn ich das ganze aus der Eingabeaufforderung starte (von D:\cygwin\bin aus)

Wenn ich cygwin.bat unter D:\cygwin starte, kommt ein schwarzes Fenster mit dem Eintrag
Administrator@hi ~
$

Soweit ich verstehe ist dies die XFree86 Oberfläche in WinXp.
Ich kann mit ssh -X root@192.168.1.5 an den Linux Rechner einloggen und ohne graf. Oberfläche auf dem Linux Rechner von XP Recher aus arbeiten.

Daher nehme ich an, daß bei mir gdm, wdm oder sonstwas nicht richtig konfiguriert sind. Aber was, Leute? Mir ist aufgefallen, daß gdm Verzeichnis unter \var\opt\gnome liegt (sollte es nicht unter /etc/X11/ liegen?) - gmd läßt sich aber auf der Linux Kiste starten. Sehe dann GNOME Anmeldefenster.

Danke Allen ganz herzlich im voraus für die Hilfestellung.
MfG,
cygent
 

moenk

Administrator
Teammitglied
Ich habe bisher immer erstmal überprüft ob der Server überhaupt rangeht und alles soweit funktioniert. Dazu bietet sich XWin an:
http://www.nus.de/x_win_features.html
Das Programm ist zwar ziemlich teuer aber die Demo ist auf jeden Fall für den Test des Application-Servers gut. Man muss nur die IP wissen und als Protokoll XDMCP verwenden.
 
A

Anonymous

Gast
Hi moenk!
Danke Dir für den Hinweis. Werde diese ausprobieren!
 
OP
C

cygent

Newbie
Hi moenk,
habe x-win ausprobiert. Das Ding verhält sich unter XDMCP genauso wie Cygwin. Anderes funkt nicht - wenn ich x-win mit anderen Optionen starte, erscheint Software-Balken in der Windows leiste. Ich kann den aber nicht "öffnen" bzw. maximieren.

Es scheint, daß meine Linux Kiste falsch konfiguriert ist.
Was hat es aug sich, daß mein gdm in einem anderen Verzeichnis plaziert ist (also nicht unter X11)?

Hättest Du andere Vorschläge?

Ciao,
cygent
 

moenk

Administrator
Teammitglied
XWin funktioniert auf Anhieb wenn der Server korrekt ist. Du kannst dann die Session starten. Diverse Dinge können stören: XDMCP hört nicht auf Anfragen von ausserhalb, eine Firewall ist im Weg.
Check mal Punkt 3 in diesen Text und die genannten Einstellungen: http://portal.suse.de/sdb/de/2003/03/tsaupe_export.html
Die Firewall mal temporär abschalten zum Test: SuSEfirewall2 stop
 

moenk

Administrator
Teammitglied
Sind die Hostnamen über die /etc/hosts auflösbar?
Steht sonst irgendwas brauchbares in /var/log/messages ?
 
A

Anonymous

Gast
Habe mich auch ewig mit dem Problem herumgeschlagen und im Prinzip aufgegeben, bis ich VNC gefunden habe.
Kann hier nicht die ganze Installation erklären:
Vorschlag: Auf der SUSE9 und ich denke auch den vorherigen CD's gibt es den VNC-Server.
Der muss auf Linux gestartet werden.
Dann den vncviewer auf den Client laden und dort starten.
Bei mir hat es wunderbar geklappt. Alle Applicationen laufen auf dem Linux-Server unter vnc und die Win-Clients greifen nur via vnc auf den server zu. Einziges Problem: Realtime-Video funktioniert nicht wegen der 'langsamen' Netzverbindung und Töne werden über VNC nicht unterstützt.
 
A

Anonymous

Gast
Habe mich auch ewig mit dem Problem herumgeschlagen und im Prinzip aufgegeben, bis ich VNC gefunden habe.
Kann hier nicht die ganze Installation erklären:
Vorschlag: Auf der SUSE9 und ich denke auch den vorherigen CD's gibt es den VNC-Server.
Der muss auf Linux gestartet werden.
Dann den vncviewer auf den Client laden und dort starten.
Bei mir hat es wunderbar geklappt. Alle Applicationen laufen auf dem Linux-Server unter vnc und die Win-Clients greifen nur via vnc auf den server zu. Einziges Problem: Realtime-Video funktioniert nicht wegen der 'langsamen' Netzverbindung und Töne werden über VNC nicht unterstützt.
 
A

Anonymous

Gast
Mußte auch aufgeben. Würde gern an das Problem ran, habe gerade jedoch keine Zeit.

Werde das vielleicht noch mit SuSe 9.0 Pro probieren, falls was, werde ich auch auf VNC umsteigen.

Ciao,
cygent
 
A

Anonymous

Gast
Verucht es doch mal damit, hat bei mir gut mit Thinstation funktioniert:
http://www.redhat.com/mirrors/LDP/HOWTO/XDMCPHOWTO/procedure.html

Gruß Ingerim

ingerim@gmx.net
 
A

Anonymous

Gast
Verucht es doch mal damit, hat bei mir gut mit Thinstation funktioniert:
http://www.redhat.com/mirrors/LDP/HOWTO/XDMCPHOWTO/procedure.html

Gruß Ingerim

ingerim@gmx.net
 
A

Anonymous

Gast
Hallo,

ich habe folgende Schritte durchgeführt:

1. In der Datei /etc/sysconfig/displaymanger die Zeile DISPLAYMANAGER_REMOTE_ACCESS auf "yes gesetzt.
2. In der Datei /usr/lib/X11/xdm/xdm-config die letzte Zeile DisplayManager.requestPort: 0 mit ! auskomentiert.

Danach init 3, SuSEconfig und wieder init 5.

Evtl. kommt der SuSEconfig auch nach dem init 5. Kann mich nicht mehr so genau dran erinnern.

In CygWin habe ich dann mit dem Befehl export DISPLAY=192.168.1.4:0.0 das Display zugewiesen.

Nach der eingabe von xwin -query 192.168.1.7 (IP-Adresse des Linux Servers) kam dann das grafische Login.

Viel Glück beim nachmachen.


Achim
 

SCT

Member
Das funktioniert alles wunderbar bei mir. Ich würde gerne per Klick auf einen Icon auf dem Windows Rechner Cygwin und gleich "xwin -query <IP-addr> -screen 0" starten, Auf einmal. Das ging bei mir schon mal alles, aber meine eine Platte ist abgeraucht und ich habe das Startscript nicht mehr. Was nicht funktioniert, ist die xwin Zeile in die cygwin.bat reinzuschreiben...

Ciao
SCT
 
Oben