DHCP-Config *Hilfäää*

Status
Für weitere Antworten geschlossen.
Hallo Leute,

auch ich habe mir vorgenommen (gezwungender Maßen) einen LTS aufzusetzten, da ich dies als Abschlussprojekt an meiner Schule demonstrieren möchte.

Nun bin ich also schon einige Tage am rum probieren, aber anscheinend scheitert es bei mir an einem Punkt: DHCP

Ich habe schon unterschiedlichste Konfigurationen ausprobiert und bin bisher am Booten des Clients gescheitert.

Dazu muss man sagen dass ich versuche, einen Client über Diskette zu starten. In meinem Server steckt bloss eine Netzwerkkarte, mit der ich einen Client booten möchte.

Da ich nicht genau weiss, wie so eine dhcp-config genau auszusehen hat (hab eben mehrere Varianten gefunden) wäre es toll wenn jemand ein lauffähiges Beispiel geben könnte.

mfg Wieselflink
 

rolle

Guru
Code:
roland@sv00:~> cat /etc/dhcpd.conf
next-server    192.168.255.100;
option domain-name "sv";
option domain-name-servers 192.168.255.100;
option routers 192.168.255.100;
option netbios-name-servers 192.168.255.100;
option root-path "192.168.255.100:/opt/ltsp/i386";
ddns-update-style none;
default-lease-time 14400;
subnet 192.168.255.0 netmask 255.255.255.0 {
  range 192.168.255.111 192.168.255.119;
  default-lease-time 14400;
  max-lease-time 172800;
}
host sv03 {
  hardware ethernet 00:30:05:7B:B4:78;
  fixed-address 192.168.255.103;
filename "lts/2.6.9-ltsp-3/pxelinux.0";
}
host sv04 {
  hardware ethernet 00:E0:7D:DA:71:7C;
  fixed-address 192.168.255.104;
filename "lts/vmlinuz-2.6.9-ltsp-3";
}
host schlepptop {
  hardware ethernet 00:11:5B:8D:29:8D;
  fixed-address 192.168.255.120;
filename "lts/2.6.9-ltsp-3/pxelinux.0";
}
host sv02 {
  hardware ethernet 00:E0:7D:95:8B:52;
  fixed-address 192.168.255.102;
filename "lts/vmlinuz-2.6.9-ltsp-3";
}
host sv05 {
  hardware ethernet 00:00:E8:58:0E:B9;
  fixed-address 192.168.255.105;
filename "lts/vmlinuz-2.6.9-ltsp-3";
}
 
Erst mal vielen dank rolle für deine Hilfe. Habe die Config einfach mal übernommen:

# dhcpd.conf

next-server 192.168.0.3;
option domain-name "ltsp";
option domain-name-servers 192.168.0.3;
option routers 192.168.0.3;
option netbios-name-servers 192.168.0.3;
option root-path "192.168.0.3:/opt/ltsp/i386";
ddns-update-style none;
default-lease-time 14400;
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.111 192.168.0.119;
default-lease-time 14400;
max-lease-time 172800;
}
host ltspclient {
hardware ethernet 00:11:09:C7:52:FD;
fixed-address 192.168.0.20;
filename "lts/vmlinuz-2.6.9-ltsp-3";
}

Allerdings bekomme ich, wenn ich den dhcp-Dienst starten möchte eine Fehlermeldung, die ich schon öfters gelesen habe:

FEHLERMELDUNG:

Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Wrote 0 deleted host decls to leases file.
Wrote 0 new dynamic host decls to leases file.
Wrote 0 leases to leases file.

No subnet declaration for status (0.0.0.0).
** Ignoring requests on status. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface status is attached. **


Not configured to listen on any interfaces!

If you did not get this software from ftp.isc.org, please
get the latest from ftp.isc.org....



:(

Hat wer ne Ahnung woran das liegen kann?
 
Hallo....

kann es leider nicht genau sagen ... hab einfach neu installiert.

Wahrscheinlich eine andere konfigdatei zerschossen oder so...

Jetzt hab ich noch ein problem beim booten:

DHCP läuft.

Boote mit NVIDIA Boot Agent...Netztwerkkarte bekommt IP etc.----

Irgendwann beim laden hört er auf mit der Fehlermeldung:

######################################
ERROR:

Could not automatically detect the network card.
PCI cards shoult be detected automatically. ISA
cards cannot be detected, so they require the nic
driver to be specified in 'NIC=' parameter to be
passed op the Kernel commandline, usually speci
fied in option-129, in the /etc/dhcpd.conf file. See the
LTSP docs for more info.

Kernel-panic - not syncing: Attempted to kill init!

######################################

Also die Option 129 hab ich in der dhcpd.conf angegeben:


## dhcpd start ##

option domain-name "ltsp";
option domain-name-servers 192.168.0.3;
option routers 192.168.0.3;

#ltsp
next-server 192.168.0.3;

option broadcast-address 192.168.0.3;
option root-path "182.168.0.3:/opt/ltsp/i386";
option option-128 code 128 = string;
option option-129 code 129 = text;
#end ltsp

default-lease-time 14400;
ddns-update-style none;
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.10 192.168.0.20;
default-lease-time 14400;
max-lease-time 172800;

#ltsp
use-host-decl-names on;
option log-servers 169.254.139.29;
filename "lts/2.6.9-ltsp-3/pxelinux.0";

## dhcpd.conf end ##

Oder muss ich den Kartentreiber extra angeben? Der Wer für XSERVER in meiner lts.conf steht nämlich auf "auto".

Hat wer ne Ahnung?

Auszug aus der /var/log/messages - Datei:


linux dhcpd: DHCPACK on 192.168.0.20 to 00:11:09:c7:52:fd via eth0
Mar 19 14:16:13 linux in.tftpd[5392]: tftp: client does not accept options
 
die option-129="text" ist nur die definition der option-129 !
Das gehört ganz nach oben!

Dann kannst du irgendwie mithilfe dieser definierten option angeben um welche Netzwerkkarte es sich handelt!

Oder muss ich den Kartentreiber extra angeben? Der Wer für XSERVER in meiner lts.conf steht nämlich auf "auto".

=> Jetzt muss ich dich leider enttäuschen! Du bist noch gernicht soweit, dass die GraKa angesprochen wird (vom XSERVER)! Der Client kann das Dateisystem (root bzw. / ) nicht finden (es scheitert am mounten) um irgendwas zu starten! Du hast nur den Kernel, der nicht weis um welche Netzwerkkarte es sich handelt!

Wenn es sich aber nicht um einen ganzen Raum handelt, sondern nur um eine Demonstration würde einfach eine andere (PCI wg. Plug&Pray) Netzwerkkarte einbauen. Die wird dann automatisch erkannt und das ganze sollte funktionierten![/quote]
 
Das wird wohl die einzige Alternative sein...

Die Frage ist ja, wie ich der Kiste sage welchen Treiber er für meine Netzwerkkarte nehmen soll.

Meine Karte:

NVIDIA nForce3 250Gb LAN Controller (on Board)

Vor allem: Wie soll ich wissen wie der Treiber heisst?


Hab es in meiner Schule schon mit einer anderen Netzwerkkarte von 3Com probiert und es kam folgende Fehlermeldung:

...

mount: Mounting 192.168.0.5:/opt/ltsp/i386 on /mnt failed: Invalid argument

ERROR!

Failed to mount the root directory via NFS
Possible reasons include:

1) NFS services may not be running on the server
2) Workstation IP does not be running on the server
3) Wrong address for NFS server in the DHCP config file
4) Wrong pathname for root directory in the dhcp configfile

Also hat diese Karte geschluckt. Hat man auch anhand des Protokolls gesehen.


Also wie sage ich meinem Server, was der Client für eine Karte hat?
Sonst muss ich wohl echt eine neue kaufen...
 
Du kannst dem Client per DHCP mitteilen welche Netzwerkkarte es ist. Aber WIE kann ich dir leider auch nicht sagen.

Ich gebe dir einen Tip: kauf dir für 5€ in irgendeinem PC-Laden ne billige PCI Netzwerkkare (meistens von RealTEC) und benutz die (schalte dann aber die onboard Karte aus -> BIOS).

Netzwerkkarten von 3com machen nur Probleme (persönliche meinung und erfahrung)
 
Sooo...habe mir nun eine neue Netzwerkkarte gekauft und musste sage nd schreibe 4,90 € investieren (schnief).

Sie ist von Realtek und hat den RTL8139D Chipsatz.

Habe mir nun ein Bootimage von Boot-O-Matic gebastelt und es getestet.

Result: Der Client fährt hoch...aber nicht ganz.

Am Ende sieht man einen grauen Bildschirm mit einem schwarzen X-Cursor.
Da funzt doch irgendwas noch nicht richtig oder? Weiss nicht genau ob es der XDM ist oder ob gerade der schon funzt...

Hat wer ne Ahnung?

Übrigens: Bei der Übersicht beim "ltspadmin" über die Dienste ist bei mir xdmcp nur installiert aber nicht "enabled" oder gar auf "running"...

Wenn ich ihn aber händisch konfigurieren möchte wird mir aber gesagt dass er läuft...Bug? :roll:
 
Jetzt hast du es eigentlich geschafft!

Dein Client fährt hoch und startet den X-Server!

Du musst XDM (bzw. KDM) noch mitteilen, dass Verbindungen von außen erlaubt sein sollen und die Firewall abschalten, damit die entsprechenden Ports geöffnet sind.

KDM : Yast -> System (menü links) -> Editor für /etc/sysconfig-Dateien.
Dann musst du dich im Menü links durchklicken:

Desktop -> Displaymanager -> DISPLAYMANAGER_REMOTE_ACCESS und setzte diesen Wert auf yes

[Wenn du willst kannst du auch gleich noch DISPLAYMANAGER_ROOT_LOGIN_REMOTE auf yes setzten, damit du dich am Terminal auch grafisch als root anmelden kannst!]

Firewall:

Als root auf die Konsole.
"SuSEfirewall2 stop" eintippen

-> Client hochfahren -> geschafft !
 
Hallo Admin!

Also ich habe die einträge, die du beschrieben hast auf "yes" gesetzt, allerdings keine Änderung.

Hier eine Fehlermeldung die mein Clinet ausgiebt, kurz bevor er oben ist:

++++++++++++

Scanning for Video card

Warning:

Auto probe of the videocard failed!
You should specifie the proper X server
in lts.conf

Proceeding with the slow vesa server

++++++++++++++++++++++++

In meinem Server steckt eine GeForce FX 5200.

Meine lts.conf:

+++++++++++++++++++++++++

[Default]
SERVER = 192.168.0.5
XSERVER = auto
X_MOUSE_PROTOCOL = "PS/2"
X_MOUSE_DEVICE = "/dev/psaux"
X_MOUSE_RESOLUTION = 400
X_MOUSE_BUTTONS = 3
USE_XFS = N
SCREEN_01 = startx

+++++++++++++++++++++++++

mehr Einträge habe ich erst mal nicht gemacht. Fehlt etwas? Oder muss ich den Treiber explizt angeben? Soo alt ist die Karte ja nicht.

Immer noch Grauer Bildschirm und X cursor
:(
 
Das ist seltsam!

Wenn ein grauer Bildschirm mit einem X - Cursor da ist, ist der X-Server gestartet, kann nur keine Verbindung zum Terminalserver aufbauen!

Die Fehlermeldung spielt dann keine Rolle!

Mögliche lösungsansätze:

- läuft kdm/xdm/gdm auf dem server?
- ist die firewall auch wirklich ausgeschaltet
- ist die ip in der lts.conf richtig? (den Eintrag kannst du eigentlich löschen, wenn es kein anderer Server ist als der auf dem das rootverzeichnis / kernel / ... liegt)



Noch ein Tipp wenns denn mal läuft:

in der lts.conf
X_MOUSE_PROTOCOL = "IMPS/2" angeben, dann funktioniert auch das Scrollrad!

ansonsten
gr. und viel Glück

admin@home (and @school)


EDIT: mir fällt grade noch was ein: du musst kdm nach den änderungen neustarten! (oder starte dann den ganzen server neu und beende dann die firewall -> firewall beenden ist extrem wichtig!)
 
Habe nach einem Prozess auf meinem Server ausschau gehalten, der wie ein Displaymanager aussieht --> Fehlanzeige


Hab jetzt SAX 2 installiert....der funzt.

Hab ihn danach wieder gekillt und danach kdm gestartet --> FUNZT!

Habe jetzt wenn ich den Client starte ein grafisches Login!

UNd ich habe sofort das nächste Problem:


Ich kann mich mit keinem Benutzer anmelden!
Es wird immer die message: "Login failed" ausgegeben!

Keine Ahnung warum aber darauf muss es doch eine Lösung geben!
 

rolle

Guru
Fein, ich betrachte diesen Thread jetzt als gelöst und schließe ihn. Wenn neue Probleme auftauchen, mache bitte einen neuen auf.
 
Status
Für weitere Antworten geschlossen.
Oben