• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

Gelöst Druckertreiber für HP LaserJet M209dwe

hallo zusammen,

ich verwende Ubuntu 20.04LTS und openSuSE Tumbleweed
und suche einen Druckertreiber für
HP LaserJet M209dwe
bisher leider ohne Erfolgt.
Es kann ggf. auch ein anderer Laserdruck monochrom sein.
Wobei double-sided muss nicht unbedingt sein.
Bei HP wäre schon gern geblieben.

Vielleich kann jemand von euch mir weiterhelfen.

bayernherz :thumbs:
 
HP Laserjet M209dwe3.21.2YesNoFullColorNoNoUSB,Network

Wird also seit hplip 3.21.2 unterstützt.....
Als root bei angeschlossenem Drucker und installiertem hhplip::
Code:
hp-setup

Hier meine hplip (nicht auf die Version und das Repo achten, nur für dich als Anhaltspunkt):
Code:
zypper se -si hplip
Repository-Daten werden geladen...
Warnung: Repository 'Main Update Repository' scheint veraltet zu sein. Ziehen Sie in Erwägung, eine andere Spiegelung oder einen anderen Server zu verwenden.
Installierte Pakete werden gelesen...

S  | Name             | Type  | Version          | Arch   | Repository
---+------------------+-------+------------------+--------+--------------
i+ | hplip            | Paket | 3.22.6-lp153.1.1 | x86_64 | Sauerland-OSS
i+ | hplip-devel      | Paket | 3.22.6-lp153.1.1 | x86_64 | Sauerland-OSS
i+ | hplip-hpijs      | Paket | 3.22.6-lp153.1.1 | x86_64 | Sauerland-OSS
i+ | hplip-sane       | Paket | 3.22.6-lp153.1.1 | x86_64 | Sauerland-OSS
i+ | hplip-scan-utils | Paket | 3.22.6-lp153.1.1 | x86_64 | Sauerland-OSS
 
OP
B

bayernherz

Hacker
hallo zusammen,

ich habe bei meinem openSuSE Tumbleweed mal die hplib installiert.

Code:
zypper se -s hplip
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name             | Type  | Version    | Arch   | Repository
---+------------------+-------+------------+--------+------------------------
i+ | hplip            | Paket | 3.22.6-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
v  | hplip            | Paket | 3.22.6-1.2 | i586   | openSUSE-Tumbleweed-Oss
   | hplip-devel      | Paket | 3.22.6-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
   | hplip-devel      | Paket | 3.22.6-1.2 | i586   | openSUSE-Tumbleweed-Oss
i  | hplip-hpijs      | Paket | 3.22.6-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
v  | hplip-hpijs      | Paket | 3.22.6-1.2 | i586   | openSUSE-Tumbleweed-Oss
i  | hplip-sane       | Paket | 3.22.6-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
v  | hplip-sane       | Paket | 3.22.6-1.2 | i586   | openSUSE-Tumbleweed-Oss
   | hplip-scan-utils | Paket | 3.22.6-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
   | hplip-scan-utils | Paket | 3.22.6-1.2 | i586   | openSUSE-Tumbleweed-Oss


Leider ist mein Wunschdrucker HP LaserJet M209dwe nicht dabei. Oder habe ich etwas übersehen ?

Code:
rpm -ql hplip | grep -i m2
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_cm2320_mfp-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_cm2320fxi_mfp-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_cm2320n_mfp-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_cm2320nf_mfp-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_m253-m254-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_m255-m256-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_m282-m285-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_mfp_m274-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_mfp_m278-m281-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_pro_m252-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-color_laserjet_pro_mfp_m277-ps.ppd.gz

/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_200_color_m251-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_200_colormfp_m275-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_200_colormfp_m276-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_m2727_mfp_series-ps.ppd.gz

/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_pro_m201_m202-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_pro_m203_m206-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_pro_mfp_m225_m226-ps.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip-hpps/hp-laserjet_pro_mfp_m227-m231-ps.ppd.gz
/usr/share/hplip/data/images/devices/hp_laserjet_m2727_mfp.png

Sauerland hat geschreiben:
Als root bei angeschlossenem Drucker und installiertem hhplip::
Code:
hp-setup

leider habe ich den Drucker noch nicht gekauft (vielleich auch zum Glück).

bayernherz :thumbs:
 
Alles da.....
Code:
rpm -ql hplip-hpijs | grep -i m2
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320fxi_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320n_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320nf_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m2727_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_mfp_m232-m237.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_mfp_m28-m31.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m25a.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m25nw.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m26a.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m26nw.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m27c.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m27cnw.ppd.gz

Code:
gzip -d hp-laserjet_m207-m212.ppd.gz && grep -i m209 hp-*
*Product: "(HP LaserJet m209d)"
*Product: "(HP LaserJet m209dw)"
*Product: "(HP LaserJet m209dwe)"
 
OP
B

bayernherz

Hacker
hallo zusammen,

Code:
rpm -ql hplip-hpijs | grep -i m2
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320fxi_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320n_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320nf_mfp-pcl3.ppd.gz

/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz

/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m2727_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_mfp_m232-m237.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_mfp_m28-m31.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m25a.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m25nw.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m26a.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m26nw.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m27c.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m27cnw.ppd.gz

Code:
gzip -d hp-laserjet_m207-m212.ppd.gz && grep -i m209 hp-*
gzip: hp-laserjet_m207-m212.ppd.gz: No such file or directory

Wo liegt mein Fehler ? :confused-lc:
 
Zuletzt bearbeitet:
hallo zusammen,

Code:
rpm -ql hplip-hpijs | grep -i m2
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320fxi_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320n_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-color_laserjet_cm2320nf_mfp-pcl3.ppd.gz

/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz

/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m2727_mfp-pcl3.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_mfp_m232-m237.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_mfp_m28-m31.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m25a.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m25nw.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m26a.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m26nw.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m27c.ppd.gz
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m27cnw.ppd.gz

Code:
gzip -d hp-laserjet_m207-m212.ppd.gz && grep -i m209 hp-*
gzip: hp-laserjet_m207-m212.ppd.gz: No such file or directory

Wo liegt mein Fehler ? :confused-lc:
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz
Dort ist es..... 207 bis 212
 

susejunky

Moderator
Teammitglied
Hallo bayernherz,

Wo liegt mein Fehler ? :confused-lc:
auf meinem System sieht das so aus:
Code:
# rpm -ql hplip-hpijs | grep -i m207
/usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz
#

# ls -la /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m2*
-rw-r--r-- 1 root root 17176  1. Sep 08:45 /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd
-rw-r--r-- 1 root root  3186  1. Sep 08:45 /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m2727_mfp-pcl3.ppd.gz
#

# grep -i m209 /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd
*Product: "(HP LaserJet m209d)"
*Product: "(HP LaserJet m209dw)"
*Product: "(HP LaserJet m209dwe)"
#
Beachte: Das Paket hp-laserjet_m207-m212.ppd hat keine Endung .gz.

Viele Grüße

susejunky
 

tomm.fa

Administrator
Teammitglied
bayernherz, bist du auch im richtigen Verzeichnis? Ansonsten kann auch der vollständige Pfad mit angegeben werden.


Beachte: Das Paket hp-laserjet_m207-m212.ppd hat keine Endung .gz.

Viele Grüße

susejunky
Hast du den Befehl von Sauerland zuvor ausgeführt? Weil nach einer frischen Installation von hplip-hpijs hier bei mir:
Code:
ls /usr/share/cups/model/manufacturer-PPDs/hplip/ | grep -Ei hp-laserjet_m207
hp-laserjet_m207-m212.ppd.gz

Ich würde ohnehin eher einen Befehl mit zcat oder zgrep verwenden als den vorgeschlagenen von Sauerland.
Zum Beispiel:
Code:
zcat /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz | grep -i m209

Weshalb?
Weil bei Sauerlands Befehl die entsprechende Datei entpackt wird und danach nicht mehr als komprimierte Datei (in xz) vorhanden ist, danach wäre eigentlich noch ein
Code:
gzip /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd
notwendig, um den Ursprungszustand wieder herzustellen.
Volle Pfadangaben entfallen, wenn man sich im passenden Verzeichnis befindet.
 
OP
B

bayernherz

Hacker
hallo zusammen,

Code:
zcat /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_m207-m212.ppd.gz | grep -i m209
*Product: "(HP LaserJet m209d)"
*Product: "(HP LaserJet m209dw)"
*Product: "(HP LaserJet m209dwe)"

damit sollte eigentlich nachgewiesen sein, das der HP LaserJet m209dwe mit Treibern von openSuSe Tumbleweed unterstützt wird. :razz:

Als nächstes würde ich die hplip auf kubuntu 20.04LTS installieren und untersuchen ob auch dort die Treiberunterstützung vorhanden ist.

bayernherz :thumbs:
 
OP
B

bayernherz

Hacker
hallo zusammen,

"bayernherz hat geschrieben:" Als nächstes würde ich die hplip auf kubuntu 20.04LTS installieren und untersuchen ob auch dort die Treiberunterstützung vorhanden ist.
Leider komme ich mit der Diagnose von
Code:
Betriebssystem: Kubuntu 20.04
KDE-Plasma-Version: 5.18.8
KDE-Frameworks-Version: 5.68.0
Qt-Version: 5.12.8
Kernel-Version: 5.15.0-46-generic
Art des Betriebssystems: 64-bit
Prozessoren: 4 × Intel® Core™ i5-3570 CPU @ 3.40GHz
Speicher: 15,3 GiB Arbeitsspeicher
bezüglich der Unterstützung meines Wunschdrucker HP LaserJet M209dwe nicht so recht weiter.
Was ich bisher herausgefunden habe folgt:
Code:
hp-info -i

HP Linux Imaging and Printing System (ver. 3.20.3)
Device Information Utility ver. 5.2

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.
error: No device found that support this feature.
Die hplip Treiber Lib steht im Verzeichnis:
Code:
/usr/share/hplip/

und hier die *.gz
/
Code:
/usr/share/hplip/data/pcl$ ls -l
insgesamt 3856
-rw-r--r-- 1 root root 12973 Apr 1 2020 align1_8xx.pcl.gz
-rw-r--r-- 1 root root 94822 Apr 1 2020 align1_9xx.pcl.gz
-rw-r--r-- 1 root root 2518 Apr 1 2020 align2_8xx.pcl.gz

-rw-r--r-- 1 root root 8047 Apr 1 2020 align2_9xx.pcl.gz

-rw-r--r-- 1 root root 1708 Apr 1 2020 align3_8xx.pcl.gz
-rw-r--r-- 1 root root 3691 Apr 1 2020 align3_9xx.pcl.gz
-rw-r--r-- 1 root root 38220 Apr 1 2020 align4_450.pcl.gz
-rw-r--r-- 1 root root 1425 Apr 1 2020 align4_8xx.pcl.gz
-rw-r--r-- 1 root root 8687 Apr 1 2020 align5_8xx.pcl.gz
-rw-r--r-- 1 root root 38982 Apr 1 2020 align6_450.pcl.gz
-rw-r--r-- 1 root root 3582620 Apr 1 2020 colorcal1_450.pcl.gz
-rw-r--r-- 1 root root 54 Apr 1 2020 colorcal2_450.pcl.gz
-rw-r--r-- 1 root root 10674 Apr 1 2020 crbcal.pcl.gz
-rw-r--r-- 1 root root 704 Apr 1 2020 crcaldone.pcl.gz
-rw-r--r-- 1 root root 31096 Apr 1 2020 crcbcal.pcl.gz
-rw-r--r-- 1 root root 17166 Apr 1 2020 crccal.pcl.gz
-rw-r--r-- 1 root root 41560 Apr 1 2020 crcpcal.pcl.gz
-rw-r--r-- 1 root root 11899 Apr 1 2020 crpcal.pcl.gz
Wahrscheinlich ist es das gz
Code:
-rw-r--r-- 1 root root 8047 Apr 1 2020 align2_9xx.pcl.gz
da es sich um einen pcl Drucker handelt.

Leider konnte ich trotz intensiver Nachforschungen im Internet nicht herausfinden was sich in der
align2_9xx.pcl.gz befindet.

Vieleicht kennt sich ja jemand von Euch mit ubuntu aus.

bayernherz :thumbs:
 
Zuletzt bearbeitet:

tomm.fa

Administrator
Teammitglied
Leider komme ich mit der Diagnose von
Code:
Betriebssystem: Kubuntu 20.04
KDE-Plasma-Version: 5.18.8
KDE-Frameworks-Version: 5.68.0
Qt-Version: 5.12.8
Kernel-Version: 5.15.0-46-generic
Art des Betriebssystems: 64-bit
Prozessoren: 4 × Intel® Core™ i5-3570 CPU @ 3.40GHz
Speicher: 15,3 GiB Arbeitsspeicher
bezüglich der Unterstützung meines Wunschdrucker HP LaserJet M209dwe nicht so recht weiter.
Was ich bisher herausgefunden habe folgt:
Code:
hp-info -i

HP Linux Imaging and Printing System (ver. 3.20.3)
[…]

Siehe:
HP Laserjet M209dwe3.21.2YesNoFullColorNoNoUSB,Network

Wird also seit hplip 3.21.2 unterstützt.....
[…]

Noch Fragen?
 
Hier in kubuntu 22.04:
Code:
apt list hplip
Auflistung… Fertig
hplip/jammy,now 3.21.12+dfsg0-1 amd64  [Installiert,automatisch]
 
OP
B

bayernherz

Hacker
hallo zusammen,

Sauerland hat geschrieben:
Hier in kubuntu 22.04:

Code:
apt list hplip
Auflistung… Fertig
hplip/jammy,now 3.21.12+dfsg0-1 amd64 [Installiert,automatisch]
Vielen Dank für Deine Antwort Sauerland. :razz:

Es stellt sich für mich die Frage ob ein Upgrade von (k)ubuntu 20.04LTS mit
HP Linux Imaging and Printing System
Code:
apt list hplip
Auflistung... Fertig
hplip/focal,now 3.20.3+dfsg0-2 amd64  [Installiert,automatisch]
auf die von Dir oben weiter erwähnte hplib Vers. hplip 3.21.2 problemlos funktioniert.

Bei der grafischen Oberfläche HPLIB Stutus Service habe ich bedenken,
da diese, wie ich gelesen habe, Python verwendet (Python arbeitet sehr versionsabhängig)
Zum setup denke ich mal braucht man diese nicht unbedingt.
Für spätere Servicezwecke ist mir im Moment nicht klar,
das müsste ich im Benutzerhandbuch des Druckers nachlesen
in wie weit dieses die minimal Bedienung am Drucker abdeckt.

Ein upgrade wäre ja ein Versuch wert. :irre:

bayernherz :thumbs:
 
Zuletzt bearbeitet:
OP
B

bayernherz

Hacker
hallo zusammen

ich habe mich für den nachfolgenden HP-Drucker entschieden:
HP LaserJet M209DW
da der Typ HP LaserJet M209DWe, den ich zuerst im Auge hatte, nur mit Verbindung ins Internet druckt.

Die Installation mit Tumbleweed und hplib 3.22.6 funktionierte problemlos.
Ich habe die installation des Druckers mit dem HP Device Manager 15.0 durchgeführt.

Bei Ubuntu 20.04LTS habe ich die hplib 3.22.6 installieren müssen.

Download der hplib
HP Developers Portal | Version: 3.22.6

Installation der hplib auf (k)ubuntu 20.04LTS
Code:
sudo hplip-3.22.6.run

Die automatische Installation der hplib ist allerdings hängengeblieben, weil sie eine nicht vorhandene hplib deinstallieren wollte.
Dieses lies sich allerding leicht beheben, indem ich mittels ubuntu wieder eine ältere hplib installiert habe.
Anschliessend lief die automatisch Installation der hplib problenlos durch.
Ebenso die Druckerinstallation mittel des HP Device Manager 15.0

Nochmals vielen Dank für Euere hilfreichen Hinweise. :razz:

viele herzliche Grüsse aus dem bayerischen Oberland
bayernherz :thumbs:
 
Oben