ELSA Microlink 56k USB

umsteiger

Newbie
Hallo Linux-Fans,

habe auch (mal wieder) Linux installiert. Habe ein Elsa Modem (56k USB) und möchte damit ins Inet. In der 7.2er Version ging das auf Anhieb. Mit meiner jetzigen 9er Version erkennt das OS das Modem zwar, jedoch passiert bei der Anwahl nichts. Woran liegt das? :?
 

T.o.m.

Newbie
Also ich hatte auch das elsa 56 Basic und das hat mit KInternet ab SuSe 8.0 (soweit ich mich erinnern kann) bis 9.0 immer funktioniert. Bin leider jetzt umgestiegen sonnst könnte ich mal vergleichen.
 
A

Anonymous

Gast
Habe genau das gleiche Modem und den gleichen Stess!
Ich habs schon soweit gebracht, dass das Modem funktionierte. Jedoch nicht immer, da offensichtlich ein Timingproblem bei der Modemerkennung vorliegt (mal wird es erkannt und mal nicht).

Mir hat die (Nach-)Installation von "kppp"(graphische Interneteinwahl) geholfen. kppp ist gesprächiger als kinternet. Dort wurde angemeckert, dass der PPP Server (pppd) kein SUID-Bit gesetzt hat. Das kann man als root folgendermaßen erreichen: "chmod 4755 /usr/sbin/pppd". kppp hat dann bei mir noch gemeckert, dass die Datei "/etc/resolv.conf" fehlen würde. Die habe ich dann als root mit "touch /etc/resolv.conf" angelegt. Mit diesen ganzen Maßnahmen hat dann (von den Erkennungsproblemen beim Booten abgesehen) die Einwahl funktioniert.

Dennoch bin ich die Probleme mit der Erkennung des USB Modems leid und kaufe mit jetzt ein US Robotics oder ein Acer (siehe SuSE Hardwaredatenbank).

Viel Glück!
 
A

Anonymous

Gast
Hallo!

Kaufe besser kein ACER-Modem, ich hab so einige Modems bei mir zu Hause stehen, aber dieses lahme Teil ist einfach der Hammer. Hab schon namhafte Marken, wie U.S. Robotics (das ältere Sportster-Modem) probiert, aber das mit Abstand "saugfähigste" Modem ist und bleibt das schon ca. 2 Jahre alte ELSA Microlink 56 K Fun II (C-Variante, A-Variante geht eigentlich auch). Natürlich kann man bestimmt auch eins von DEVOLO holen, aber ich denke, die haben vielleicht die Gehäuse-Aufschrift geändert, das wird wahrscheinlich schon alles sein. Tipp: EBAY. 1/4 des Neupreises.

Gruß
Manuel
 
A

Anonymous

Gast
Hallo!
Noch was, werde die Antwort wahrscheinlich nicht mitverfolgen. Meine Mail: mk-arts AT gmx.de
 
A

Anonymous

Gast
Mit dieser Anleitung sollte es funktionieren:

USB Modem Konfiguration (ELSA USB Modem)
----------------------------------------
Hintergrund: Das ELSA USB Modem ist zwar kein Winmodem, jedoch kommt es offensichtlich zu Timingproblemen. Daher wird das Kernel Modul "acm" nicht geladen und damit das Modem vom Kernel 2.4.21 (bei smp4G für Intel P4, 2.8 HT, Northwood) nicht erkannt.
Dies kann zwar manuell mittels "modprobe acm" erreicht werden. Jedoch ist dies auf Dauer kein Zustand. Die folgende Vorgehensweise ist nur sinnvoll falls dieses Modem wirklich am USB-Port hängt.

1. System -> YAST -> System -> Editor für /etc/sysconfig Dateien starten

2. Hardware -> Hotplug -> HOTPLUG_USB_STATIC_MODULES ergänzen
um den Eintrag: acm
Bsp. für den Eintrag: "evdev joydev mousedev keybdev acm"

3. Danach System neu starten

Hinweis:
System kann beim 1. Mal u.U. nicht ganz richtig herunterfahren. Sollte aber nach dem Restart behoben sein.

Kommt es dennoch vor, dass das Modem nach Wiedereinwahl nicht erkannt wird, so muss manuell (root-Rechte) mittels:
modprobe -r acm
modprobe acm
das Kernelmodul entladen und wieder geladen werden.

Falls das Modem immer noch nicht erkannt wird, kann vorsichtig folgendes eingegeben werden:
modprobe -r usbcore
modprobe -r usb-uhci
modprobe usbcore
modprobe usb-uhci
 
A

Anonymous

Gast
Hallo,

danke zuerst mal für Deine Hilfe! Hat mir sehr geholfen.

Beim Start von kinternet ist es in meinem Fall nötig
das USB Kernelmodul zuerst zu entladen und dann wieder zu laden mit den Befehlen:

modprobe -r acm
modprobe acm

(Wie von Dir beschrieben!)

Dann funktioniert die Einwahl.

Kann mir jemand sagen wie ich dieses Prozedere nun automatisieren kann?

Danke!



Anonymous schrieb:
Mit dieser Anleitung sollte es funktionieren:

USB Modem Konfiguration (ELSA USB Modem)
----------------------------------------
Hintergrund: Das ELSA USB Modem ist zwar kein Winmodem, jedoch kommt es offensichtlich zu Timingproblemen. Daher wird das Kernel Modul "acm" nicht geladen und damit das Modem vom Kernel 2.4.21 (bei smp4G für Intel P4, 2.8 HT, Northwood) nicht erkannt.
Dies kann zwar manuell mittels "modprobe acm" erreicht werden. Jedoch ist dies auf Dauer kein Zustand. Die folgende Vorgehensweise ist nur sinnvoll falls dieses Modem wirklich am USB-Port hängt.

1. System -> YAST -> System -> Editor für /etc/sysconfig Dateien starten

2. Hardware -> Hotplug -> HOTPLUG_USB_STATIC_MODULES ergänzen
um den Eintrag: acm
Bsp. für den Eintrag: "evdev joydev mousedev keybdev acm"

3. Danach System neu starten

Hinweis:
System kann beim 1. Mal u.U. nicht ganz richtig herunterfahren. Sollte aber nach dem Restart behoben sein.

Kommt es dennoch vor, dass das Modem nach Wiedereinwahl nicht erkannt wird, so muss manuell (root-Rechte) mittels:
modprobe -r acm
modprobe acm
das Kernelmodul entladen und wieder geladen werden.

Falls das Modem immer noch nicht erkannt wird, kann vorsichtig folgendes eingegeben werden:
modprobe -r usbcore
modprobe -r usb-uhci
modprobe usbcore
modprobe usb-uhci
 

Schwoandl

Newbie
Servus ,
i hab des gleiche problem wie ihr aber jezt wollt i die HOTPLUG_USB_STATIC_MODULE ändern wie einer zuvor geschrieben hat aber leider find i des ned oder gibts bei mir gar ned !
i hab linux 9.1 home edit. kann ma jemand weiterhelfen ?!?!?!?!?!?!
 
Oben