Fehlermeldung bei Start

roemi

Advanced Hacker
sodele, ich mache den anfang

ich habe mono in ein unter vmware laufendes suse 9.1 gnome installiert.
(danke an die stelle deren die mir die nötige hilfe gegeben haben)

so, installiert ist es ... aber beim start bekomme ich nun folgende meldung:
Unhandled Exception: System.DllNotFoundException: gnomesharpglue
in <0x00053> (wrapper managed-to-native) Gnome.Program:gtksharp_gnome_program_init (string,string,Gnome. ModuleInfo&,int,string[],int,Gnome.Program/PropertyArg[])
in <0x002de> Gnome.Program:.ctor (string,string,Gnome.ModuleInfo,string[],object[])
in [0x000d5] (at /home/duncan/conf/mono-conf/monodevelop/BUILD/monodevelop-0.4/src/Main/StartUp/MonoDeve lopMain.cs:80) MonoDevelop.SharpDevelopMain:Main (string[])

ein großes :?:
 
Hallo roemi !!

Naja - 'normalerweise' wuerde ich sagen, dass eine .NET-Dll namens 'gnomesharpglue' fehlt - nur ist die auch nicht auf meiner Platte, weder unter mono-0.96/gtk-sharp-0.98 (Beta3), noch unter mono-0.97/gtk-sharp-0.99 (RC1) !

Entweder sind diese Sachen in eine der gtk-sharp Dlls mit ein-compiliert, nur habe ich im Moment wenig Zeit, dies genauer zu untersuchen ...

Kurze Frage(n): welche Version(en) setzt du ein (z.b. mono-0.97, gtk-sharp-0.99, etc.) ..?

Hast Du die Pakete von http://www.go-mono.com/archive/rc/suse-91-i586/ installiert - und, wenn ja, welche ??

Fuer MonoDevelop brauchst Du folgende Sachen:
- (natuerlich) Mono
- GTK# (gtk-sharp)
- gecko-sharp
- gtksourceview-sharp
- monodoc
- MonoDevelop

Welches Gnome hast Du am Laufen - 2.4.x oder 2.6.x ??

bye,
Duncan
 
OP
roemi

roemi

Advanced Hacker
ok, ist dir wenig geholfen (bzw. mir) wenn ich nun antworte: immer das neuste :lol:

ich muss heute abend nachschauen und sage dir dann bescheid.

zum download: jupp, genau die adresse und hier (weil ich ja ne faule socke bin :D ) die datei "mono-all.zip".

ist da nicht alles enthalten?
 
Immer die LATEST :) ? - gut, sehr gut!

Hatte noch nach Deiner Gnome Version gefragt bzw. welche gnome-packages hast Du installiert ..?

bye,
Duncan
 
OP
roemi

roemi

Advanced Hacker
sodele, ich hoffe ich kann dir nun alles sagen.
1 linux suse 9.1 2.6.4-5.2-default
gnome 2.4

ich habe nochmal yast geöffnet:
da kamen gleich fehlermeldungen (ungelöste abhängigkeiten)
render, xrender, libpopt.so.o würden fehlen.

ich habe das ignoriert und make, sourcen, gcc nachinstalliert (jetzt frage ich mich gerade ob ich überhaupt die tools installiert habe?) (egal)
render, xrender u. lib.... habe ich nicht gefunden (folglich auch nicht installiert)

dann habe ich nochmal sämtliche 61 pakete drüber gebügelt (incl suseconfig) (ihr seht, ich lerne).

lange rede .... die gleiche meldung beim start.
:?:
 
Ich habe ja im Moment keine SuSE Installation von Mono mehr am Laufen (im Mom. nur auf Gentoo), aber JETZT wo Mono als 1.0 Final erschienen ist, werde ich unseren Server (SuSE 9.0) mit den Mono-Packages mal installieren, dann kann ich mehr dazu sagen ... (entweder noch heute Nacht, spaetestens morgen im Laufe des Tages). Auf diesen 9.0er Server habe ich bereits die SuSE RPMs der Gnome 2.6 gestellt ... - ich weiss ja nicht, wie es zeitlich bei Dir aussieht, aber wenn's Dir moeglich ist -und Du keine Einwaende gegen eine 2.6er Gnome hast-, koenntest Du ja mal versuchen, das Ganze mit einer Gnome 2.6 im Ruecken laufen zu lassen ... - GTK# (in der auch die gnome-dlls sind) ist ja stark Gnome-lastig und ich kenne es noch aus meiner Zeit (SuSE 9.0 Workstation), in der ich unter SuSE immer die Latest Sources aus dem Mono CVS installiert hatte ... - am Schluss hatte ich sogar da Gnome 2.6 (damals aus den Org. Gnome Sources in naechtelanger Arbeit installiert) drauf und hatte nie Probs. mit Mono, GTK# und auch nicht mit MonoDevelop, welches ich seit der v0.2 immer aus den Sources baute.

Die RPMs habe ich -wie gesagt- selbst noch nie genutzt, probiere es aber mal jetzt mit unserem SuSE 9.0 Server ...

Ach ja - die render u. xrender Geschichten gibt's auf: http://freedesktop.org/~xlibs/release/

bye,
Duncan
 
OP
roemi

roemi

Advanced Hacker
dat is gut,

ich habe mir gestern beim basteln meinen gnome 2.4 vm-pc zerschossen.
werde ich heute (oder morgen )nochmal neu hochziehen.
vielleicht probiere ich mal was völlig neues und versuche zu reparieren.
alleine der gedanke daran ist für einen eingefleischten ex-winler schon abnormal (bin ich auf dem weg ein linuxaner zu werden ...?, beantworte ich etwa bald fragen hier im forum ... ? und stelle nicht nur welche ... ? upps)

würde mich freuen wenn du deine erfahrungen dann hier veröffendlichst und ich und die anderen tausende daraus patipazieren können (welch ein wort)
:p

edit durch mich: "partizipieren" (hat mir keien ruhe gelassen)

p.s.: bin heute gut drauf ...
 
Hallo roemi!

Schoen, dass Du heute gut drauf bist :) ... - ich leider wegen besagter Dependency-Probs. (BTW: ich hasse RPMs!) etwas weniger ...

Also - ich habe nach meinen Gnome 2.6 Packages die Mono Packages auf SuSE 9.0 installiert - nun habe ich wieder die 'lustigen' Dependency-Probs. - einerseits mit libgtkhtml3 und andererseits mit libpixman :( ...

Yast2 schreibt, dass beide Packages NICHT vorhanden sind, was ja bei gtkhtml3 verstaendlich ist - aber libpixman und libpixman-devel werden als installiert beim Suchen nach 'libpixman' angezeigt :( ...

Irgendeine Idee??

P.S.: wenn ich den ganzen Tag ueber nicht meiner xxx-Arbeit nachgehen muesste, wuerde ich kurzerhand mal selbst RPMs fuer einige probl. Installs herstellen, die dann funktionieren wuerden - nur hat mein Tag leider nur 24h ...
 
So - ich hab' mein Problem dann doch geloest ... - geht jetzt ALLES ohne Dep.-Conflicts ...

Habe nach meiner Gnome 2.6 (SuSE Packages vom SuSE FTP) Installation und nach meiner Mono-Installation (alle RPMs vom mono-all.zip File) mit rpm --nodeps --force *.rpm noch folgende Packages mir aus dem Netz 'besorgt':

- gtksourceview-1.0.1-3.i586.rpm
- libgal2.0_6-1.99.11.0.200404140531-0.snap.ximian.8.1.i586.rpm
- libgtkhtml3.0_4-3.0.10.0.200404140531-0.snap.ximian.8.1.i586.rpm
- libpixman-0.1.1-0.ximian.8.0.i586.rpm
- libpixman-devel-0.1.1-0.ximian.8.0.i586.rpm

und installiert und siehe da: KEINE Dependency-Conflicts mehr :) !!

SO - JETZT bin ich mal gut drauf :lol: ...

bye,
Duncan
 
OP
roemi

roemi

Advanced Hacker
das ist gut :D

ich hatte gestern weniger glück .... mein vm läuft noch nicht . zumindest nich so wie ich will.

ich bastel heute oder (vermutlich) morgen weiter.
und wenn dann mein icewm mit rox läuft, dann bin ich zuversichtlich die kiste mono zum laufen zu bringen (mit deiner hilfe :wink:)

edit 05.07.2004 15:55 und ich bastel immer noch :cry:
 
OP
roemi

roemi

Advanced Hacker
guten abend,

nach viel mühe kann ich sagen: mein mono rennt. :D
z.z. nur als root. beim user gibt es ein fehlermeldung.
egal darum kümmere ich mich demnächst.

jetzt heist es erstmal die platte putzen.
zuviel gnomezeugs. :(
wo doch "nur" icewm mit rox läuft. :p

da habe ich dann auch gleich zwei fragen .... :wink:

aber jetzt ... gute nacht
 
Oben