[Frage] Befehl USERS für smb mounts in fstab macht Probleme!

Matty2k

Newbie
Hi zusammen,

ich bin schon seit einiger Zeit damit beschäftigt, einen vernünftigen Eintrag für smb Freigaben in meine fstab zu bekommen. Wie man hier auch im Forum sieht, scheint es immer wieder zu Konflikten oder Verständnis Probleme zu kommen, obwohl es eigentlich nicht so schwierig ist.

Ich habe bisher keine Probleme gehabt, die Freigaben als root oder per sudo, was ja aufs gleiche herauskommt, über die Konsole einzubinden. Auch die Einträge in die fstab funktionieren, solange man nicht versucht, das mounten für normale Benutzer durch den Befehl users zu erzwingen. Auch die Einrichtung über das Webinterface Webmin funktioniert nur solange, bis man die Option "Benutzer das mounten erlauben" aktiviert. Anschließend kommt dann eine Fehlermeldung.

In Benutzung ist hier Suse 10.0 mit den neuesten Updates. Handelt es hierbei um einen BUG oder um einen Fehler meinerseits?

mfG

matty
 
Warum eigentlich '/etc/fstab'?
Für Samba-Freigaben am besten /etc/samba/smbfstab benutzen.
Und dann einfach mit
Code:
rcsmbfs start
(als root) starten bzw. den Dienst 'smbfs' einfach beim starten ausführen lassen (im entsprechenden Runlevel aktivieren).

Ansonsten (wenn das mounten durch den user unbedingt via '/etc/fstab' ausgeführt werden soll) einfach 'sudo' benutzen und den user in der '/etc/sudoers' autorisieren.
 
Oben