[gelöst] HP LaseJet4plus unter SUSE 10 geht net

Status
Für weitere Antworten geschlossen.

VW_Andy

Newbie
Hilfe ! Ich bin ein absoluter SUSE LINUX 10 Anfänger (BJ1964).
Ich kann den Drucker nicht konfigurieren.
Unter Windoof klappt alles, also liegt kein mech. Fehler vor.
(MSI ATX Board-PT880)

YaST2 erkennt den HP Laserjet4plus Drucker,
er ist an der Parallelen Schnittstelle angeschlossen (lp0)
beim Druckeranschluss testen gibt es die Fehlermeldung:
Beim Senden ist ein Problem aufgetreten ich soll doch das Kabel prüfen....
(Blödsinn=unter Windoof geht der Drucker einwandfrei)
Wenn ich probiere mit lp1 oder lp2 kommt die Meldung:
Das Gerät ist möglicherweise nicht ordnungsgemäß konfiguriert
oder Sie verfüge nicht über die entspr. Schreibberechtigung
– hä Wie ? :shock: Ich komme doch nur als root in YaST2 oder ?

Gut, Abbruch, anderer Versuch: lsusb
gibt mir gar keinen Drucker/Anschluss aus !
(zumindest kann ich keinen Erkennen (lauter ID Nuller) bzw.
Bus 002 Device 002: ID 1241:1166 Belkin
Bus 005 Device 003: ID 05e3:0710 Genesys Logic, Inc.

wenn ich in der Textkonsole: lpc status abfrage kommt die meldung
laserjet4plus:
printer is on device 'parallel' speed -1
queuing is enabled
printing is enabled
1 entries
daemon present

wenn ich in der Textkonsole mit dem lpr Befehl drucke
passiert nix, auch keine Fehlermeldung !?

Was mach ich falsch ?
Wer kann mir Helfen wo kann ich was Suchen, Probieren??

Ich geb nicht auf ! Ich will weg von XP - Ich will mit Linux arbeiten !
Alle anderen Problemchen konnte ich durch stöbern im Forum + WWW lösen!
Gruß und Danke !
Andy :D
 

misiu

Moderator
Teammitglied
lsusb listet USB-Geräte auf, da du am Parallelport hängst, wird der Drucker da nicht auftauchen.
Mach folgendes:
- Lösche im YaST den Drucker
- starte den Rechner neu mit eingeschaltetem Drucker
- richte ihn neu mit YaST ein (ohne Testdruck)
- starte den Rechner neu
- versuche von einer Anwendung zu Drucken

Falls es so nicht klappt melde dich wieder oder versuche dich an der Suchfunktion des
Forums mit : lpt parport

MfG
misiu

P.S. geht der auch mit USB?
 

VW_Andy

Newbie
Hallo misiu !
Danke für die promte Antwort !
das lsusb nur USB Geräte listet,
hätte man ja am Namen erkennen können - schäm :oops:
(Der (alte) Drucker hat nur eine PRN Schnittstelle)

Habe den Drucker wie von Dir beschrieben gelöscht und neu eingerichtet;
Mit einem Teilerfolg;
Wenn ich nun eine Office Datei Drucken will erscheint am Drucker Display:

W2 Ungültig. Pers.

Was kann das denn jetzt noch sein ?
Ist das jetzt ein SUSE oder ein HP Problem ?

Gruß Andy
 

misiu

Moderator
Teammitglied
Eher Schnittstellenproblem, schau dir die Einstellungen für Parport im BIOS an.
(EPP/ECP)

MfG
misiu
 

VW_Andy

Newbie
Hallo,
ein Blick ins Bios hat ergeben das ECP + IRQ + DMA auf AUTO steht.
Ich habe dann auf Manuel umgestellt und diese Werte dann in Yast eingestellt.
Das Ergebnis war das gleiche – Fehlermeldung am Druckerdisplay!

Nach vielen weiteren Sinnlosen Fehlersuchen
und rumprobieren ist die Lösung dann doch relativ Einfach !

:!: Ich musste nur eine andere PPD-Datei verwenden !! :!:
Yast bietet für diesen Drucker Oldie 6 Stück zur Auswahl.
Bei mit funktioniert der Drucker mit der .....Foomatic/hpijs... Datei Einwandfrei !
Gottseidank !!!

Vielen Dank für die Freundliche Unterstützung!
Ich werde sicherlich noch öfters vorbei Schauen !

Mit freundlichen Grüßen Andy :D
 
Status
Für weitere Antworten geschlossen.
Oben