[gelöst] Sarg "Buffer overflow detected" bei &quot

Status
Für weitere Antworten geschlossen.

RossiRat

Newbie
Hallo,
ich habe einen Suse 10.0 Server mit squid und sarg laufen. Beide Programme sind die aktuellen Versionen aus dem YAST Update und funktionieren gut.

Nur wenn ich in der sarg.conf die Option overwrite_report yes einstelle, dann startet sarg nicht mehr und ich bekomme den Fehler Buffer overflow detected . :x

Weder mit google, noch in diesem Forum oder in den Manpages habe ich was dazu gefunden. :cry:

Kann mir jemand einen Tipp geben wie ich sarg dazu bringe die Option anzunehmen und nicht mehr diese nervigen .1 .2 .3 Verzeichnisse zu erstellen?


Vielen Dank für eure Mühe

RossiRat
 

RossiRat

Newbie
Hmmm, scheint nicht sehr verbreitet zu sein das Problem.

Darf ich dann mal fragen, ob jemand von Euch die Option overwrite yes benutzt und wenn ja mit welcher sarg Version?
 

RossiRat

Newbie
Geschafft es funktioniert jetzt! Auch wenn keiner mit mir sprechen wollte :p ;) gebe ich doch gerne meinen Lösungsweg preis:
  1. Das Suse sarg RPM deinstalliert
  2. Die Sourcen direkt von der Sarg Page geladen: sarg-2.1.tar.gz
  3. Configure mit folgenden Parametern aufgerufen:
    ./configure --enable-sysconfdir=/etc --enable-htmldir=/srv/www/htdocs
  4. make
  5. make install
  6. Die Datei /etc/sarg.conf bearbeitet (Pfade, Sprache, "overwrite_report" ...)
  7. Alte Auswertungen aus /srv/www/htdocs/... gelöscht
  8. sarg gestartet
  9. Statistik angeschaut
So klappt es auch mit dem "overwrite_report on". Außerdem hat die neueste sarg Version mehr Optionen (z.B. Textgröße, Logfiles packen) und umfangreichere Statistiken. :idea:

Viel Erfolg beim Nachmachen


PS:
Mein erstes kompiliertes Programm! Ich bin stolz auf mich. 8)
Jetzt kann ich meinen Usern endlich "fast realtime" Reports vor die Nase setzen. :roll:
 
Status
Für weitere Antworten geschlossen.
Oben