[gelöst] SuSE 9.2 / Netgear WG311v3

Rossi79

Newbie
Hallo,

zu dieser Konstellation gibt es wohl schon einige Beiträge, daher Entschuldigung, dass ich das Thema erneut anschneide.

Ich versuch schon seit ein paar Tagen die obige WLAN-Karte zum Laufen zu bringen, leider erfolglos. Ich hab es mit ndiswrapper probiert, zunächst in der Version 0.10, die bei SuSE 9.2 dabei ist. Das klappt auch alles super, bis zu dem Punkt, an dem ich die Karte konfigurieren will.
iwconfig ergibt eine Meldung, die in etwa so aussieht:

Code:
lo no wireless extension
eth0 no wireless extension
sit0 no wireless extension

Sollte da nicht irgendwo wlan0 erscheinen? Wenn ich dmesg eingebe, erscheint am Ende:

Code:
ndiswrapper: unsupported module, tainting kernel.
ndiswrapper version 0.10 loaded (preempt=no,smp=no)
ndiswrapper (import:134): Unknown symbol: ntoskrnl.exe:ObfDereferenceObject
ndiswrapper (load_driver:1829): Unable to prepare driver

Ich hab's dann mal mit der Version 1.10 ausprobiert, die hab ich aber nicht installieren können. :oops:

Kann mir da jemand weiterhelfen?
Danke
 

wiebkes

Member
Hei.
Um mal die einfachen Fragen vorweg zu stellen:
Hast Du bei Deiner SuSE irgendwann mal ein Kernel-Update gefahren (geht ja auch per Kabel)? Wenn nein versuch die Installation mit der ndiswrapper-Version, die auf den Installationsmedien ist - wenn die Versionen da nicht zusammenpassen gibt das sonst eine Menge Ärger, mehr aber leider auch nicht.
Dann mußt Du noch folgende Pakete mindestens installiert haben:
bin86
make
kernel-sources
glibc-devel
gcc

+ deaktiviere die Firwall
und dann kannst Du nach folgendem Text vorgehen:Inst. Doku Wlan mit ndiswrapper

Drücke die Daumen dass es klappt.

Wiebke
 
OP
R

Rossi79

Newbie
wiebkes schrieb:
Hast Du bei Deiner SuSE irgendwann mal ein Kernel-Update gefahren (geht ja auch per Kabel)?
Nein, bisher noch nicht. Die Räumlichkeiten sind etwas ungeeignet für Kabel.

wiebkes schrieb:
Wenn nein versuch die Installation mit der ndiswrapper-Version, die auf den Installationsmedien ist - wenn die Versionen da nicht zusammenpassen gibt das sonst eine Menge Ärger, mehr aber leider auch nicht.
Das hab ich probiert: Version 0.10, klappt nicht.

wiebkes schrieb:
+ deaktiviere die Firwall
Ist das in jedem Fall notwendig?

Vielen Dank für die Paketliste! Ich hab jetzt zumindest ndiswrapper-1.5 installieren können. Es klappt auch wieder alles super, bis zu dem Punkt, an dem ich "modprobe ndiswrapper" versuche:

Code:
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.8-24-default/extra/ndiswrapper.ko): Invalid module format

Nach "dmesg" erscheint dann das Folgende:

Code:
ndiswrapper: unsupported module, tainting kernel.
ndiswrapper version 0.10 loaded (preempt=no,smp=no)
ndiswrapper (wrapper_init:2286): loadndiswrapper failed (1536); check utils version mismatch

Version 0.10 hatte ich mit YaST installiert, dann aber auch wieder deinstalliert. Kracht es deswegen? Ich hatte irgendwo gelesen, dass SuSE 9.2 sich gut mit Version 1.5 versteht...

Trotzdem schonmal vielen Dank!
 
--- Ich hätte ca. das gleiche Problem !!!--

hab die gleiche wlan karte und linux 9.1

wenn ich mir bei yast2 die verfügbaren nics anzeigen lasse, wird die wlan karte als ethernet karte gefunden ... was kann ich dagegen tun ??

und wo sehe ich ob ich ne verbindung hab (egal ob mit wlan, oder ethernet)

... bin totaler linux anfänger

mfg
black knight
 

wiebkes

Member
Hei Rossi79.
Dein System meldet Dir ein ndiswrapper-Versionschaos und lädt auch noch die ndiswrapper 0.10 zuerst.
Hattest Du rpm-Packete für ndiswrapper Version > 0.10? Wenn ja kannst Du die erstmal (als root auf der Konsole) mit
Code:
rpm -e ndiswrapper
deinstallieren und dann nochmal in Yast gucken, ob die original ndiswrapper-Packete installiert sind oder nicht (falls ja deinstallieren). Wenn Du dann das System wieder sauber hast würde ich es mit den neueren nochmal versuchen.
Wobei die Firewall an dieser Stelle tatsächlich aus sein muß.
Du kannst dann nach der Anleitung von linuxstevi vorgehen - oder wenn Du es noch genauer brauchst mußt Du mal suchen gehen, ich hab' selber irgendwann Anfang des Jahres jemandem meine Doku gepostet. Da steht dann auch "der Rest" drin wie die Yast-Einträge...

Viel Glück erstmal

Wiebke

1. die Doku von Linuxstevi
2. die Doku von mir (2. Post von oben)
 
OP
R

Rossi79

Newbie
Tausend Dank! Mein Tag ist gerettet, diese Zeilen schreibe ich aus Linux heraus. Nach einer "Säuberung" hat es endlich funktioniert. Neben den sehr hilfreichen Anleitungen aus Wiebkes letztem Posting kann ich die folgenden empfehlen:

http://ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.x
http://ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.2

... und die allgemeine Installationsanleitung auf der ndiswrapper-Seite.

Nochmals tausend Dank! Ihr habt einem Linux-Einsteiger viel Motivation für den Wechsel gegeben! :D

Rossi
 

Maxi1992

Newbie
äääh leute kleine frage ich neu hier aber hab des schon ma gelesen und hab des auch mit dem ndiswrapper gemacht
wenn ich dann eingeb:
'ndiswrapper -l'
dann kommt:
'wg311v3 driver installed, hardware present'
aber ich komm dann trotzdem nich auf unser lokales Netzwerk!!!

Maxi
 
OP
R

Rossi79

Newbie
@Maxi1992: Ich empfehle Dir, die Installationsanleitungen von der ndiswrapper-Seite runterzuladen und dann aus Linux heraus offline zu lesen. Außerdem vermute ich, dass Du erst noch "ndiswrapper -m" eingeben und anschließend mit "modprobe ndiswrapper" das Modul laden musst. Zuguterletzt musst Du natürlich auch noch die Schnittstelle einrichten, am besten per YaST (so hab ich es zumindest gemacht). Wie bereits gesagt,
http://ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.x
war auch sehr hilfreich.

Viel Erfolg
Rossi
 
Oben