[gelöst]synaptic und die aktuelle Java-Version

fabilazar

Member
Hallo,
ich wollte mit synaptic meine Java Laufzeit- und Entwicklungsumgebung auf den neuesten Stand bringen, aber leider wird da Java 1.4.2 als die installierte und aktuellste Version ausgegeben.
Was muss ich tun um mit Synaptic Java 1.4.2 auf 1.5.0 updaten zu können? Ich habe Suse 9.2
Gruss
 

oc2pus

Ultimate Guru
dann wirst du dir dein Paket selber bauen müssen...

wie das geht habe ich hier beschrieben:
SuSE 9.x und JDK 1.5.x
http://www.linux-club.de/viewtopic.php?t=21665
 

fabilazar

Member
Okay, wenn es sein muss :wink:
Ich will aber nur das akutelle JDK 1.5 haben. Muss ich die
java-1_4_2_sun
java-1_4_2_sun-devel deinstallieren?
Ich bin mir nicht sicher, da dann bestimmt Abhängigkeiten auftreten werden...
 

oc2pus

Ultimate Guru
fabilazar schrieb:
Okay, wenn es sein muss :wink:
Ich will aber nur das akutelle JDK 1.5 haben. Muss ich die
java-1_4_2_sun
java-1_4_2_sun-devel deinstallieren?
Ich bin mir nicht sicher, da dann bestimmt Abhängigkeiten auftreten werden...

erstelle wie oben beschrieben die Java-Pakete und mach dann ein ganz normales update (d.h. die neuen Pakete ersetzen die bereits installierten) . Wo ist da jetzt ein Problem ?
 

fabilazar

Member
okay, da die Links nicht gehen, habe ich das
java-1.5.0-sun-1.5.0-3jpp.nosrc.rpm bei rpmseek.com geladen. Allerdings die...-1.5.0.06-1jpp, wenn ich es installieren will bekomme ich diese Meldung:
Code:
linux:/home/fabse/java-dateien # rpm -i java-1.5.0-sun-1.5.0.06-1jpp.nosrc.rpm
warning: java-1.5.0-sun-1.5.0.06-1jpp.nosrc.rpm: V3 DSA signature: NOKEY, key ID c431416d
warning: user jacorley does not exist - using root
warning: group ncsu does not exist - using root
warning: user jacorley does not exist - using root
warning: group ncsu does not exist - using root
warning: user jacorley does not exist - using root
warning: group ncsu does not exist - using root
linux:/home/fabse/java-dateien #
Kann mir jmd. helfen?? [/code]
 

oc2pus

Ultimate Guru
nein nein nein ... du hast nur das erste Posting gelesen ;)

weiterlesen ... und das funktioniert!

btw ich verschiebe das dann mal zu Programmieren :)
 

fabilazar

Member
Okay, danke für den Hinweis, mit rpm -Uhv...ging es :wink:
Die Installation hat nach deinem Howto bis auf die fonts gut geklappt, und da die nicht wichtig sind, belasse ich es dabei.
Wenn ich jetzt aber in Synaptic nach java suche, habe ich beide Versionen sowohl java 1.4.2 als auch java 1.5.0 installiert.
Das wollte ich eigentlich vermeiden. Kann ich jetzt die 1.4.2 deinstallieren? Wenn ja, was genau?
Wenn ich beim firefox über about:plugins die verwendete java-Version prüfe, dann ist da auch noch java 1.4.2 hinterlegt..?
 

oc2pus

Ultimate Guru
das Plugin-Problem wird durch die Installation vom Paket java-1.5.0-sun-plugin-1.5* gelöst.

die beiden Jave Versionen können koexistieren ;)
oder mit rpm -e bzw synaptic die 1.4er Pakete löschen
 
Oben