kinternet & wiedereinwahl

gms

Newbie
hi all. Ich habe mir vorige Woche zum ersten mal linux installiert und bin bis jetzt recht begeistert davon. nur habe ich einige probleme mitdenen ich nicht zurecht komm. mein haupt problem ist:

ich habe dsl. kann mich mit meinem server (linux 9.1) über kinternet ohne probleme einwählen (und auch im netz sharen, das war alles kein problem)
aber wo ich nicht mehr weiter weis ist:

nach 8 stunden hab ich vom provider her einen disconnect. dannach kann ich mich nicht mehr einwählen. ich muss dann imma rumspielen

kinternet schliessen - aufmachen - starten -wida - schliessen - starten - eine seite anpingen - usw usw

irgendwann (hab noch kein muster erkannt) funktioniert es dann wieder und ich komm ins internet.

ich habe auto-reconnect angeschalten und auch dial on demand. aber es will nicht ordentlich funktionieren...



hat wer einen tipp für mich? ich verzweifle bald :)





eine frage hab ich dann in weiterer folge:
wie kann ich den traffic kontrollieren in meinem heim netzwerk? im windows hatte ich ein programm namens "bandwitch controller"
ich hab schon viel gegoogelt aber nichts gescheites gefunden. vielleicht hat wer erfahrungen damit und kann mir einen tipp geben.




vielen dank im vorraus!!
 

Bonsai

Advanced Hacker
Frage 2 wurde schon beantwortet:
http://www.linux-club.de/viewtopic.php?t=8365&highlight=traffic

Zu Nummer 1. Taucht das vielleicht dann auf, wenn kein Traffic auf der Leitung ist, oder auch bei vollem Betrieb? Hast Du in Kinternet eine Zeit definiert, nach der Kinternet auflegen soll? Wenn ja, setz die mal auf 0.
 
OP
G

gms

Newbie
hi.

nein das kann ich ausschliessen.

mein internet disconnectet nach 8 stunden. und das ist wegen meinem provider => also "normal"

ich kann mich dann auch normal einwählen nach einer zeit - aber nicht direkt nach dem disconnect. jetzt war meine vermutung dass vielleicht 1 leitung 'blockiert' ist und diese erst freigegeben werden muss.

hab da z.b. den befehl "multilink" (das bei mir auf "no" gesetzt) oder "max-number-of-links" (ist bei mir auf "1") gefunden in der konfigurationsübersicht. aber ich find darüber keine informationen wie ich das umstellen könnte zum testen ob das das problem lösen würde.


ad punkt 1: danke für den link, ich teste gleich mal und berrichte ob ich zusammenkomm :)
 

Bonsai

Advanced Hacker
Vielleicht hilfts einfach das Netzwerk neu zu starten? Der Provider trennt vielleicht etwas unsauber. Dein System wartet eventuell noch, weil es der Meinung ist, die Verbindung steht noch. Wenn Du aber das Netzwerk komplett durchstartest, ist wieder alles im Ausgangszustand.
 
OP
G

gms

Newbie
ist ein versuch wert. kannst du mir nur noch sagen wie mit welchem befehl ich das mache? *schäm* :)
 
OP
G

gms

Newbie
super. das hat geholfen.

nach dem reconnect (rcnetwork restart hat funktioniert). ich konnte mich nach dem reconnect wieder ins internet einwählen.

danke für die promte hilfe!


für mich stellt sich jetzt nur die frage wie ich das automatisiere bzw ob es bessere tools gibt als kinternet, die die verbindung besser trennen oä?
 

Bonsai

Advanced Hacker
In ein script schreiben.

Such mal mit Goole nach Shellscript und schau Dir die Manuals zu sudoers und visudo an.
 
Oben