• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

Linux 8.1 Rechner als Windows Xp Client

Vorab möchte ich nur sagen das es mir natürlich bewusst ist das es andersrum natürlich besser wäre aber ich möchte es sorum machen.

Ich habe auf dem WinXP Rechner die gemeinsame Nutzung der internetverbindung aktiviert und beim Linux Rechner den WinXP Rechner sowohl als Standardgateway als auch als DNS Server eingetragen und trotzdem funktioniert die Geschichte nicht.

Greetz magoo
 

admine

Administrator
Teammitglied
mistermagoo schrieb:
Vorab möchte ich nur sagen das es mir natürlich bewusst ist das es andersrum natürlich besser wäre aber ich möchte es sorum machen.

Ich habe auf dem WinXP Rechner die gemeinsame Nutzung der internetverbindung aktiviert und beim Linux Rechner den WinXP Rechner sowohl als Standardgateway als auch als DNS Server eingetragen und trotzdem funktioniert die Geschichte nicht.

Greetz magoo

Hi,

trag einen DNS-Server von "draußen" ein, denn dein Xp hast sicher nicht als DNS-Server konfiguriert ;-)
 
OP
M

mistermagoo

Newbie
Hatte ich auch schon versucht, geht aber trotzdem nicht. In der Hilfe von Windoofs steht auch drin man soll als DNS Server die Adresse vom WinXP Rechner eintragen und keine von draussen (sprich bei mir der T-online DNS Server).

Ich weiss langsam echt nicht mehr an was es liegen könnte. Muss ich irgendwas spezielles als Domäne beim Linux Rechner eintragen oder als Domain suche?

Greetz Magoo

Edit: Giebt es auch noch andere Möglichkeiten? Evtl. den Xp Rechner als Proxy Server einrichten und darüber verbinden?
 

towo

Moderator
Teammitglied
mistermagoo schrieb:
Hatte ich auch schon versucht, geht aber trotzdem nicht. In der Hilfe von Windoofs steht auch drin man soll als DNS Server die Adresse vom WinXP Rechner eintragen und keine von draussen (sprich bei mir der T-online DNS Server).

Ich weiss langsam echt nicht mehr an was es liegen könnte. Muss ich irgendwas spezielles als Domäne beim Linux Rechner eintragen oder als Domain suche?

Greetz Magoo

Edit: Giebt es auch noch andere Möglichkeiten? Evtl. den Xp Rechner als Proxy Server einrichten und darüber verbinden?
Die Spielzeugfirewall von XP haste aber schon deaktiviert, oder?
Was kommt denn als Fehlermeldung?
was sagt ein /sbin/route?
was ein /sbin/ifconfig?
was ein ping 80.237.130.3?
 
OP
M

mistermagoo

Newbie
Also die Spielzeugfirewall von Windows habe ich natürlich deaktiviert.

ifconfig sagt mir das eth0 die Adresse 192.168.0.182 vom DHCP zugewiesen bekommen hat (netzwerkmaske 255.255.255.0)

Der Ping auf die angegebene IP 80.237.130.3 ergiebt nur das alle Packete verloren gegangen sind. In der Routing tabelle ist kein Eintrag vorhanden.

Greetz Magoo
 

towo

Moderator
Teammitglied
mistermagoo schrieb:
Also die Spielzeugfirewall von Windows habe ich natürlich deaktiviert.

ifconfig sagt mir das eth0 die Adresse 192.168.0.182 vom DHCP zugewiesen bekommen hat (netzwerkmaske 255.255.255.0)

Der Ping auf die angegebene IP 80.237.130.3 ergiebt nur das alle Packete verloren gegangen sind. In der Routing tabelle ist kein Eintrag vorhanden.

Greetz Magoo
Wo hast Du dann das Gateway angegeben? Wenn in der Routingtabelle nix drin steht, dann stimmt da aber auch nix!
 
OP
M

mistermagoo

Newbie
Den Gateway hab ich per Yast in der grafischen Konsole eingetragen. Das es in der Routing Tabelle nicht drin steht hat mich allerdings auch gewundert. Was soll ich denn in da eintragen bzw. wie kann ich einen Eintrag hinzufügen und welche Form muss das ganze haben?

Greetz Magoo

Edit: Ich hab ihn als Standard Route bei den Grundeinstellungen der Netzwerkkarte eingetragen.
 

admine

Administrator
Teammitglied
mistermagoo schrieb:
Den Gateway hab ich per Yast in der grafischen Konsole eingetragen. Das es in der Routing Tabelle nicht drin steht hat mich allerdings auch gewundert. Was soll ich denn in da eintragen bzw. wie kann ich einen Eintrag hinzufügen und welche Form muss das ganze haben?

Greetz Magoo

Edit: Ich hab ihn als Standard Route bei den Grundeinstellungen der Netzwerkkarte eingetragen.

Wenn du es mit YAST machen willst, dann so:
Netzwerkkarte wählen - Bearbeiten - Routing - StandardGateway => da die IP des XP-Rechner eintragen.
 

admine

Administrator
Teammitglied
mistermagoo schrieb:
Jo genau das habe ich gemacht und es geht trotzdem nicht....

Versuch doch mal feste IP's zu vergeben.
AFAIK bekommt der XP-Client bei Einstellen von ICS die IP 192.168.0.1
Somit gibst du dem Linux-Rechner mal die IP 192.168.0.2
 
OP
M

mistermagoo

Newbie
Also ich wäre ja nciht so verzweifelt wenn ich das nciht alles schon versucht hätte. Ich hatte schon feste IP´s vergeben und damit funktioniert es auch nicht.
 

admine

Administrator
Teammitglied
mistermagoo schrieb:
Also ich wäre ja nciht so verzweifelt wenn ich das nciht alles schon versucht hätte. Ich hatte schon feste IP´s vergeben und damit funktioniert es auch nicht.

Und DNS-Server aus dem Internet eingetragen?
Das Netzwerk zwischen XP und Linux funzt aber ??

PS: Wo stand eigentlich, dass du den XP-Rechner als DNS eintragen solltest ?
 
OP
M

mistermagoo

Newbie
Also ich bekomme einen Ping auf die Netzwerkadresse des XP Rechners (192.168.0.1) und auf die Internetadresse des XP Rechners auch. Das ich den XP Rechner als DNS Server eintragen soll stand auf einer Webseite die sich mit sowat beschäftigt. Alerdings ist der Tip wohl nix wert...*g*

die dns server hab ich auch eingetragen ( die 2 DNS server von t-online) was soll denn jeweils bei dem domainnamen hin und was bei domain suche (im yast)
 
Oben