• Der Linux-Club wurde auf eine modernere Forensoftware umgestellt und hat auch optisch einen neuen Anstrich erhalten. Weitere Details findest du im Beitrag "Update der Forensoftware 2022".

Mailserver mit SuSE 9.0

Status
Für weitere Antworten geschlossen.

selektor

Newbie
Hallo Leute !

Da ich hier in diesem Forum schon so viel Hilfe bekommen habe, egal ob aktiv durch direkte Antworten oder einfach nur durch lesen der Beiträge, möchte ich auch einen kleinen Beitrag leisten, LINUX an den Mann/Frau zu bringen.

Eine Anleitung zum "Bau" eines Mailservers mit Postfix könnt Ihr unter folgender Adresse finden:

http://www.edv-serr.de/postfix.htm

Ich gebe natürlich keine Garantie darauf, allerdings dürfte das Dokument verständlich genug sein.
Über Verbesserungsvorschläge bin ich natürlich dankbar.
Diese werde ich dann dort einbinden.

Viele Grüße und danke für das tolle informative Board!

Chris
 

Lestat

Newbie
Danke für dieses Nette howto !
Habe nur ein Problem !
Wenn ich die dateien ins Hash format umwandeln wil kommt folgender Fehler:
postfix[2528] : fatal : bad numerical configuration : message_size_limit = 10240000:q

was will der mir damit sagen was ist falsch und wo ?
kann mir da einer einen tip geben !
habe mich auch an die oben liegende Anleitung gehalten !
Habe jedoch fetchmail weggelassen was das ein reiner Intranet mailserver werden soll !

MFG
Lestat
 

Lestat

Newbie
Super Danke nun kann ich postmap benutzen !

Habe nur leider ein weiteres Problem !
ICh kann von meinem 2. Rechner aus keine mails versenden!
Also local geht das nicht quasie von benutzer zu benutzer !
Habe das Tut so verstanden das auf dem server für jeden benutzer der die mails abrufen oder verdenden will ein Konto angelegt werden muss !
Dies habe ich dann auch getan !
Da das nur ein Intranet ohne Internet anbindung ist reicht mir ja der interne Schriftverkehr !
Aber dieser will nicht , der sagt immer Wartende nachrichten konnten nicht versand werden !

Habe in Kmail unter Versand volgendes drin stehen :
Server: 192.168.1.1
port 25
Benutzer : soundso
PW: soundso

nun meine postfix main.cf:

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
myhostname = linuxserver
mydomain = oere.local
inet_interfaces = all
unknown_local_recipient_reject_code = 450
mynetworks_style = subnet
mynetworks = 192.168.1.0/24, 127.0.0.0/8
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin
setgid_group = maildrop
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/spool/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
program_directory = /usr/lib/postfix
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
content_filter =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 1000000000000
sender_canonical_maps =hash:/etc/postfix/sender_canonical
smpt_sasl_auth_enable = no

seht ihr da einen Fehler drin ?

MfG
Lestat
 
A

Anonymous

Gast
Hier die Adresse von einem weiteren nach meiner Meinung guten Mailserver Howto:
http://www.linux-tin.org/

Mfg. Mercedesdriver :)
 

pft

Advanced Hacker
wie verschickst Du denn die Mails, d.h. welche genauen Adressen verwendest Du?

Ich vermute evtl. ein Problem in deiner "$mydestination"-Einstellung. Es fehlt $mydomain, da du vermutlich deine Mails an soundso@$mydomain verschickst und nicht an soundso@$myhostname.

Right ?
 
Status
Für weitere Antworten geschlossen.
Oben