• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

Gelöst Manchmal kratziger Sound

BeastXXL

Hacker
Hallo,

ich habe manchmal und nur unter bestimmten Bedingungen ein Soundproblem. Sonst funktioniert der Sound einwandfrei und hört sich gut an.

Mein Problem:
Wenn ich mit Clementine ein Internetradio oder eine MP3 höre und dann in Firefox ein Tab mit gog.com oder deepl.com öffne, wird der Sound kratzig. Das gleiche passiert, wenn ich auf music.youtube.com ein Musikstück höre und eine der beiden Seiten öffne. Andere Internetseiten sind mir mit diesem Problem nicht aufgefallen.
Andersherum gibt's keine Probleme, d.h., wenn eine der beiden Seiten offen ist und dann erst wie beschrieben Musik abgespielt wird, klingt alles normal. In diesem Fall, kann ich die Tabs auch wieder schließen und wieder öffnen während die Musik weiter läuft. Keine Veränderung.

Hier ein paar Infos zu meinen Audiogeräten, dessen Befehle ich auf die Schnelle gefunden habe:
Code:
beastxxl@linux-5099:~> cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfce60000 irq 97
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfc900000 irq 98
beastxxl@linux-5099:~> aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA ATI HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 9: HDMI 3 [HDMI 3]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 10: HDMI 4 [HDMI 4]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 11: HDMI 5 [HDMI 5]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 0: ALC892 Analog [ALC892 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
beastxxl@linux-5099:~> sudo lspci | grep -i audio
[sudo] Passwort für root:
26:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
28:00.4 Audio device: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller
beastxxl@linux-5099:~> head -n 1 /proc/asound/card0/codec*
Codec: ATI R6xx HDMI
beastxxl@linux-5099:~> head -n 1 /proc/asound/card1/codec*
Codec: Realtek ALC892
beastxxl@linux-5099:~> lsmod | grep snd
snd_hda_codec_realtek   159744  1
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
ledtrig_audio          16384  1 snd_hda_codec_generic
snd_hda_codec_hdmi     73728  1
snd_hda_intel          53248  7
snd_intel_dspcfg       28672  1 snd_hda_intel
soundwire_intel        45056  1 snd_intel_dspcfg
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          106496  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_soc_core          303104  1 soundwire_intel
snd_compress           28672  1 snd_soc_core
snd_pcm_dmaengine      20480  1 snd_soc_core
snd_pcm               159744  9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_compress,snd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd_timer              40960  1 snd_pcm
snd                   110592  23 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore              16384  1 snd
beastxxl@linux-5099:~>
Achso, ich höre den Sound/die Musik hauptsächlich über den Mainboard-Chip (also Realtek ALC892). Die Grafikkarte benutze ich nur, wenn ich etwas über die Monitor-Lautsprecher hören möchte. Und das kommt nur selten vor.

Kann man da was machen?

Danke schon mal im Voraus für eure Hilfe oder Tipps.
 

Christina

Moderator
Teammitglied
Hier ein paar Infos zu meinen Audiogeräten, dessen Befehle ich auf die Schnelle gefunden habe:
Hi!
Wichtig ist auch die verwendete Linux-Distribution.
Ergänze das bitte noch im Thema: Oben auf das 3 Punkte-Menü [ ⋯ ▾ ] klicken und dann "Thema bearbeiten".

Welche Firefox-Version verwendest du?
Tritt das Problem auch bei anderen Webbrowsern auf?

Guter Hinweis!
@BeastXXL
Poste bitte ebenfalls die Ausgabe von inxi -Aa.
 

Burkhard

Member
Hallo,

dieses Problem hatte ich auch. Die Ursache herauszufinden, war nur durch Versuch und Irrtum möglich. Wenn ich Musik hörte und im Firefox surfte, war es besonders schlimm. Unter diversen Linux Distributionen war es unterschiedlich schlimm. Leap schnitt dabei mit Pipewire noch am besten ab. Ich habe viele Stunden im Netz verbracht, um zu recherchieren und den Fehler einzukreisen. Als erstes habe ich alle Kabel durch höherwertige Kabel ausgetauscht. Dann habe ich verschiedene Soundkarten ausprobiert, hatte zwei externe USB Karten zur Verfügung und eine interne original Soundblaster. Also USB ist bei mir extrem auffällig und anfällig durch Knacken und Störgeräusche aufgefallen. Eine externe USB Sound Karte würde ich mir nie wieder kaufen. Die interne Soundblaster saß direkt zwischen dem Prozessor und der Grafikkarte. Wenn ich die Lautstärke zu hoch drehte, waren die Störgeräusche besonders stark. Allerdings auch nur beim Surfen oder Scrollen mit dem Firefox. Bei dem Chromium Browser war es gut, fast weg. Dann habe ich die Soundblaster Boxen ausgetauscht gegen Wavemaster mit Subwoofer und 50 Watt, die seit Jahren immer wieder bei Test's gut abschnitten. Dann erinnerte ich mich, das auf dem hochwertigen Motherboard einen 7 Kanal VIA Soundchip hatte, den ich dann einfach im BIOS aktivierte. Seltsamerweise war der in der Soundqualität der allerbeste. Störungen traten nur noch selten oder sporadisch auf.Dann habe ich konsequent den externen Klangregler des Wavemaster auf höchstens mittlere Lautstärke heruntergepegelt. Nun waren alle Störungen zumindest nicht mehr wahrnehmbar. Drehe ich den wieder hoch, werden alle Geräusche, die auch im PC entstehen, also auch Laufwerkgeräusche einer klassischen HD auf die Lautsprecher übertragen. Was nun die eigentliche Ursache ist, kann ich nicht endgültig mit Bestimmtheit sagen.Zumindest habe ich durch Versuch und Irrtum jetzt erstmal Ruhe, die Klangqualität ist bestens bei mittlerer Lautstärke. Diese Probleme treten bei vielen Usern auf, wie ich durch meine Recherchen erfuhr. In keinem Fall aber konnte eindeutig bestimmt werden, werden, wer denn der Störenfried wirklich war. Es können auch Störungen im Stromnetz sein, die sich negativ auswirken. Angeblich sollen Netzfilter, die durchaus etwas teuer sind, Abhilfe schaffen. Ausprobiert habe ich das nicht. Leider konnte ich Dir nur meine Erfahrungen mitteilen, eine Lösung habe ich auch nicht. Und welcher Normaluser hat schon ein Labor zu Hause mit Messgeräten ....

Gefühlt war die Soundqualität unter Pipewire immer etwas besser.

Gruß Burkhard
 
OP
B

BeastXXL

Hacker
Hallo,

Hier die Infos:
Firefox Vers. 91.11.0esr (64bit)
Code:
beastxxl@linux-5099:~> uname -a
Linux linux-5099 5.3.18-150300.59.87-default #1 SMP Thu Jul 21 14:31:28 UTC 2022 (cc90276) x86_64 x86_64 x86_64 GNU/Linux
beastxxl@linux-5099:~> inxi -Aa
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: ASUSTeK driver: snd_hda_intel
           v: kernel bus ID: 26:00.1 chip ID: 1002:aaf0
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
           v: kernel bus ID: 28:00.4 chip ID: 1022:1487
           Sound Server: ALSA v: k5.3.18-150300.59.87-default
beastxxl@linux-5099:~>
Folgende Tests habe ich gemacht (Clementine; Internetradio; die beiden problematischen Seiten aufgerufen):
Soundausgabe über die Grafikkarte (und Monitor) --> kein kratziger Sound
Soundausgabe über Mainboardchip und Verwendung vom Falkon-Browser --> kein kratziger Sound
Soundausgabe über Mainboardchip und Verwendung vom Midori-Browser --> kein kratziger Sound
Unter Windows (selbe Setting wie bei openSuse):
Soundausgabe über Mainboardchip und Verwendung von Firefox (Vers. 102) --> kein kratziger Sound

Fehlt noch ein Test oder eine Info?
 

Burkhard

Member
Halten wir doch ein mal fest und fassen zusammen:

Bei gleicher Hardwareausstattung gibt es bei unterschiedlichen Distris auch unterschiedliche Soundqualität und unterschiedliche Klangerlebnisse.

Firefox macht in einigen Distros große Probleme (Knistern, Störungen), in anderen eben nicht. Bei mir war das so.

Andere Browser verhalten sich normal.

Nun benutze ich openSUSE Leap 15.4 mit Pipewire. Gute Klangqualität, keinerlei Störungen, auch nicht beim Surfen oder scrollen im Firefox.

Herauszufinden, warum das so ist, ist unheimlich schwierig. Es kann ja auch nur in einer bestimmten Version von Firefox Probleme geben, das habe ich überhaupt nicht bedacht. Es könnte ein Bug sein .... wenn es mit anderen Browsern vernünftig funktioniert. Alles ist möglich.

Das erste, was ich nach einer Neuinstallation von Leap mache, das ich die bevorzugte Soundkarte konfiguriere. Dazu benutze ich YAST.

Das Schöne ist, das Du unter Linux ja die Wahl hast und auf den Firefox nicht angewiesen bist.

Gruß Burkhard
 
OP
B

BeastXXL

Hacker
Hallo Burkhard,

ja, evtl. versuche ich Pipewire, allerdings scheint es mir so, als wäre es eine zusätzliche Schicht im Linux-Soundsystem. Ähnlich wie Voicemeeter für Windows?!

Ich habe das Gefühl, dass Firefox bei manchen Webseiten mit dem Linux-Soundtreiber in die Quere kommt, wenn die Webseite NACH der Anwendung geladen wird, die momentan auf den Soundchip zugreift. Wenn die Seite VORHER geladen wurde, ist der Treiber nicht vermurkst oder der Chip nicht durcheinander. Bei deepl.com könnte ich mir das sogar vorstellen, weil sie auch eine Sprachausgabe hat. Bei gog.com habe ich keine Erklärung in dieser Art. Andererseits hat dict.cc auch eine Sprachausgabe, aber da ist der Sound vollkommen in Ordnung (selbst wenn ich die Sprachausgabe gleichzeitig mit der Musik abspiele).

Wenn also Pipewire nicht auch einen anderen bzw. besseren Treiber für den Soundchip hat, habe ich die Befürchtung, dass es keine Besserung bringt.

Tatsächlich habe ich mich schon nach einer Alternative zu Firefox umgesehen, finde aber alle open-source-Alternative, die in den Standard-Repos sind, doof (chromium habe ich absichtlich nicht ausprobiert). Ich würde gern IceCat oder Waterfox ausprobieren, die sind aber nicht in den Repos drin...

Die letzte Möglichkeit wäre noch die alte Soundblaster-Soundkarte einzubauen, ich würde es aber vorziehen, das Problem über die Software zu lösen, da mir der Aufwand im Vergleich zum Problem zu groß erscheint.

Nachtrag: pipewire ist bereits bei mir installiert. Wie finde ich jetzt heraus, ob es mir bei meinem Problem hilft?
 

Burkhard

Member
Hallo BeastXXL,

ich habe ein ziemlich gutes musikalisches Gehör und spüre auch feinste Unterschiede, die manch Anderer nicht wahrnimmt. Ich liebe Musik. Und deshalb wäre der Zustand, den ich ja auch monatelang ertragen habe, auf Dauer nicht akzeptierbar gewesen. Gottlob ist bei mir alles wieder in Ordnung, es gibt nicht nur keinerlei Störungen mehr, sondern der Klang ist glasklar und eine helle Freude. Hab ja auch lange genug getestet und probiert. Aber ehrlicherweise kann ich immer noch nicht mit Bestimmtheit sagen, wo die eigentlichen Ursachen liegen. Alles Wissen, auch durch Erfahrung, ist nur Vermutung und wie ich bereits schrieb, durch Versuch und Irrtum erworben worden.

Bei Soundsystemen habe ich alles ausprobiert, von OSS, ALSA, JACK, Pulseaudio bis Pipewire. Für meine Ohren hat Pipewire tatsächlich am besten abgeschnitten, Höhen und Tiefen waren irgendwie voluminöser, Bässe im Subwoofer kräftiger. Das kann keine Einbildung sein. Da ich weder Tontechniker noch Elektroingenieur bin, werde ich die Ursache wohl auch nicht finden. Tatsächlich gehören mit openSUSE Leap 15.4 und Pipewire meine Soundprobleme nunmehr der Vergangenheit an.

Ob Pipewire bei der Bewältigung oder Beseitigung Deiner sporadisch auftretener Soundstörungen hilft, kannst Du Dir nur selbst beantworten. Da kann ich leider aus der Ferne auch keine Diagnose zu abgeben.

Selber würde ich, wenn es keine andere Möglichkeit mehr gibt, dann letztendlich auch den Browserwechsel in Betracht ziehen. Und das der Firefox von den Marktanteilen gegenüber dem Chromium nur noch als Nischenprodukt bezeichnet werden kann, das wirst Du wohl selber wissen.

Mit JACK habe ich auch gute Erfahrungen gemacht. Wahrscheinlich machen die niedrigeren Latenzen den Unterschied. Nochmal, ich bin kein ausgewiesener Experte, kann aber (hoffentlich) noch logisch denken. Aber ob meine Rückschlüsse und Entscheidungen verallgemeinerbar sind, möchte ich nicht behaupten. Mir war es trotzdem wichtig, meine Erfahrungen mit Dir zu teilen, auch wenn ich Dir leider keine Lösung anbieten kann.

Gruß Burkhard
 
OP
B

BeastXXL

Hacker
Hallo Burkhard,

danke für deine Erfahrungsmitteilung.
Mir würde es schon helfen zu wissen, wie ich die Soundströme testweise nur über pipewire leiten kann. Ich bin ehrlich, ich habe kaum ein Wort verstanden, was ich im Netz darüber gefunden habe. Auch die Frage, ob ich dazu die Pakete gstreamer-plugin-pipewire, pipewire-alsa und/oder pipewire-pulseaudio benötige.
Und die Frage, ob bzw. wie ich die kleinen Tools alsamixer und pavucontrol weiter benutzen kann.
 

Burkhard

Member
Hallo BeastXXL,

gerne, hier eine Kurzanleitung, wie ich Pipewire aktiviert habe.

Pipewire selbst ist bereits installiert. Du solltest aber folgende Pakete nachinstallieren:

  • pipewire-alsa
  • gstreamer-plugin-pipewire
  • pipewire-pulseudio
Bei dem Paket pipewire-pulseaudio kommt ein Dialog, das es Konflikte gibt, und es werden 2 Lösungen angeboten. Bitte die erste Lösung auswählen und bestätigen, das alle pulseaudio Pakete gelöscht werden sollen. Es werden dann auch alle Pulseaudio Pakete gelöscht, das ist auch OK so.

Dann in der Konsole (nicht als root) folgende Service aktivieren und starten:

Code:
systemctl --user enable --now pipewire.socket # or pipewire.service

systemctl --user enable --now wireplumber.service

Rechner neu starten. Pipewire wird automatisch gestartet und benutzt.

Kontrollieren kannst Du es mit

Code:
pactl info

Es sollte folgende Ausgabe geben:

Code:
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 53
Tile Size: 65472
User Name: ralph
Host Name: linux.fritz.box
Server Name: PulseAudio (on PipeWire 0.3.49)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Default Source: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
Cookie: 205b:5cb5

Aha Pipewire läuft.

Ich stelle dann als Audiowiedergabe alle Audio/Videoplayer auf ALSA. Ich verwende den KDE Desktop, da benötige ich kein Pavucontrol, denn im Lautstärkeregler - unter Anwendungen wird mir dann auch angezeigt, das beim VLC oder Audiacious Pipewire benutzt wird. Du kannst Pavucontrol auf jeden Fall auch weiter benutzen, wenn es bereits installiert wird. Alsamixer funktioniert auch weiterhin, ich bevorzuge aber die Lautstärkeregler der jeweiligen Desktop. Das alles ist ausgiebig getestet und funktioniert bei mir einwandfrei.

Gruß Burkhard
 
Zuletzt bearbeitet:
OP
B

BeastXXL

Hacker
Hallo Burkhard,

ok, das hört sich ziemlich einfach an, so dass ich es die Tage mal ausprobieren werde. Pavucontrol brauche ich nur, um die Balance zwischen rechts und links einfach zu justieren (ist bei mir wichtig). Kann ich auch über alsamixer machen (was auch mein Backup dafür ist), aber über pavucontrol geht's einfacher. Die Lautstärke regel ich auch über die Desktop-Lautstärke (Systemabschnitt in der Kontrollleiste) bzw. Shortcuts.

Eine Frage habe ich aber noch: Du sagst,
Ich stelle dann als Audiowiedergabe alle Audio/Videoplayer auf ALSA.
Wie machst du das genau?

Und noch eine Frage fällt mir ein: Welchen Service würdest du eher starten: socket oder service?
Danke und Gruß.
 
Zuletzt bearbeitet:

Burkhard

Member
Hallo,

socket oder service, das ist völlig egal. Ich nehme socket.

Es gibt ja bekannterweise viele Audio und Videoplayer. Ich kann hier nur stellvetretend für Audacious und VLC sprechen.
Beim VLC läßt sich die Audioausgabe folgendermaßen konfigurieren:

Werkzeuge - Einstellungen - Reiter Audio - Bereich Ausgabe - Output Module. Wenn ich das auf ALSA-Audioausgabe umstelle, steht auch unter Gerät: Default ALSA Output (Currently PipeWire-Media-Server). Standardmäßig ist der VLC auf Pulseaudio eingestellt. Wenn Du bei der Audio Ausgabe etwas verkehrtes einstellst, kommt einfach kein Ton.

Bei Audacious:

Ausgabe - Audio-Einstellungen - Ausgabeeinstellungen - Ausgabe-Plugin: ALSA Ausgabe. Steht standardmäßig auf automatisch, heißt auch Pulseaudio.

Wie das jetzt bei Browsern ist, muß Du selbst recherchieren. Da ich aber mit firefox einen guten Klang habe, wird es automatisch funktionieren. So, nun interessiert mich natürlich, ob Deine Störungen unter PipeWire weg sind.

So mehr kann ich nicht beitragen, ich hoffe, es hat Dir weiter geholfen. Viel Erfolg.

Gruß Burkhard
 
Zuletzt bearbeitet:
OP
B

BeastXXL

Hacker
Hallo,

so, jetzt konnte ich mich (endlich) wieder mit dem Problem beschäftigen und es gibt recht gute Ergebnisse.

Ich habe mich an deine Anleitung gehalten und mit wireplumber ein Problem bekommen, da openSuse keine Datei kennt, die so heißt. Und in der YAST Softwareverwaltung habe ich auch keine solche Datei gefunden. Wo bekomme ich die her, wenn nicht aus den Standard-Repos bzw. Packman? Und ist die wirklich notwendig?

Nach dem Neustart habe ich die Installation überprüft und folgendes zurückbekommen:
Code:
beastxxl@linux-5099:~> pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 73
Tile Size: 65472
User Name: beastxxl
Host Name: linux-5099
Server Name: PulseAudio (on PipeWire 0.3.24)
Server Version: 14.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_28_00.4.analog-stereo
Default Source: alsa_input.pci-0000_28_00.4.analog-stereo
Cookie: 1f95:8a68
beastxxl@linux-5099:~>
Scheint also funktioniert zu haben und Sound höre ich auch (mit clementine, VLC und im Browser getestet). Insgesamt scheint pipewire einen stärkeren Output zu haben, denn unter pulseaudio musste ich die max. Lautstärke auf 150% hochdrehen. Nun reicht eigentlich "schon" 100%.
Eine der besten Nachrichten: das Problem mit dem kratzigen Sound ist behoben. Wenn ich Musik höre und eine der beiden Web-Seiten aufrufe, bleibt alles normal.:D

An einem Problem habe ich etwas herumgekaut: Audacity wollte nicht den Sound aufnehmen, den ich gerade höre. Bei dem (Aufnahme)-Monitor und auch akustisch hörte ich bei Audacity nur statisches Rauschen, wenn ich den Monitor mit einem Klick aktivierte. Das Rauschen kam von meinem angeschlossenen, aber ausgeschalteten Mic. Audacity hatte auf dem falschen Kanal gelauscht. Nach dem ich in pavucontrol das Standard-Eingabegerät auf den Monitor vom Mainboard-Soundchip (Realtek) eingestellt hatte, lauscht Audacity wieder auf dem richtigen Kanal.

Also abgesehen von wireplumber ist die Operation geglückt.
Danke für den Hinweis auf pipewire! (y)
 

Burkhard

Member
Hallo BeastXXL,

schön, das es endlich funktioniert und geklappt hat. Darüber freue ich mich mit Dir. Wireplumber ist bereits installiert, so war es zumindest bei mir.

Gruß Burkhard
 
OP
B

BeastXXL

Hacker
Hallo Burkhard,

lt. dieser Web-Seite openSUSE Software ist wireplumber nur bei Tumbelweed in den offiziellen Repos. Naja, so lange es läuft, werde ich es (vermutlich) nicht brauchen. Nur, dass die Konfiguration über .conf-Dateien stattfindet, stört ein wenig das schöne Bild.

Jetzt würde ich mir eigentlich nur noch eine Art Voicemeeter für Linux wünschen...:cool:

Auf jeden Fall Danke für die Hilfe!
 

Burkhard

Member
Hallo Burkhard,

lt. dieser Web-Seite openSUSE Software ist wireplumber nur bei Tumbelweed in den offiziellen Repos. Naja, so lange es läuft, werde ich es (vermutlich) nicht brauchen. Nur, dass die Konfiguration über .conf-Dateien stattfindet, stört ein wenig das schöne Bild.

Jetzt würde ich mir eigentlich nur noch eine Art Voicemeeter für Linux wünschen...:cool:

Auf jeden Fall Danke für die Hilfe!

Hallo,

sehr gerne. Wireplumber, ich schrieb es bereits ist bei mir (Leap 15.4) bereits mitinstalliert worden.
Guckst Du hier:

Code:
zypper search wireplumber

ergibt:

Code:
S | Name                 | Summary                                       | Type
--+----------------------+-----------------------------------------------+------
i | libwireplumber-0_4-0 | Session / policy manager implementation for-> | Paket
i | wireplumber          | Session / policy manager implementation for-> | Paket
i | wireplumber-audio    | Session / policy manager implementation for-> | Paket
  | wireplumber-devel    | Session / policy manager implementation for-> | Paket

Als Voicemeter kenne ich nur pavumeter und meterbridge. Letzteres funktioniert aber wohl nur mit JACK.

Gruß Burkhard
 

Burkhard

Member
Hallo,

offensichtlich funktioniert wireplumber. Beispiel:

Code:
pw-cli list-objects Device

in der Konsole bei mir ergibt:

Code:
id 44, type PipeWire:Interface:Device/3
         object.serial = "45"
         factory.id = "14"
         client.id = "34"
         device.api = "alsa"
         device.description = "GP108 High Definition Audio Controller"
         device.name = "alsa_card.pci-0000_01_00.1"
         device.nick = "HDA NVidia"
         media.class = "Audio/Device"
    id 45, type PipeWire:Interface:Device/3
         object.serial = "46"
         factory.id = "14"
         client.id = "34"
         device.api = "alsa"
         device.description = "Built-in Audio"
         device.name = "alsa_card.pci-0000_00_1b.0"
         device.nick = "HDA Intel MID"
         media.class = "Audio/Device"

Selber benötige ich wireplumber (zur Zeit) nicht. Müßte mich auch einarbeiten.

Gruß Burkhard
 
OP
B

BeastXXL

Hacker
Wireplumber, ich schrieb es bereits ist bei mir (Leap 15.4) bereits mitinstalliert worden.
OK, dann scheint meine zitierte Web-Seite nicht ganz aktuell zu sein. Bei 15.3 ist es definitiv nicht dabei.
Als Voicemeter kenne ich nur pavumeter und meterbridge. Letzteres funktioniert aber wohl nur mit JACK.
Vorsicht, Voicemeeter ist deutlich mehr als nur ein Pegelanzeiger. Damit wird die Audio-"Organisation" unter Windows ein Kinderspiel.

Nachtrag: Ich habe gerade gesehen, dass an einer Adaption von Voicemeeter für Linux gearbeitet wird. Nennt sich pulsemeeter
Jetzt muss das nur noch problemlos mit pipewire zusammenarbeiten...
 
Zuletzt bearbeitet:

tomm.fa

Administrator
Teammitglied
Wireplumber, ich schrieb es bereits ist bei mir (Leap 15.4) bereits mitinstalliert worden.
OK, dann scheint meine zitierte Web-Seite nicht ganz aktuell zu sein. Bei 15.3 ist es definitiv nicht dabei.
Bei openSUSE Leap 15.3 ist es auch noch nicht in den offiziellen Repositorien. Wireplumber wird aber über download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.3/ bereitgestellt.
Dazu sei jedoch gesagt, dass es Komplikationen geben kann, wenn die Repositorien von Multimedia:Libs und PackMan zusammen verwendet werden.
 
OP
B

BeastXXL

Hacker
Dazu sei jedoch gesagt, dass es Komplikationen geben kann, wenn die Repositorien von Multimedia:Libs und PackMan zusammen verwendet werden.
Gut zu wissen. Danke. Dann werde ich mich nicht darum reißen, v.a. da es bei mir auch so funktioniert.
Sollte es dann tatsächlich in den offiziellen Repos sein, dann werde ich es noch (nach-)installieren.
 
Oben