Problem bei Installation von ndiswrapper

psyxl

Newbie
Bin nach folgender Seite bei der Installation von diswrapper vorgegangen:

http://www.linux-infopage.de/show.php?page=berichte-ndiswrappercentrino

Beim Befehl make install erhalte ich folgende Fehlermeldung:

linux:/home/psyxl/ndiswrapper/ndiswrapper-1.10 # make install
make -C driver install
make[1]: Entering directory `/home/psyxl/ndiswrapper/ndiswrapper-1.10/driver'
Can't find kernel sources in /lib/modules/2.6.13-15-default/build;
give the path to kernel sources with KSRC=<path> argument to make
make[1]: *** [prereq_check] Fehler 1
make[1]: Leaving directory `/home/psyxl/ndiswrapper/ndiswrapper-1.10/driver'
make: *** [install] Fehler 2
linux:/home/psyxl/ndiswrapper/ndiswrapper-1.10 #

Wer kann mir helfen?
 

Grothesk

Ultimate Guru
Das Paket 'kernel-source' nachinstallieren.

update: 02.04.2004 | aktualisiert auf Ndiswrapper 0.6
Die Anleitung ist ja uralt... Bist du sicher, das das alles noch so funktioniert wie dort beschrieben? Ich nämlich nicht.. Mittlerweile sind nämlich die Treiber für die Centrino-Geschichten ganz anders zu installieren...
 

psyxl

Newbie
Bin absoluter Newbee, wie mach ich das? :oops:

edit:
Habe keine aktuellere Anleitung gefunden. Nehme es auch nur als groben Leitfaden, habe ein anderes WLAN.

edit2:
Habe jetzt herausgekriegt wie ich das nachinstalliere. Für eine aktuelle Anleitung, wie ich mein Medion WLAN MD40900 zum Laufen kriege bin ich dennoch dankbar :)
 

psyxl

Newbie
Nachdem ich den kernel-source installiert habe bekomme ich nun folgende Fehlermeldung:

linux:/home/psyxl/ndiswrapper/ndiswrapper-1.10 # make install

make -C driver install

make[1]: Entering directory `/home/psyxl/ndiswrapper/ndiswrapper-1.10/driver'

make -C /lib/modules/2.6.13-15-default/build SUBDIRS=/home/psyxl/ndiswrapper/ndi
swrapper-1.10/driver \

DRIVER_VERSION=1.10

make[2]: Entering directory `/usr/src/linux-2.6.13-15-obj/i386/default'

make -C ../../../linux-2.6.13-15 O=../linux-2.6.13-15-obj/i386/default

/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: gcc: command not found

/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: gcc: command not found

make[4]: gcc: Kommando nicht gefunden

grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verze ichnis nicht gefunden

LD /home/psyxl/ndiswrapper/ndiswrapper-1.10/driver/built-in.o

grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verze ichnis nicht gefunden

grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verze ichnis nicht gefunden

grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verze ichnis nicht gefunden

grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verze ichnis nicht gefunden

grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verze ichnis nicht gefunden

CC [M] /home/psyxl/ndiswrapper/ndiswrapper-1.10/driver/hal.o

/bin/sh: gcc: command not found

make[5]: *** [/home/psyxl/ndiswrapper/ndiswrapper-1.10/driver/hal.o] Fehler 127

make[4]: *** [_module_/home/psyxl/ndiswrapper/ndiswrapper-1.10/driver] Fehler 2

make[3]: *** [_all] Fehler 2

make[2]: *** [all] Fehler 2

make[2]: Leaving directory `/usr/src/linux-2.6.13-15-obj/i386/default'

make[1]: *** [default] Fehler 2

make[1]: Leaving directory `/home/psyxl/ndiswrapper/ndiswrapper-1.10/driver'

make: *** [install] Fehler 2

linux:/home/psyxl/ndiswrapper/ndiswrapper-1.10 #
 

psyxl

Newbie
Danke, hätte ich auch selber drauf kommen können. :roll:

Habe jetzt ndiswrapper installiert.

Nachdem ich mit dem Befehl, ndiswrapper -i wlanuig versuche den Treiber zu installieren, bekomme ich die Meldung: couldn't copy wlanuig at /usr/sbin/ndiswrapper line 135.

Er führt den Treiber aber dennoch unter Installed Driver auf, nur mit dem Status Invalid.

edit:
Bei der Installation hat er mir mehrfach folgende Zeile ausgeworfen:
grep: /lib/modules/2.6.13-15-default/build/include/linux/usb.h: Datei oder Verzeichnis nicht gefunden.

Wenn ich den Befehl modprobe ndiswrapper angebe, erhalte ich die Meldung:
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.13-15-default/extra/ndiswrapper.ko): Operation not permitted

Habe das Gefühl, dass ndiswrapper nicht sauber installiert ist.
 
Oben