smpppd läuft nicht

beltze

Newbie
hallo leute,

bin ein super-neuling und habe suse 9.0 auf meinem rechner aufgesetzt. bin auch schon mal erfolgreich ins netz gekommen. aber jetzt kommt bei dem verbindungsversuch mit kinternet "smpppd läuft nicht oder der user ist kein mitglied der gruppe dialup". in der gruppe dialup bin ich aber, also was tun? verwende ein alcatel ethernet modem. provider aon (österreich), zugang via adsl.

danke für alle kommenden infos!
 
A

Anonymous

Gast
Hallo,

also du machst ne shell auf und gibst su ein
danach das root passwort.
dann schreibst du /etc/init.d/smpppd start
dann sollte sich der dienst starten.

dann kehrst du zum desktop zurück und öffnest kinternet, wenn du es gleich danach wieder schliesst wirst du gefragt ob du es beim start automatisch öffnen willst (oder so) -> mit ok bestätigen.

mfg
edding400
 

walther

Newbie
Hallo, das selbe Problem hatte ich auch und habe es auf diese weise
gelöst. Nur wie starte ich diesen Dienst bei jedem Systemstart automatisch?
Kann mir da jemand weiterhelfen? Das mit dem Automatisch öffenen betrifft bei mir nur das kinternet programm.
 

Paulchen

Member
Hallo Walter,

Du kannst smpppd wie folgt dauerhaft aktivieren:
Wechsel in die Konsole (die Muschel in der Kontrolleiste) und Anmelden als Superuser
Eingabe:su <Enter>
Eingabe:passwort <Enter>
Eingabe:rcsmpppd start <Enter> (aktiviert smpppd)
Eingabe: insserv smpppd <Enter> (damit bleibt smpppd dauerhaft aktiviert).

Laß Dir auch mal mit der Suchfunktion die Postings listen. Dort erhältst Du mehr Informationen.


Paulchen
 

scooter

Newbie
Hi Z'sammen,
das gleiche Problem hatte ich auch bei der 9.1 Version, 9.0 ohne Problem.
Habe es auf die von Paulchen beschriebene Version beseitigt.
Was aber immer noch nicht funktioniert, ist die automatische Abwahl nach einer bestimmten Zeit ohne Traffic. In welcher Datei würde diese Einstellung auftauchen und mit welchem Parameter/Befehl?

Bye
Scooter
 

Bonsai

Advanced Hacker
Gibts das da nicht? :shock: Unter Einstellungen oder so? Hab kein Kinternet am laufen, hatte aber mal an einem Schlepptop damit gebastelt. Dann im Yast.
 

scooter

Newbie
Im Yast habe ich es konfiguriert, aber darauf reagiert er nicht. Deswegen die Frage nach Parameter, Wert und in welcher config Datei.

Bye
Scooter
 

linfux

Newbie
smpppd kann man auch unter YaST - System - Runlevel-Editor im einfachem Modus aktivieren oder im Expertenmodus bestimmen, ab welchen Runleveln das Teil zu starten hat... soweit ich das herauskrebsen konnte (bin auch Neuling und XP - Umsteiger) - jedenfalls hatte ich dieselbe Fehlermeldung und seit dieser Umstellung läufts bunderwar ;-)

Übrigens sehr konkurrenzfähig zu XP, dieses SuSe 9.1, ein paar Mucken hat es schon noch, aber da bin ich von Windows gaaanz andere Sachen gewöhnt... :roll: ..hab schon seit Win 95 graue Haare... :mrgreen:
 

Paulchen

Member
Die Einstellungen für kinternet können als root in /etc/sysconfig/network/providers/provider0 geändert werden.

DEMAND='yes' für Dial on Demand
und
IDLETIME='Zeit in Sekunden'
für Trennen der Verbindung.

Gruß Paulchen
 

scooter

Newbie
@paulchen
Den Eintrag IDLETIME='Zeit in Sekunden' habe ich Handbuch nach langem suchem gefunden. Habe mir die Datei unter /etc/sysconfig/network/providers/provider0 (bei mir steht tonline anstelle provider0) angeschaut und der Eintrag IDLETIME='240' war vorhanden. Trotzdem wählt sich die Kiste nicht ab. Kann es sein das unter der Suse 9.1 es nur in Verbindung mit DEMAND='yes' für Dial on Demand funktioniert? Wäre bei ISDN und ohne Flat ziemlich sch....!

Bye
Scooter
 

Paulchen

Member
@scooter,

bei mir funtioniert die automatische Trennung (bei DSL) ohne Dial on Demand.
Laß Dir mal den Traffic anzeigen. Kannst Du in der Konsole als su mit pppstats. Optionen zu pppstats findest Du in den man-pages.
pppstats -w[Zeit in Sekunden] gibt im gewählten Intervall alle x Sekunden eine Zeile aus, in der Traffic für Up- und Download angezeigt wird.

Das hilft zwar nicht weiter, wenn das Problem wirklich bei smpppd liegt. Würde ich aber als erstes versuchen. Damit kannst Du ausschließen, daß bei korrekter Konfiguration die Trennung deshalb nicht erfolgt, weil über irgendeinen Dienst Traffic erzeugt wird.

Paulchen
 

scooter

Newbie
@paulchen
habe anstelle pppstats, ipppstats (da isdn) laufen lassen und tatsächlich gingen IP Packet raus, aber es funktioniert jetzt doch. Werde die idletime noch etwas nach unten korrigieren. Vielen Dank!

Bye
Scooter
 
Oben