[solved] Anderer Textmodus als 80x25

Tron04

Newbie
Hallo,

Wie kann man einen anderen Textmodus als 80x25 im nur Textmodus (runlevel 3) einstellen?

Ich habe GRUB schon soweit konfiguriert bekommen das 80x43 dargestellt wird (VGA=EXT in menu.lst) während des Bootvorgangs. Diese Einstellung hält allerdings nicht lange vor. Kurz vor dem Login-Prompt schaltet der Bildschirm wieder auf 80x25.

Was muss getan werden, damit die 80x43 bestehen bleibt? :?
 
OP
Tron04

Tron04

Newbie
Sorry, leider bin ich wohl etwas zu newbie...

Habe ein paar Startoptions probiert, aber das Problem bleibt wie oben beschrieben bestehen. Rechner bootet im angegebenen Modus, aber kurz vor dem Login wird auf 80x25 zurückgeschaltet.
Ich glaube das passiert nach dem Laden des Bildschirmfonts.

Hat jemand ein paar genauere Anweisungen für mich?
 
A

Anonymous

Gast
Was Wenf dir damit sagen wollte (glaube ich :wink: ) ist folgendes:

tippe mal bei vga=xy am Bootprompt einen Wert, der zu deiner Bildschirmauflösung passt ein. Die entsprechenden Werte findest du unter wenf's Link.

Eventuell könntest du es zusätzlich noch mit folgender option versuchen (sollte aber unnötig sein):

video=fbdev vga=wasauchimmer
 
OP
Tron04

Tron04

Newbie
Sorry es funktioniert auch mit dem obigen Tipp nicht.

Die Rückschaltung auf 80x25 geschieht ungefähr bei diesem Vorgang:
"Loading console font lat1-16.psfu -m none"

Vorher existiert wie gesagt der gewünschte Modus.

Bin leider immer noch ratlos. Wahrscheinlich eine triviale Einstellung... Aber wo...?
 

wenf

Hacker
sorry, dass ich nicht genauer geantwortet habe

bei mir sieht die zeile etwas anders aus
(die mit loading font)

habe SuSE 9.0
brauchst du die Konsolen Fonts ?
wenn nicht deaktivere sie mal - und schaue ob es daran liegt
 
OP
Tron04

Tron04

Newbie
OK, habe etwas Forschung betrieben und bin nun zu folgenden Ergebnissen gekommen:

Wenn Linux mit einem Framebuffer gestartet wird (also z.B. VGA=0x314), dann bleibt die Auflösung auch nach dem setzen des Fonts bestehen.
Vorteil: Hohe Textauflösung und Refreshrate. Nachteil: Langsame Textspeed. Also im Endeffekt ist dies ein Grafikmodus (hier 800x600).

Wird Linux mit einem reinen Textmodus gestartet (z.B. VGA=ask), so wird beim Setzen des Fonts wieder auf die "alte" Auflösung von 80x25 geschaltet.

Abhilfe: chmod ugo-x /bin/setfont

Das ist wohl quick and dirty, aber verhindert das setfont die reine Textauflösung wieder zurücksetzt.

(Andere Möglichkeit: Editieren des entsprechenden Startskripts)
(Oder man setfont und lernen :D )

Also ich bin mit meiner Lösung happy und muss nun nicht auf die langsamen Pseudotextmodes (Framebuffer) zurückgreifen. :p
 
Oben