[solved] SuSe 9.0, Hauppauge DVB-s, Radeon 9800 = CRASH

A

Anonymous

Gast
Hallo Leute,

Eben hab ich mein neues SuSe System aufgesetzt und musste mit Erschrecken feststellen dass beim starten von KwinTV, XawTV u.ä. mein PC "abstürzt" bzw nur noch nen Black Screen ausspuckt, die Tastatur reagiert noch, STR, ALT und F6 zb bringt aber nichts. Liegt das an meiner fglrx 3D Treiberkonfiguration bzw. stimmt da irgendwas mit XFree nicht? Ich wäre unglaublich froh wenn jemand mir helfen könnte, denn ich will nicht Windows installieren müssen nur weil Digital - TV nicht auf SuSe läuft!!
Hier mal lsmod:

specializt@Juggernaught:~> lsmod
Module Size Used by Tainted: P
dvb-ttpci 311292 0 (unused)
mt312 6444 0
tda1004x 10984 0
ves1820 5248 0
stv0299 8372 0 (unused)
grundig_29504-491 4196 0
grundig_29504-401 4716 0
alps_tdlb7 4912 0
alps_tdmb7 4552 0
alps_bsrv2 4476 1
dvb-core 43352 3 [dvb-ttpci mt312 tda1004x ves1820 stv0299 grundig_29504-491 grundig_29504-401 alps_tdlb7 alps_tdmb7 alps_bsrv2]
videodev 6272 1 [dvb-ttpci]
snd-mixer-oss 15576 0 (autoclean)
hid 21444 0 (unused)
fglrx 179016 186
isa-pnp 32712 0 (unused)
usbserial 19836 0 (autoclean) (unused)
parport_pc 28648 1 (autoclean)
lp 6304 0 (autoclean)
parport 25608 1 (autoclean) [parport_pc lp]
ipv6 227264 -1 (autoclean)
key 70456 0 (autoclean) [ipv6]
snd-seq-oss 30048 0 (autoclean)
snd-seq-midi 5088 0 (unused)
snd-emu10k1-synth 6396 0
snd-emux-synth 31484 0 [snd-emu10k1-synth]
snd-seq-midi-emul 5376 0 [snd-emux-synth]
snd-seq-virmidi 4040 0 [snd-emux-synth]
snd-seq-midi-event 3840 0 [snd-seq-oss snd-seq-midi snd-seq-virmidi]
snd-seq 41424 3 [snd-seq-oss snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-midi-event]
thermal 6180 0 (unused)
processor 8280 0 [thermal]
fan 1472 0 (unused)
snd-emu10k1 78916 4 [snd-emu10k1-synth]
button 2380 0 (unused)
snd-pcm 74116 0 [snd-emu10k1]
snd-timer 17056 0 [snd-seq snd-pcm]
snd-rawmidi 15776 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-page-alloc 6676 0 [snd-emu10k1 snd-pcm]
snd-util-mem 1696 0 [snd-emux-synth snd-emu10k1]
snd-seq-device 4528 0 [snd-seq-oss snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq snd-emu10k1 snd-rawmidi]
snd-ac97-codec 45304 0 [snd-emu10k1]
snd-hwdep 5408 0 [snd-emu10k1]
snd 40388 4 [snd-mixer-oss snd-seq-oss snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-midi-event snd-seq snd-emu10k1 snd-pcm snd-timer snd-rawmidi snd-util-mem snd-seq-device snd-ac97-codec snd-hwdep]
soundcore 3940 0 [snd]
battery 5600 0 (unused)
ac 1696 0 (unused)
st 29648 0 (autoclean) (unused)
sr_mod 14616 0 (autoclean)
sg 35232 0 (autoclean)
keybdev 2156 0 (unused)
mousedev 4340 1
joydev 5440 0 (unused)
evdev 3840 0 (unused)
input 3488 0 [dvb-ttpci hid keybdev mousedev joydev evdev]
usb-ohci 19848 0 (unused)
ehci-hcd 18028 0 (unused)
usbcore 64364 1 [hid usbserial usb-ohci ehci-hcd]
raw1394 18288 0 (unused)
ieee1394 188260 0 [raw1394]
af_packet 13168 0 (autoclean)
nvnet 25632 1
agpgart 45752 22
ide-scsi 11056 0
scsi_mod 100788 4 [st sr_mod sg ide-scsi]
ide-cd 32416 0
cdrom 29216 0 [sr_mod ide-cd]
ext3 88328 3
jbd 52448 3 [ext3]
pdcraid 12448 0
ataraid 7076 0 [pdcraid]
specializt@Juggernaught:~>
 

Wolfgang

Hacker
Wichtig ist, dass Deine XF86Config an der entsprechenden Stelle so aussieht:

Section "Module"
Load "type1"
Load "dbe"
Load "freetype"
Load "glx"
Load "dri"
Load "v4l"
Load "speedo"
# Load "extmod"

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection


EndSection


Damit deaktivierst Du die DGA-Erweiterungen.
Wird weitewr unten auch in diesem Beitrag beschrieben:
http://www.linux-club.de/viewtopic.php?t=8137
 
Oben