[solved] vlc mit packman installieren ?

ich möchte mir gerne den vlc player auf mein suse 10.0 system installieren. nun hab ich bei packman per http zwar den downloadlink gefunden, möchte ich das rpm installieren bekomme ich ne menge abhaengigskeitsfehler.
gibts ne möglichkeit das ganze in yast einzutragen (hab ich versucht, mit dem suchwort vlc bzw. videolan wird bei packman aber nichts gefunden (der pfad ist ok, da xine ne menge treffer liefert)
oder muss ich tatsaechlich die ganzen einzelnen packete runterladen und einzeln per yest installieren ?

mir macht auch noch sorgen das yast dateien fehlen die nicht bei packman stehen
 
Alternativ zu apt kannst du dir auch Packman als alternative Installationsquelle in YaST einfügen und vlc über YaST installieren:
http://www.linux-club.de/viewtopic.php?t=27988
Paketabhängigkeiten werden so automatisch aufgelöst.
 
fritzbee21 schrieb:
mir macht auch noch sorgen das yast dateien fehlen die nicht bei packman stehen
libdvdcss? => Musst Du selbst kompilieren, weil das Anbieten fertiger RPMs zu riskant ist.

Siehe Anleitung: http://packman.links2linux.de/?action=122
 

Grothesk

Ultimate Guru
Sicher. Jedenfalls auf einem 32bit-System.
Hast du zufällig 64bit? Da ist es evtl. möglich. Auf einem 32bit-System ist es mit 100%iger Sicherheit nicht notwendig.
 

Lone Wolf

Newbie
ich hab nen 32bit Systen

aber durch VLC wurd bei mir auch net alles besser - siehe http://www.linux-club.de/viewtopic.php?t=55451

MfG
Lone Wolf
 
Sagen wir es mal mit Harry Potter:
Packman Pakete besitzen immer nur Abhängigkeiten zu anderen Packman Paketen und zu Suse Paketen. Wenn es also bei der Installation von vlc von Packman Paketabhängigkeiten gibt, kann es nur an ihm, dessen Name nicht genannt werden darf liegen.
Nur es, dessen Name nicht genannt werden darf, gibt es nämlich bei Packmal nicht als rpm.

Wenn man Packman also als alternative Installationsquelle in YaST eingefügt hat und YaST meckert wegen fehlender Abhängigkeiten, dann kann das nur an ihm liegen, dessen Name nicht genannt werden darf.

Wer ist er? Voldemort? Nein, viel schlimmer!
Psssssssst!
http://packman.links2linux.de/?action=122

Edit: Obwohl es, dessen Name nicht genannt werden darf, hier auch nicht als zusätzlich benötigtes Paket genannt wurde:
http://packman.links2linux.de/?action=377
Es darf wohl wirklich nicht genannt werden.
Hoffentlich habe ich jetzt nicht die Auroren von Askaban auf mich aufmerksam gemacht...
 
@Griffin


schade aber Abhängigkeiten werden wohl def. nicht aufgeloest.
Ich hab jetzt mal packman als Quelle in Yast eingetragen, nach VLC gesucht, dieses angehackt und siehe da, ich bekomme die gleiche Fehlermeldung das jede Menge Dateien fehlen, als wenn ich das rpm von Packman runterlade und dies versuche manuell mit yast zu installieren


#### YaST2 conflicts list - generated 2006-03-09 19:10:20 ####

arts nicht verfügbar
Benötigt von:
vlc benötigt arts
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
db1 nicht verfügbar
Benötigt von:
vlc benötigt db1 >= 1.85-
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit vlc 0.8.4a-1.pm.7
Nicht erfüllte Abhängigkeiten:
vlc benötigt libdvdcss >= 1.2.8-
vlc benötigt arts
vlc benötigt db1 >= 1.85-
vlc benötigt libdvdnav >= 0.1.10-
vlc benötigt libmpeg2 >= 0.4.0b-
vlc benötigt libartsc.so.0
vlc benötigt libdvdnav.so.4
vlc benötigt libmpeg2.so.0
vlc benötigt libxosd.so.2
Konfliktlösung:
( ) vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libartsc.so.0 nicht verfügbar
Benötigt von:
vlc benötigt libartsc.so.0
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libdvdcss nicht verfügbar
Benötigt von:
vlc benötigt libdvdcss >= 1.2.8-
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libdvdnav nicht verfügbar
Benötigt von:
vlc benötigt libdvdnav >= 0.1.10-
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libdvdnav.so.4 nicht verfügbar
Benötigt von:
vlc benötigt libdvdnav.so.4
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libmpeg2 nicht verfügbar
Benötigt von:
vlc benötigt libmpeg2 >= 0.4.0b-
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libmpeg2.so.0 nicht verfügbar
Benötigt von:
vlc benötigt libmpeg2.so.0
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libxosd.so.2 nicht verfügbar
Benötigt von:
vlc benötigt libxosd.so.2
Konfliktlösung:
( ) Entsprechendes Paket löschen
vlc nicht installieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren

#### YaST2 conflicts list END ###
 

sandino

Member
hab's grad mal durch gespielt, mein Yast sagt mir nur das die besagte und libdvbpsi3... fehlen.

Der Rest liegt bei Packman oder auf DVD.
 

Grothesk

Ultimate Guru
Und libdvbpsi3 wird nicht mal von vlc benötigt...
Code:
apt policy vlc libdvbpsi3
vlc:
  Installiert: 0.8.4a-1.pm.7
  Kandidat: 0.8.4a-1.pm.7
  Versionstabelle:
 *** 0.8.4a-1.pm.7 0
        500 ftp://ftp4.gwdg.de SuSE/10.0-i386/packman-i686 pkglist
        100 RPM Database
     0.8.4a-1.pm.7 0
        500 ftp://ftp4.gwdg.de SuSE/10.0-i386/packman pkglist
libdvbpsi3:
  Installiert: (nichts)
  Kandidat: 0.1.4-0.pm.4
  Versionstabelle:
     0.1.4-0.pm.4 0
        500 ftp://ftp4.gwdg.de SuSE/10.0-i386/packman pkglist
 
ich gehe davon aus das es richtig eingetragen ist


http
packman.iu-bremen.de
/suse/10.0
anonymous

->
daraus ergibt sich
status: an
aktualisieren: an
url: http://packman.iu-bremen.de//suse/10.0

-> software installieren oder löschen

"vlc" als suchwort eingeben, es werden 3 einträge gefunden (vlc, vlc-devel, vlc-mozillaplugin)
vlc anhacken und "übernehmen" anklicken
und schon kommen die ganzen ungelösten abhängigkeiten
 
Oben