• Der Linux-Club wurde auf eine modernere Forensoftware umgestellt und hat auch optisch einen neuen Anstrich erhalten. Weitere Details findest du im Beitrag "Update der Forensoftware 2022".

Suse9 + nit realtek8029as (ne2k-pci) + kabelmodem = kaputt

A

Anonymous

Gast
hallo!
hab ein problem und weiss überhaupt nicht woran es liegt. könnt ihr mir auf die sprünge helfen?

also: suse9, 2 nic realtek8029as mit ne2k-pci von suse automatisch eingebunden.
egal ob über dhcp oder fix eingetragene ip usw das internet über kabelmodem (chello austria-motorola surfboard) geht ein paar minuten, dann stürzt das kabelmodem ab-kein ping mehr ins inet oder ans kabelmodem möglich. während der minuten ist es auch max 4kb/sek schnell statt 100kb/sek.

nach modemreset gehts wieder ein paar minuten.-das modem verliert nicht die verbindung ins kabelnetz, es kommuniziert einfach nicht mehr mit der nic (weiss ich wegen status leds).

die nic hab ich versucht umzukonfigurieren in /etc/modules.conf- alle optionen beim ne2k-pci eintrag rausgenommen und auch options ne2k-pci options=[integer],[integer] probiert (laut beschreibung ne2k-pci die media-typen, also 10baset,fd,hd usw), aber egal, immer dasselbe.

ne2k-pci-diag zeigt immer, egal welche options ich hab, dass die nic fürs interne netz 10baseT/coax half duplex is und die externe 10baseT forced full duplex (die is über rj kabel dran). auch wenn ich die options mit modprobe ne2k-pci options=x,x ändre tut sich nix.

vielleicht is half/full duplex nicht das problem, unter xp hab ich die nics auf halfduplex gestellt, weils mit auto nicht funkte. unter xp gehts jedenfalls.

hat wer eine idee???
danke!!
 
A

Anonymous

Gast
Habe genau das gleiche Problem unter Mandrake 10 (gleiche Netzwekkarte).


Jmd ne Idee?
 

Bonsai

Advanced Hacker
Hat einer der Herren Gäste mal versucht (wenns denn mit Windoof klappt) alle TCP/IP Optionen GENAU so einzustellen wie im Windoof?
Auch MTU, TTL, etc...
 

jado

Member
Hier findest du Infos zu NE2000-Problemen:
http://www.ibiblio.org/mdw/HOWTO/Ethernet-HOWTO-2.html
... vielleicht hilft es ja.

Hast du eigentlich auch schon mal versucht Full-Duplex explizit auszuschalten?
" full_duplex = 0,0 "

Mit dem "mii-tool" kann man auch den Media-Type manipulieren.
Wäre auch nochmal ein Versuch wert.


greez
 
A

Anonymous

Gast
mii-tool geht nich (not supported)
full_duplex=0,0 bringt keine änderung
 
Oben