[teilw. gelöst] Probleme mit MPlayer nach Sicherheitsupdate

taki

Advanced Hacker
Hi.
Beim gestrigen apt-get upgrade wurde eine neue MPlayer-Version von Packman installiert. Diese scheint arg kaputt zu sein. Grund für den Update (RPM ist vom 6.3.2006) war wohl eine mögliche Sicherheitslücke bei der Wiedergabe von asf-Dateien. Das Format kenne ich nicht einmal. Mit der "pre7try3" stürzt MPlayer regelmäßig bei der Wiedergabe von Divx-Filmen ab... Leider gibt es keine älteren Pakete mehr bei Packman, so dass ich nicht downgraden kann. Ist ausser mir auch schon jemand ein Problem mit MPlayer aufgefallen?

P.S. Die folgende Fehlermeldung kommt nach den ersten Sekunden erfolgreicher Wiedergabe in der Konsole. Das MPlayer-Fenster bleibt dabei stehen und der Prozess muss gekillt werden.

Konsole schrieb:
*** glibc detected *** double free or corruption (!prev): 0x088167e0 ***


MPlayer interrupted by signal 6 in module: decode_audio
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.


MPlayer interrupted by signal 2 in module: uninit_acodec


MPlayer interrupted by signal 15 in module: uninit_vcodec
 

sandino

Member
seit ich das: http://www.linux-club.de/viewtopic.php?t=51937 verfolgt
habe, hab ich mein mplayer gepinnt :wink:
 

taki

Advanced Hacker
Danke Sandino. Dein Link war Gold wert. Jetzt läuft bei mir der MPlayer von suser-jenghl. War etwas fummelig zu installieren, aber jetzt klappt wieder alles.

Fummelig: Jenghls MPlayer benötigt noch die libsvga. In dem Paket fehlt der Link von libvga.so.1.3.4 nach libvga.so.1. Nach Setzen des Links läuft hier wieder ein fehlerfreier MPlayer. OK, die Sicherheitslücke bei Wiedergabe von asf-Dateien ist wohl noch drin, aber das stört mich nicht. asf gibt es auf meinem Rechner nicht und Filme aus Mails klicke ich eh nicht an.

Das Problem mit dem Packman-RPM hängt wohl mit dem gcc zusammen. So wie es aussieht, verträgt sich der Sicherheitspatch wohl nicht mit der in der SUSE 10 verwendeten gcc-Version. Bevor ich auf Jenghls RPM kam habe ich einen Rebuild des Source-RPMs von Packman ausprobiert. Dabei kam eine Konsolenfüllende Warnung, weil ein vom MPlayer-Projekt nicht unterstützter Compiler verwendet würde. Mit dem selbstgebauten RPM gab es dann die selbe Fehlermeldung beim Abspielen der Videos.

Mein gcc und die glibc stammen von der SUSE 10.0-DVD.

apt policy * schrieb:
taki@rivendell:~> apt policy glibc
glibc:
Installiert: 2.3.5-40
Kandidat: 2.3.5-40
Versionstabelle:
*** 2.3.5-40 0
100 RPM Database
taki@rivendell:~> apt policy gcc
gcc:
Installiert: 4.0.2_20050901-3
Kandidat: 4.0.2_20050901-3
Versionstabelle:
*** 4.0.2_20050901-3 0
100 RPM Database

[edit] Habe gerade eine Mail an Henne (Maintainer des Packman-Pakets) geschickt. Ich würde schon gerne bei der Packman-Version bleiben. Eigentlich ist ja gerade packman bei mir gepinnt... :-/
 

taki

Advanced Hacker
@jengelh
Ich bitte vielmals um Entschuldigung :oops:.

Zum Thema selbst scheint niemand etwas zu sagen zu haben. Von Henne habe ich auch noch nichts gehört. Hat denn sonst niemand Probleme mit der Packman-Version? :?
 

4NothinK

Member
Ich versuche komplett vom Mplayer abstand zu nehmen. Sowohl unter SuSE als auch unter Ubuntu stürzt das Teil (un)regelmäßig ab. Leider gibt es einige Videos, die nur mit dem Mplayer funzen.
 
A

Anonymous

Gast
Ich habe KEINE Probleme mit der Packman Version...eine andere nutze ich gar nicht.
ASF läuft mir in letzter Zeit auch häufiger über die Füsse...
 

oc2pus

Ultimate Guru
da es ja nun offensichtlich ein Thread wird, über pro und contra MPlayer

==> verschoben nach Multimedia :mrgreen:
 

Frankie777

Advanced Hacker
Hi,
Ich habe mit Suse 9.3 genau die gleiche Fehlermeldung.

Ursache kann wohl nur dieses Update sein:
MPlayer-1.0pre7try3-1 Sat Mar 11 14:53:59 2006

MPlayer:
Installed: 1.0pre7try3-1
Candidate: 1.0pre7try3-1
Version Table:
*** 1.0pre7try3-1 0
500 ftp://ftp4.gwdg.de SuSE/9.3-i386/packman pkglist
100 RPM Database
1.0pre7try2-29 0
500 ftp://ftp4.gwdg.de SuSE/9.3-i386/suser-jengelh pkglist
1.0pre7-pm.3 0
500 ftp://ftp4.gwdg.de SuSE/9.3-i386/suser-raoul pkglist
 
Oben