• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

USB-Stick läuft nicht mehr

T0m

Newbie
Hi !

Mein USB-Stick will nicht mehr unter SuSE Linux 9.1 !
Unter 8.0 konnte man den während des Betriebs einstecken und dann den entsprechenden Eintrag in der fstab mounten. Jetzt geht das wohl nicht mehr so ... Wie ändere ich dies ?
 
OP
T

T0m

Newbie
Hi !

Ist nun mit FAT16 formatiert, allerdings läuft er immer noch nicht nachdem ich ihn reinstecke. In der fstab gibt's keinen neuen Eintrag ...
(USB-Ports tun aber da mein Scanner unter Linux läuft.)

Was muß ich nun machen ?
 

admine

Administrator
Teammitglied
T0m schrieb:
Hi !

Ist nun mit FAT16 formatiert, allerdings läuft er immer noch nicht nachdem ich ihn reinstecke. In der fstab gibt's keinen neuen Eintrag ...
(USB-Ports tun aber da mein Scanner unter Linux läuft.)

Was muß ich nun machen ?

Dieser wird wohl, wie so einige andere Dinge unter Suse 9.1, automatisch gemountet.
Hast du einen "Arbeitsplatz" auf dem Dektop ?
Wenn ja, schau da mal rein, evt. sieht du ihn da.
 
OP
T

T0m

Newbie
Hi !

Unter root zwar nicht, aber unter meinem normalen Benutzer schon.
(Wie bekomme ich denn die Symbole auch bei root hin ohne alles von Hand machen zu müssen ?)

Aber leidet erscheint da auch kein USB-Stick.
 
OP
T

T0m

Newbie
Hi !

So hat es ja auch unter 8.0 bisher funktioniert.
Aber in 9.1 tut das wohl nicht mehr so. Deswegen frage ich ja, wie ich das wieder zum Laufen bekomme.
 
A

Anonymous

Gast
Schon mal die Tips aus den ganzen anderen USB Threads ausprobiert?
 

na-cx

Hacker
T0m schrieb:
(Wie bekomme ich denn die Symbole auch bei root hin ohne alles von Hand machen zu müssen ?

- Als root einloggen
- Konqueror oder ähnliches öffnen
- zu /home/"benutzername"/Desktop wechseln
- "myComputer.desktop" und bei Bedarf andere Dateien auswählen und kopieren
- zu /root/Desktop gehen
- dort einfügen
- fertig.
 
OP
T

T0m

Newbie
Hi !

So, der USB-Stick funktioniert nun endlich wieder.
Wenn ich X-Window am Laufen habe und ihn einstecke, dann wird er auch sofort automatisch gemountet.
Unter der Konsole ist er danach auch noch verfügbar bis man ihn halt rauszieht oder umount macht.

Aber wenn ich ihn reinstecke während ich nur unter der Konsole bin, dann wird er nicht automatisch gemountet (wie bei 8.0) und auch nichts in die fstab eingetragen.

Wie kann ich das noch ändern ? Das ich mir per Skript eine weitere Zeile in die fstab eintrage und danach den USB-Stick ebenfalls per Skript mounte ist ja nicht besonders schwer, aber früher ging das halt automatisch ...
Weiß da noch einer was von euch ?
 

unity

Newbie
hi,

habe mir mehrere posting durchgelesen aber keine antwort gefunden. ich verwende suse 9.1 auf dem acer travelmate 634. submount ist auch aktiviert. wenn ich nun die usb-mouse und den usb stick gleichzeitig verwende bleibt das system "hängen". es geht gar nichts mehr ausser der reset button. "hängen" bleibt das system sobald ich dateien auf dem usb-stick löschen möchte. das herunterkopieren hat funktioniert.

danke schon im voraus!

:(
 
A

Anonymous

Gast
Dann probier es mal ohne submount!

http://portal.suse.com/sdb/de/2004/05/hmeyer_91_revert_from_subfs.html
 

unity

Newbie
hi,

werde ich versuchen. wobei ich schon gerne das submount verwende würde.
gibt es hier keine mögliche lösung? ist der fehler beim submount? warum erzeugt submount solche konflikte?

würde mich sehr interessieren und danke noch für deine rasche antwort!

:D
 
A

Anonymous

Gast
Submount bringt dir nur, dass nach dem Einstecken des USB-Sticks ein Fenster aufgeht. Sonst nix! Wenn du dir eine Desktop Verknüpfung zu dem USB-Stick anlegst, hast du fast den gleichen Komfort.

Submount ist einfach noch nicht ausgereift genug. Der submount-Entwickler selbst hat mal geschrieben, dass er panische Angst hat, weil SuSE sein Programm jetzt in einen riesen Beta-Test geschickt hat. Ich hoffe ich habe das halbwegs richtig wiedergegeben.
 
Wenn du dir eine Desktop Verknüpfung zu dem USB-Stick anlegst, hast du fast den gleichen Komfort.

Wo wird der denn Configurirt? unter /dev/usbfs/ ?????
 
Oben