Versionskonflikt zwischen SVN/httpd?

mideg

Newbie
Hallo!

Ich habe folgendes Problem: Ich habe auf einer Virtual Machine mit SLES92 Subversion und httpd installiert, um das Repository per WebDAV zugänglich zu machen. Die dazu nötigen Pakete habe ich gleich mitinstalliert.

Da ich hier im Betrieb am laufenden System keinen Schaden anrichten wollte, habe ich das ganze erst auf einer Kopie der VM durchgeführt, dort alles ans Laufen gebracht (siehe meine zwei anderen Fragen) und erst danach versucht, dies auf der "echten" VM nachzuvollziehen.

Nach der Installation startet httpd nicht, und gibt folgende Fehlermeldung aus:

Cannot load /usr/local/apache2/modules/mod_dav_svn.so into server: /usr/local/apache2/modules/mod_dav_svn.so: undefined symbol: svn_fs_access_add_lock_token

Diesen Fehler hatte ich auch auf meinem Testsystem schonmal, dort hatte ich zuerst die aktuellste Version von httpd installiert, nachdem ich httpd 2.0.55 installiert hatte, lief es dort.

Daher habe ich nun direkt nur httpd 2.0.55 installiert.

Installationsreihenfolge:
Python, apr, apr-util, autoconf, openssl, httpd, neon, subversion.

Dabei habe ich jeweils die in den INSTALL bzw. README-Dateien stehenden Installationsanweisungen beachtet (idR ./configure; make; make install), nur bei httpd
(./configure --enable-dav --enable-dav-fs --enable-maintainer-mode --enable-so --with-ssl=/usr/local/ssl --enable-ssl; make; make install)

und subversion
(./configure --enable-maintainer-mode --enable-apr --with-ssl --with-neon=/usr/local/bin; make; make install)

waren es spezielle Konfigurationseinstellungen. Hat jemand eine Idee, was ich noch probieren kann? Vielen Dank und Grüße,

Michel
 

mideg

Newbie
Ich habe einen weiteren möglichen Fehler: Ich habe - wie mir gerade erst aufgefallen ist - auf dem Testsystem neon-0.25.4 benutzt und auf der anderen VM neon-0.25.5. Meine Frage: Kann das die Fehlermeldung "Cannot load /usr/local/apache2/modules/mod_dav_svn.so into server: /usr/local/apache2/modules/mod_dav_svn.so: undefined symbol: svn_fs_access_add_lock_token" verursachen?

Wäre dankbar für jegliche Hilfestellung. :)
 
Oben