Webhttrack läuft nicht... vielleicht ist das die Lösung:

rethus

Advanced Hacker
Hi @ all,
ich wollte webhttrack nutzen, habe aber immer beim Aufruf folgenden Fehler erhalten:

/usr/bin/webhttrack(24238): launching /usr/bin/firefox
Error: Failed to send command: 500 command not parseable
/usr/bin/webhttrack(24238): waiting for browser to terminate..
/usr/bin/webhttrack(24238): nasty signal caught, cleaning up..
/usr/bin/webhttrack: line 168: kill: (24253) - Kein passender Prozess gefunden
/usr/bin/webhttrack(24238): ..done


Firefox-Verion: 1.5.0.1
WebHttrack-Version: 3.40.2-0.oc2pus.1


Nun woran hat es gelegen?
Es liegt an einem fehlerhaften Aufruf in dem Script /usr/bin/webhttrack. Um den Bug zu Fixen geht wie folgt vor:

vi /usr/bin/webhttrack

Suche den Codeblock:
===================================================
# launch any browser
# if it is a mozilla like browser, check if the browser is running and use
# -remote if needed. Change the URL into openURL($url) too.
# (thanks to Torsten Werner for the patch)
# see http://www.mozilla.org/unix/remote.html
if mozillabrowser ${browser}; then
if ! ${browser} -remote "openurl(${url})"; then
log "spawning browser.."
${browser} "${url}"
fi
else
log "spawning regular browser.."
${browser} "${url}"
fi
===================================================
Ändere die Zeile:
if ! ${browser} -remote "${url}"; then
gegen:
if ! ${browser} -remote "openurl(${url})"; then

Abspeichern....
Starten.

Habe den Patch auch nach Httrack geschickt, hoffe, das die diesen einpflegen und das Problem zukünftig nicht mehr besteht
 

oc2pus

Ultimate Guru
kleine Frage: hast du nur den firefox installiert ?

Ich habe den mozilla UND den firefox, und es klappt (?)
ofenbar muss dann noch eine Fallunterscheidung rein ...
ich werde deinen "Patch" in meinem nächsten Paket mit reinehmen, merci ;)
 

rethus

Advanced Hacker
ach du bist DER oc2pus :lol:
Naja, hab den Patch Richtung httrack-Website gepostet. Aber bei dir ist der ja dann auch bestens aufgehoben.

Ich nutze Firefox 1.5.0.1
Mozilla hab ich nicht installiert, lediglich der Konqueror ist noch bei mir drauf.
 
Oben