Wie greife ich auf ein externes USB- Floppy zu?

Icelord

Newbie
ja, wie der Titel schon sagt, ich versuche auf Teac FD-05PUW
zuzugreifen unter /dev/fd0 finde ich es aber nicht.
Wie kann ich trotzdem drauf zugreifen und gibt es auch eine
Möglichkeit unter KDE?

thx in advance
 

towo

Moderator
Teammitglied
Icelord schrieb:
ja, wie der Titel schon sagt, ich versuche auf Teac FD-05PUW
zuzugreifen unter /dev/fd0 finde ich es aber nicht.
Wie kann ich trotzdem drauf zugreifen und gibt es auch eine
Möglichkeit unter KDE?

thx in advance
Wird das Ding denn beim Anstöpseln erkannt?
Was sagt denn das Log?
 

towo

Moderator
Teammitglied
gabbagandalf schrieb:
rechte maustaste auf desktop>neu erstellen>Festplatte und unter gerät dev/fd0 auswählen
dann müsste es klappen
Tja, nur leider völlig falsch, da ein USB-Gerät nicht als /dev/fd0 eingebunden wird!
 
OP
Icelord

Icelord

Newbie
nun ja, wenn ich das Ding anstöpsle passiert zunächst mal gar nichts.
Wenn ich ne floppy reintu dann rattert es kurz.

Wenn ich das Teil von Anfang an angeschlossen hab und dann den
Rechner boote, dann rattert das Teil fast konstant immer wieder, bis
Linux fertig geladen ist.
Ob es erkannt wurde, oder wie ich drauf zugreife bleibt mir immernoch
ein Rästel.
 
Ja dann: rechte maustaste auf Desktop>Neu erstellen>Diskette
und unter Gerät dat dingen auswählen
Klapts jetzt?
see ya
 
OP
Icelord

Icelord

Newbie
neee, da ist es glaub nicht dabei. Wie müsste es denn heißen?
Egal was ich da auswähle, es funktioniert nicht.
 

Hermann

Hacker
Icelord schrieb:
neee, da ist es glaub nicht dabei. Wie müsste es denn heißen?
Egal was ich da auswähle, es funktioniert nicht.

Hallo, nimm eine Shell log Dich als root ein steck die externe Floppy an und tippe danach dmesg in die Shell. irgendwo unten sollte jetzt stehen wie die Floppy erkant wurde.

Gruß, Hermann
 
OP
Icelord

Icelord

Newbie
hmmm...
das sind die letzten Zeilen:
usb 3-1: new full speed USB device using address 4
usb 3-1: Product: TEAC FD-05PUW
usb 3-1: Manufacturer: TEAC
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: TEAC Model: FD-05PUW Rev: 2000
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sdb: 2880 512-byte hdwr sectors (1 MB)
sdb: assuming Write Enabled
sdb: assuming drive cache: write through
sdb:<3>ldm_parse_privhead(): Cannot find PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 0
Attached scsi generic sg1 at scsi1, channel 0, id 0, lun 0, type 0
USB Mass Storage device found at 4

was heisst 4? sorry ich kapier das nicht.
 
A

Anonymous

Gast
Sch...ade, habe ich schon befürchtet, denn bei meinem USB-stick steht am Ende
Code:
sdb: sdb1
anstatt
Code:
 sdb:<3>ldm_parse_privhead(): Cannot find PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.

Das scheint mir aber eher was mit der Formatierung der Floppy, als mit der Hardware zu tun zu haben, da LDM 'Windows Logical Disk Manager' bedeutet und auch was mit NTFS zu tun hat (was bei google eben so ausgespuckt wird).

Schon mal eine andere Diskette probiert?
 
OP
Icelord

Icelord

Newbie
ich hab jetzt zufällig nen anderen Weg gefunden.
(An der floppy scheint es nicht gelegen zu haben).
Wenn man das Laufwerk schon vor dem Systemstart am
Rechner angeschlossen hat, dann wird es unter KDE im
Arbeitsplatz aufgelistet und man kann dann problemlos
drauf zugreifen.

Warum das so ist, weiss ich nicht, aber immerhin:
es funktioniert!

(erinnert ein wenig an Plug & Play unter Windows).
 
Hallo

Bei mir funktioniert es nicht, auch nicht wenn ich das Floppy schon am Start dran habe...

mal die ausgaben von dmesg:

usb 3-2: new full speed USB device using address 5
usb 3-2: Product: TEAC FD-05PUB (Anmerkung: IBM Thinkad floppy)
usb 3-2: Manufacturer: TEAC
scsi2 : SCSI emulation for USB Mass Storage devices
Vendor: TEAC Model: FD-05PUB Rev: 3200
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 2880 512-byte hdwr sectors (1 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda: unknown partition table
Attached scsi removable disk sda at scsi2, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi2, channel 0, id 0, lun 0, type 0
USB Mass Storage device found at 5

und tail -f /var/log/messages


Jun 17 13:27:30 IBMR51 kernel: usb 3-2: new full speed USB device using address 6
Jun 17 13:27:30 IBMR51 kernel: usb 3-2: Product: TEAC FD-05PUB
Jun 17 13:27:30 IBMR51 kernel: usb 3-2: Manufacturer: TEAC
Jun 17 13:27:30 IBMR51 kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Jun 17 13:27:30 IBMR51 /etc/hotplug/usb.agent[7056]: need a device for this command
Jun 17 13:27:31 IBMR51 kernel: Vendor: TEAC Model: FD-05PUB Rev: 3200
Jun 17 13:27:31 IBMR51 kernel: Type: Direct-Access ANSI SCSI revision: 02
Jun 17 13:27:31 IBMR51 kernel: SCSI device sda: 2880 512-byte hdwr sectors (1 MB)
Jun 17 13:27:31 IBMR51 kernel: sda: assuming Write Enabled
Jun 17 13:27:31 IBMR51 kernel: sda: assuming drive cache: write through
Jun 17 13:27:31 IBMR51 /etc/hotplug/block.agent[7120]: try 1 while waiting for /block/sda's bus_id 3:0:0:0
Jun 17 13:27:32 IBMR51 /etc/hotplug/block.agent[7120]: try 2 while waiting for /block/sda's bus_id 3:0:0:0
Jun 17 13:27:33 IBMR51 kernel: sda: unknown partition table
Jun 17 13:27:33 IBMR51 kernel: Attached scsi removable disk sda at scsi3, channel 0, id 0, lun 0
Jun 17 13:27:33 IBMR51 kernel: Attached scsi generic sg0 at scsi3, channel 0, id 0, lun 0, type 0
Jun 17 13:27:33 IBMR51 kernel: USB Mass Storage device found at 6
Jun 17 13:27:33 IBMR51 /etc/hotplug/block.agent[7120]: new block device /block/sda
Jun 17 13:27:42 IBMR51 /etc/hotplug/block.agent[7120]: mount by-path/usb-storage-odd-TEAC-TEACFD05PUB:0:0:0

Wenn ich versuche auf den neuen Pfad /media/usb-storage-odd-TEAC-TEACFD05PUB:0:0:0
zuzugreifen gibt das einen fehler und folgendes Protokoll:

Jun 17 13:28:46 IBMR51 kernel: FAT: invalid media value (0xf6)
Jun 17 13:28:46 IBMR51 kernel: VFS: Can't find a valid FAT filesystem on dev sda.
Jun 17 13:28:46 IBMR51 kernel: VFS: Can't find ext2 filesystem on dev sda.
Jun 17 13:28:47 IBMR51 submountd: mount failure, Invalid argument

(kommt mehrfach, auch mit anderen Dateisystemen wie Minix und Minix V2)

direkter Zugriff auf /dev/sg0 oder /dev/sda ist nicht möglich "keine Berechtigung"

Besonders blöd ist das weil Moneyplex ohne Floppy nicht richtig arbeiten will. Oder wie stellt man da die Floppypfadeingabe ab?

:( Jan Henning
 
Oben