• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

WinBtrfs Einrichtung klappt nicht - WinXI Treibersignatur?

fhihu

Member
kurze Frage zu dem Thema. Welches Windows habt ihr hier verwendet. Ich habe diese Anleitung heute versucht bei Windows 11. Hier gibt es ja neu das SecureBoot.

Auf der Website steht dazu:

To work around this, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CI\Policy in Regedit,create a new DWORD value called UpgradedSystem and set to 1, and reboot.

Das habe ich zwar gemacht, aber funktioniert leider nicht. Ich habe allerdings gesehen, dass dieser DWORD Eintrag unterschiedlich festgelegt werden kann. Zb 64 Bit oder 32 Bit. Den Wert kann man als Hexadezimal oder Alphanummerisch festlegen. Was muss man hier benutzen?

Lieben Gruß
fhihu


Edit: Beiträge abgetrennt vom Thema: auf Festplatte mit Linux und Windows zugreifen → winbtrfs
Bitte keine Themen kapern, sondern neue, eigene Themen erstellen und die Quelle verlinken.
Christina, Moderatorin
 
Zuletzt bearbeitet von einem Moderator:

susejunky

Moderator
Teammitglied
Hallo @fhihu ,

das hier ist ein Linux-Forum. Ich könnte mir vorstellen, dass Du mit Deiner Frage in einem MS Windows Forum deutlich bessere Chancen auf Unterstützung hast.

Und übrigens
  • secureboot hat meines Wissens bereits in MS Windows 8 Einzug gehalten
  • Was hat secureboot mit dem oben diskutiertem Ausblenden von btrfs-Dateisystemen zu tun?

Viele Grüße

susejunky
 
OP
F

fhihu

Member
Hallo Susejunky,

Ich werde mich noch zusätzlich in einem Windowsforum anmelden, stimmt.

Mit dem ausblenden hat es zuerst mal nichts zu tun. Ich habe nur die Anleitung bis zum installieren benutzt. Also Rechtsklick und installieren. Bei mir hat sich aber nichts getan.

Habe auf der offiziellen Website geschaut.

GitHub - maharmstone/btrfs: WinBtrfs - an open-source btrfs driver for Windows

Hier wird es halt unter secureboot geführt. Bin in diesem Bereich nicht so versiert. Bei meinem neuen Mainboard mit UEFI gibts jedenfalls neue Sachen zu beachten. Hier muss man einen Schlüssel erstellen und auch bei jedem UEFI Update das Secure Boot deaktivieren. Soweit ich in meiner Mainboard Anleitung gelesen habe, hat es was damit zu tun, dass nur signierte Treiber und kein Schadcode ausgeführt wird. Und bei Windows 11 ist das verpflichtend dass es aktiviert ist, davor konnte man es ausschalten.
Deshalb wollte ich kurz nachfragen, welche Windows Version hier benutzt wurde.

Lieben Gruss
fhihu
 

Christina

Moderatorin
Teammitglied
Hallo @fhihu ,

das hier ist ein Linux-Forum. Ich könnte mir vorstellen, dass Du mit Deiner Frage in einem MS Windows Forum deutlich bessere Chancen auf Unterstützung hast.
Das wage ich zu bezweifeln. ;)
Hallo Susejunky,

Ich werde mich noch zusätzlich in einem Windowsforum anmelden, stimmt.
Bitte beachte dann aber dieses hier und verlinke alle Themen:
Multiposting - Was ist das und warum mag die keiner?
 

Christina

Moderatorin
Teammitglied
Welches Windows habt ihr hier verwendet.
WinXP & WinX (per BIOS Legacy Boot)

WinXI ist WinX so ähnlich, dass es sich an diversen Stellen selbst dafür hält.
(Secure Boot ist ein Teil der UEFI-Spezifikation seit Version 2.3.1 im Jahr 2013.)
Ich habe diese Anleitung heute versucht bei Windows 11. Hier gibt es ja neu das SecureBoot.

Auf der Website steht dazu:

To work around this, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CI\Policy in Regedit,create a new DWORD value called UpgradedSystem and set to 1, and reboot.
WinBtrfs Troubleshooting schrieb:
If you using Windows 10 and have Secure Boot enabled, you may have to make a Registry change in order for the driver to be loaded - see below.
(…)
For the very latest versions of Windows 10, Microsoft introduced more onerous requirements for signing, which seemingly aren't available for open-source drivers.

To work around this, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CI\Policy in Regedit, create a new DWORD value called UpgradedSystem and set to 1, and reboot.
Das habe ich zwar gemacht, aber funktioniert leider nicht.
Was funktioniert nicht? Was hast du bisher gemacht, genau?

Rufe den MS-Windows-Gerätemanager auf devmgmt.msc und schaue, ob unter dem Punkt «Speichervolumes» «Btrfs controller» → Eigenschaften → Treiber die Version 1.9.0 angezeigt wird.
Ist der Eintrag [UpgradedSystem REG_DWORD 0x00000001] (Pfad s.o) in der MS-Windows-Registry vorhanden?
Ich habe allerdings gesehen, dass dieser DWORD Eintrag unterschiedlich festgelegt werden kann. Zb 64 Bit oder 32 Bit.
DWORD ist 32bit lang.
Den Wert kann man als Hexadezimal oder Alphanummerisch festlegen. Was muss man hier benutzen?
Ob Dezimal oder Hexadezimal ist egal, weil eine 0 oder eine 1 in jedem Zahlensystem das Selbe sind.
Aber alphanummerisch ist kein Zahlensystem, sondern eine Eigenschaft einer Zeichenkette.
 
Oben