• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

Gelöst Linux auf einem Samsung Galaxy Book2 15

Ich erreiche GDM bzwl. SDDM, oder was auch immer grad bei KDE Standard ist. Das Bild ist nach ca. 5 Sekunden weg, egal ob ich mich anmelde oder nicht.

Nun habe ich Tumbleweed nochmal neu installiert, aber mit KDE, nicht Gnome, und hier kann ich mit CTRL + ALT + F2 in ein anderes TTY, das ist nun da und da geht auch kein Bild mehr weg.
 

susejunky

Moderator
Teammitglied
Hallo @asatothabaddon ,

... und hier kann ich mit CTRL + ALT + F2 in ein anderes TTY, das ist nun da und da geht auch kein Bild mehr weg.
dann zeige bitte (in dieser Situation; d.h. System bis SDDM gestartet, Bildschirm wird schwarz, mit STRG+Alt+F2 in ein virtuelles Terminal gewechselt und als Benutzer "root" angemeldet) das Ergebnis von
Code:
journalctl -b 0 -p 3

Danach versuche mit Strg+Alt+F7 in das grafische Terminal zu wechseln. Gibt es dort eine nutzbare grafische Oberfläche oder nur einen schwarzen Bildschirm? Kannst Du anschließend wieder mit Strg+Alt+F2 in das nicht-grafische virtuelle Terminal zurück wechseln und weiterarbeiten?

Die in meinem Beitrag #18 nachgefragten Ergebnisse sind weiterhin von Interesse.

Viele Grüße

susejunky
 
@susejunky ok, neue Informationen:

Das ich SDDM erreiche, war wohl zu früh gesagt, denn, es funktioniert nur beim allerersten boot nach einer Neuinstallation, danach nicht mehr. Und es funktioniert auch nur dann, wenn das Notebook am Strom hängt, ohne Strom geht das Display auch in dem Terminal aus, in dem ich mit CTRL+ALT+F3 lande...
 

susejunky

Moderator
Teammitglied
Hallo @asatothabaddon ,

wenn man das "allwissende Netz" befragt, dann scheint es beim Samsung Galaxy Book 2 Probleme mit dem PowerManagement zu geben.

Es wird empfohlen beim Systemstart stets die Kernel-Parameter i915.enable_dc=0 und intel_idle.max_cstate=2 zu übergeben und zusätzlich eine Datei /etc/systemd/logind.conf.d/10-Lid_Switch.conf mit dem Inhalt
Code:
HandleLidSwitch=ignore
HandleLidSwitchExternalPower=ignore
HandleLidSwitchDocked=ignore
anzulegen.

Mangels vergleichbarer Hardware kann ich Dir nicht sagen, ob das tatsächlich funktioniert. Aber ein Versuch kann sicherlich nicht schaden.

Viele Grüße

susejunky
 

susejunky

Moderator
Teammitglied
Hallo @asatothabaddon ,

das sieht ja recht positiv aus.

Wenn die Lösung stabil funktioniert, dann zeichne das Thema bitte noch als "Gelöst". Bei weiteren Fragen, kannst Du hier jederzeit gerne wieder ein neues Thema anlegen.

Übrigens: Die Lösung (so es denn eine ist) ist sehr wahrscheinlich auch auf andere Linux Distributionen übertragbar.

Aber ich empfehle Dir natürlich bei openSUSE Tumbleweed zu bleiben ;):)

Viele Grüße

susejunky
 

susejunky

Moderator
Teammitglied
Hallo @asatothabaddon ,

wenn Du Dich dafür entscheiden solltest openSUSE Tumbleweed weiter zu nutzen, dann hier noch ein paar Hinweise:
  • Die sicherste Art und Weise das System aktuell zu halten ist mittels
    Code:
    zypper dup
  • Neue Tumbleweed Snapshots werden auf der openSUSE Factory Mailingliste und im openSUSE Forum angekündigt.
  • Zur Zeit wird nahezu täglich ein neuer Snapshot bereitgestellt. Es ist aber nicht zwingend erforderlich jeden Snapshot zu installieren (manche der von mir betreuten Systeme werden einmal monatlich aktualisiert).
  • Snapshots können sehr viele (> 1.000) Pakete umfassen (z.B. wenn der C-Compiler aktualisiert und damit alle Pakete neu kompiliert werden).
  • Es ist empfehlenswert die openSUSE Factory Mailingliste zu abonnieren. Dort werden geplante Neuerungen, aktuelle Probleme, usw. diskutiert. Die wöchentlichen Mails mit dem Titel "Tumbleweed - Review of the week" zeigen, was in naher Zukunft umgesetzt wird.
Viele Grüße

susejunky
 
Es wird empfohlen beim Systemstart stets die Kernel-Parameter i915.enable_dc=0 und intel_idle.max_cstate=2 zu übergeben und zusätzlich eine Datei /etc/systemd/logind.conf.d/10-Lid_Switch.conf mit dem Inhalt
Code:
HandleLidSwitch=ignore
HandleLidSwitchExternalPower=ignore
HandleLidSwitchDocked=ignore
anzulegen.
Hallo Susejunky,

Ich stehe leider vor dem selben Problem und ich weiß nicht wo und wie ich die Parameter eintragen muss. Bin noch nicht Ganze so Linux erfahren nach einer langen Pause möchte ich wieder in die Linux Welt eintauschen.

Muss ich Das irgendwo im Grub in der Zeile Linux eintragen ?




Viele Grüße Dennis-Tux
 

Anhänge

  • 20230902_203402.jpg
    20230902_203402.jpg
    290,3 KB · Aufrufe: 9

susejunky

Moderator
Teammitglied
Hallo @Dennis_Tux ,

herzlich willkommen im Linux-Club-Forum.

Muss ich Das irgendwo im Grub in der Zeile Linux eintragen ?
ja, an das Ende der Zeile, die mit "linux /boot..." beginnt, anfügen (und die Datei /etc/systemd/logind.conf.d/10-Lid_Switch.conf anlegen).

Noch ein paar allgemeine Hinweise zur Forums-Nutzung:
  • Im Allgemeinen ist es keine gute Idee sich an ein bestehendes, fast 6 Monate altes und bereits als "Gelöst" gekennzeichnetes Thema "anzuhängen". Das verringert Deine Chancen auf Unterstützung deutlich. Besser ist es ein neues, eigenes Thema mit einem aussagekräftigen Titel zu erstellen und in diesem ggf. auf ein bestehendes Thema zu verweisen.
  • Sollte die oben angedachte Lösung nicht funktionieren oder Du bei der Umsetzung auf Probleme stoßen, dann erstelle bitte ein eigenes Thema.
  • Wenn Du ein Thema erstellst, dann stelle bitte möglichst detaillierte Informationen über Dein System (z.B. verwendetes Betriebssystem mit genauer Versionsangabe) und das Problem (z.B. Log-Dateien) zur Verfügung.
Viele Grüße

susejunky
 
Oben