Tip: [schlecht gelöst] Sound unter Suse 10.0

magnitudo

Newbie
Hallo zusammen,

ich würde gerne eine Info loswerden, aber weiß nicht so recht wo ich sie plazieren soll. Hier schien mir schon sinnvoll, aber ich will den Beitrag nicht nochmehr belasten/zerreden:

http://www.linux-club.de/viewtopic.php?t=53171

Also, ich hatte folgendes Problem:

Kein Sound unter Suse 10.0 und die Anwendungen z.B. Kaffeine, MPlayer usw. klagen darüber.

KMix (der kleine Lautsprecher in der Kontrollleiste) war durchgestrichen.

Ich will garnicht weit ausholen was alles nicht geholfen hat, sondern gleich die (wenn auch nicht beste) Lösung posten:

Unter /boot/grub/menu.lst wurde folgender Eintrag hinzugefügt:

acpi=off

Nach Reboot war der Sound da. Das moderne Powermanagement natürlich gleichzeitg weg, was erstmal nicht stört, aber nicht die Ursache beseitigt hat.
Im Tread oben (URL) sieht es so aus, als liegt das Problem eher in den Innereien von Suse und bedarf einer Entwicklerlösung. Vielleicht ist die Lösung ja längst bekannt, aber wenn nicht, vielleicht kann mein kleiner Beitrag ja ein wenig dazu beitragen die Lösung zu finden.

P.S. Die Lösung habe ich nicht selbst erarbeitet, sondern wurde in der LUG-Marl gefunden. Meinen Dank auch mal an die Gruppe !

P.P.S. Es hat übrigens mit einer Alsa 4000 auf nem K7-Brett und mit meinem neuen Asus A8N-SLi (Sound on Bosrd) unabhängig voneinander nicht funktioniert. Die Suse ist aus dem Sonderheft Chip 02/22006.

@ Admin: Mach mit dem Beitrag bzw. auch mit der Überschrift was du willst, ich war mir nur nicht sicher wohin damit.

Schöne Grüße
Jürgen
 

Gimpel

Guru
das mit dem acpi=off dürfte für laptop benutzer ziehmlich sinnfrei sein, und selbst mein rechner schaltet sich mit acpi=off nicht selbst aus nach dem runter fahren....

funktioniert das bei dir auch mit
Code:
acpi=noirq
?
 

magnitudo

Newbie
Hallo Gimpel,

mit
Code:
acpi=noirq
klappt das auch. Was heißt denn noirq ?

Gimpel schrieb:
selbst mein rechner schaltet sich mit acpi=off nicht selbst aus

Hast du evtl.
Code:
apm=off
?

Da fährt er bei mir auch runter aber geht nicht aus.

Schöne Grüße
Jürgen
 

Gimpel

Guru
acpi=noirq weist das acpi-system an sich nicht um die Verteilung der IRQs zu kümmern, denn was die meisten hier erleben, ist ein ACPI bug, und wohl einer in YaST ;)

apm=off hab ich nicht, ich hab nichtmal APM support im kernel.. aber egal

aber acpi=noirq ist denke ich sinnvoller als =off. Danke für den Test, ich schreibs mal in den angesprochenen Thread mit rein
 

Timon

Newbie
Hallo,

Gimpel schrieb:
aber acpi=noirq ist denke ich sinnvoller als =off. Danke für den Test, ich schreibs mal in den angesprochenen Thread mit rein

Kann es sein, dass der Schalter keine Funktion hat? Egal, ob ich ihn auf off oder noirq stelle, es funktioniert alles wie immer. Selbst das Suspend to Disc geht problemlos...

Gruß
Frank
 

Timon

Newbie
Gimpel schrieb:
laut /usr/src/linux/Documentation/kernel-parameters.txt hat er einige ;)

Das glaube ich gerne, aber warum geht dann noch alles und warum startet der acpid, wenn man acpi=off wählt? ACPI managed ja auch das "suspend to disc" und das geht problemlos, also muss das irgendwie noch an sein...kann man denn sehen, ob Suse den Kernel-Parameter ignoriert?

Gruß
Frank
 
Oben