• Willkommen im Linux Club - dem deutschsprachigen Supportforum für GNU/Linux. Registriere dich kostenlos, um alle Inhalte zu sehen und Fragen zu stellen.

Gelöst Tumbleweed PolicyKit: Legitimierung ist zum Einhängen von /dev/nvme0n1p4 erforderlich

susejunky

Moderator
Teammitglied
Hallo egweber1,

... Beim Anlegen des Benutzers kam dann ein Fenster:
Beim Schreiben des useradd-Standardwertes für '--gid' ist ein Fehler aufgetreten
das sollte so nicht sein! Aber für dieses Problem lege bitte einen separaten Beitrag an.

... Beim Anmelden des neuen Benutzers kam die Aufforderung zum Mounten nicht mehr.
Nun, das war zu vermuten. Schließlich hattest Du bereits einen weiteren Benutzer, bei dem das Problem nicht auftritt.

... Nachdem ich den Benutzer gelöscht habe, kam aber wieder die Fehlermeldung mit '--gid'. Kommt auch, wenn ich in Yast bei Benutzer und Gruppenverwaltung nur auf OK drücke.
siehe oben

Welche Daten sind auf /dev/nvme0n1p4 abgelegt?

Viele Grüße

susejunky
 
OP
egweber1

egweber1

Member
Habe /dev/nvme0n1p4 mounted.
Sehe aber nur 9 Ordner für Windows: AMD, Documents and Settings, Dokumente und Einstellungen, PerfLogs, Program Files, Program Files (x86), Programme, Users und Windows mit jeweiligen Unterordnern.
Bei Anzeige versteckte Dateien:
Verzeichnisse: $Recycle.Bin, $SysReset, $WinREAgent, CanoScan, Config.Msi, OneDriveTemp, ProgramData, Recovery, System Volume Information
Sowie Dateien: $WINRE_BACKUP_PARTITION.MARKER, DumpStack.log.tmp, hiberfil.sys, pagefile.sys und swapfile.sys
 

Christina

Moderator
Teammitglied
Welche Daten sind auf /dev/nvme0n1p4 abgelegt?
Auf der SSD ist ein komplettes MS-Windows, man sieht es auch an den jeweiligen Partitionsgrößen.
Code:
lsblk -o+FSTYPE,DISC-MAX,MODEL,PTTYPE
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS            FSTYPE DISC-MAX MODEL                 PTTYPE
(…)
nvme0n1     259:0    0 232,9G  0 disk                                     2T KINGSTON SA2000M8250G gpt
├─nvme0n1p1 259:1    0   499M  0 part                        ntfs         2T                       gpt
├─nvme0n1p2 259:2    0    99M  0 part                        vfat         2T                       gpt
├─nvme0n1p3 259:3    0    16M  0 part                                     2T                       gpt
└─nvme0n1p4 259:4    0 232,3G  0 part                        ntfs         2T                       gpt
Habe /dev/nvme0n1p4 mounted.
Sehe aber nur 9 Ordner für Windows: AMD, Documents and Settings, Dokumente und Einstellungen, PerfLogs, Program Files, Program Files (x86), Programme, Users und Windows mit jeweiligen Unterordnern.
Unter Users findest du die jeweiligen "Eigenen Dateien".
 
OP
egweber1

egweber1

Member
Unter users steht mein Benutzer, den ich auf Tumbleweed habe, gar nicht.
Das einzige, was ich mit dem Benutzernamen weber finde, ist eine Windows-Datei: CS_Live#3Aedgar.gerhard.weber.conf mit Daten für Skype und sonstiges. Ansonsten nur Daten für Windows.
 

susejunky

Moderator
Teammitglied
Hallo egweber1,

...
Sehe aber nur 9 Ordner für Windows: AMD, Documents and Settings, Dokumente und Einstellungen, PerfLogs, Program Files, Program Files (x86), Programme, Users und Windows mit jeweiligen Unterordnern.
Bei Anzeige versteckte Dateien:
Verzeichnisse: $Recycle.Bin, $SysReset, $WinREAgent, CanoScan, Config.Msi, OneDriveTemp, ProgramData, Recovery, System Volume Information
Sowie Dateien: $WINRE_BACKUP_PARTITION.MARKER, DumpStack.log.tmp, hiberfil.sys, pagefile.sys und swapfile.sys
OK, das scheint eine MS Windows-Systempartition zu sein. Darin sind aber neben den Programmen wahrscheinlich auch reine Benutzerdaten gespeichert.

Gibt es Daten (z.B. Dokumente, Datenbanken, Bilder, Videos, Musik, EMails, ...) die Du regelmäßig sowohl mit MS Windows Anwendungen als auch mit Linux-Anwendungen bearbeitest und die auf dieser Partition (/dev/nvme0n1p4) gespeichert sind?

Viele Grüße

susejunky
 
OP
egweber1

egweber1

Member
Eigentlich nicht. Habe die Festplatte nvme0 ja auch noch nicht in der fstab gehabt. Siehe fstab.
Daten, die ich gemeinsam mit Windows bearbeite liegen auf der Festplatte sda2, die ich auch als Windows-Festplatte D: nutze. Auch bei Leap hatte ich die Festplatte nicht in der fstab. Habe das komplette System erst am 26. 05. von Leap 15.3 auf Tumbleweed umgestellt und dabei die Festplatte für Linux nvme1 neu formatiert, da meine Partition für /root bei Leap mit 30 GB immer zu klein war und ich jetzt auf 50 GB vergrößert habe. Bei Leap musste ich immer wieder Snapshots löschen, um freien Platz zu bekommen. Die Partition / ist mit Updates immer mehr belegt worden.
 
Zuletzt bearbeitet:
OP
egweber1

egweber1

Member
Ich arbeite als Benutzer weber, mein Sohn gelegentlich als Benutzer stefan.
Anbei meine ganzen Festplatten und Belegung:
Festplatten.jpg
 
Zuletzt bearbeitet:

susejunky

Moderator
Teammitglied
Hallo egweber1,

es ist Dir sicherlich bereits aufgefallen, dass mir langsam die Ideen ausgehen, aber eine hätte ich noch:

Wenn die Partition /dev/nvme0n1p4 eingehängt werden soll, dann möglicherweise deshalb, weil ein Prozess eine Datei, die in dieser Partition gespeichert ist, öffnen will. Wenn dem so ist (und die Datei geöffnet bleibt), kann man diesen Prozess eventuell wie folgt identifizieren:
  1. Du startest Dein System,
  2. meldest Dich als der Benutzer an, bei dem das Problem auftritt,
  3. gibst, sobald die Abfrag für das Administratorkennwort angezeigt wird, das Kennwort ein, damit /dev/nvme0n1p4 eingehängt werden kann.
  4. öffnest eine Konsole und führst folgen Befehl aus
    Code:
    lsof +f -- /dev/nvme0n1p4
    und zeigst das Ergebnis hier.
Sollte lsof bei Dir noch nicht installiert sein, kannst Du es mit
Code:
zypper in lsof
nachinstallieren.

Viele Grüße

susejunky
 

josef-wien

Ultimate Guru
Man könnte eventuell die Dateien des Heimatverzeichnisses durchsuchen:
Code:
grep -rni "nvme0n1p4" $HOME
Und das dann noch für die UUID der Partition und die UUID des Dateisystems.
 
OP
egweber1

egweber1

Member
Trotzdem vielen Dank! Muss ich halt jedes Mal bei der Anmeldung auf Abbrechen drücken.
 
Moin allerseits,
mal unter
Systemeinstellungen
Wechselmedien
Wechselmedien
Automatisches Einhängen
nur Wechselmedien einhängen
alle Wechselmedien beim Anmelden einhängen
Wechselmedien beim Anschluss automatisch einhängen
durchprobieren.

Wie ist Deine derzeitige Einstellung?
 

susejunky

Moderator
Teammitglied
Hallo egweber1,

... Muss ich halt jedes Mal bei der Anmeldung auf Abbrechen drücken.
eine Idee hätte ich nun doch noch:
  1. Starte Dein System
  2. Wenn der grafische Anmeldedialog erscheint, melde Dich zunächst NICHT an.
  3. Öffne mit Strg+Alt+F2 eine Konsole
  4. Melde Dich als Benutzer "root" an.
  5. Prüfe, ob es eine Datei /home/BETROFFERNER_BENUTZER/.config/kded_device_automounterrc gibt.
  6. Wenn die Datei nicht existiert, dann endet die Geschichte hier (weil auch das nur eine weitere falsche Fährte war).
  7. Wenn die Datei existiert, benenne sie bitte um.
  8. Melde dich als "root" ab.
  9. Wechsle mit Strg+Alt+F7 zum Login-Dialog
  10. Melde den betroffenen Benutzer an.
Die Kennwortabfrage sollte nicht mehr angezeigt werden.

Viele Grüße

susejunky
 
OP
egweber1

egweber1

Member
Moin allerseits,
mal unter
Systemeinstellungen
Wechselmedien
Wechselmedien
Automatisches Einhängen
nur Wechselmedien einhängen
alle Wechselmedien beim Anmelden einhängen
Wechselmedien beim Anschluss automatisch einhängen
durchprobieren.

Wie ist Deine derzeitige Einstellung?
Automount Device:__________Bei der Anmeldung____________On Attach
All Known Devices__________hier ist ein Haken gesetzt________hier ist ein Haken gesetzt
Alles andere ist grau hinterlegt.
 
Zuletzt bearbeitet:
OP
egweber1

egweber1

Member
Hallo egweber1,


eine Idee hätte ich nun doch noch:
  1. Starte Dein System
  2. Wenn der grafische Anmeldedialog erscheint, melde Dich zunächst NICHT an.
  3. Öffne mit Strg+Alt+F2 eine Konsole
  4. Melde Dich als Benutzer "root" an.
  5. Prüfe, ob es eine Datei /home/BETROFFERNER_BENUTZER/.config/kded_device_automounterrc gibt.
  6. Wenn die Datei nicht existiert, dann endet die Geschichte hier (weil auch das nur eine weitere falsche Fährte war).
  7. Wenn die Datei existiert, benenne sie bitte um.
  8. Melde dich als "root" ab.
  9. Wechsle mit Strg+Alt+F7 zum Login-Dialog
  10. Melde den betroffenen Benutzer an.
Die Kennwortabfrage sollte nicht mehr angezeigt werden.

Viele Grüße

susejunky
Hallo, hat endlich geklappt. Habe aber einen einfacheren Weg gewählt: Mit Dolphin in diesem Verzeichnis versteckte Dateien anzeigen:
Im Unterverzeichnis /home/weber/.config/.config/kded_device_automounterrc
in kded_device_automounterrcalt
als normaler Benutzer weber umbenannt. Danach neu gestartet und die Meldung war weg. Hurra!
Es wurde eine neue Datei kded_device_automounterrc erstellt.
Nur bei Interesse für den Dateieintrag:
Alter Eintrag in der Datei.config/kded_device_automounterrc war:
Code:
[Devices][/org/freedesktop/UDisks2/block_devices/nvme0n1p4]
EverMounted=true
Icon=drive-harddisk
LastNameSeen=Basic data partition
Neuer Eintrag:
Code:
[Devices][/org/freedesktop/UDisks2/block_devices/nvme0n1p4]
Icon=drive-harddisk
LastNameSeen=Basic data partition
Dies ist übrigens genauso wie der Eintrag unter nvme0n1p2.
Warum das passiert ist? Mir völlig unverständlich!
Danke nochmals für die zahlreiche Hilfe besonders bei susejunky!
 
Zuletzt bearbeitet:

Christina

Moderator
Teammitglied
Es könnte auch ein Fehler in KDE Plasma sein. openSUSE Tumbleweed verteilt von allem immer die neuesten Versionen, die manchmal eben auch die neuesten Fehler enthalten.
Darum ist es hilfreich, wenn du in der Themenüberschrift "Tumbleweed" dazuschreibst und vor allem das Problem so gut wie möglich benennst. Ich hatte das diesmal für dich erledigt. Platz ist dafür genug vorhanden. ;)
lg Christina
 
Oben