ACER WLAN 11b PCMCIA Card / Suse 9.0

Ich bekomme oben genannte Karte nicht zum laufen unter Suse Linux 9.0. Leider konnten mir die anderen Threads in diesem Forum nicht weiterhelfen, weil bei den meisten Beiträgen schon einiges an Fachwissen vorrausgesetzt ist, welches ich nicht habe.

Wäre sehr nett, wenn ihr mir von Grund auf erklären könnt, wie ich die Karte lauffähig machen kann.

Nun zum thema:

Ich habe einen 2.4... Kernel und dieses WLAN Package von der Suse CD installiert. Brauche ich nun zuallererst einen neuen Kernel um überhaupt starten zu können? Was ist überhaupt ein Kernel?
Habe gesehen, dass es schon 2.6... Kernel gibt.

Habe probiert unter Yast die Acer Karte einzubinden allerdings ohne Erfolg.

Und über die Konsole habe ich auch probiert die Karte zu starten, aber dann heißt es, dass keien vorhanden ist.
 
Welche 9.0 Version hast du? Wieviel Ahnung hast du von Konsole, Rootrechten, Pakete installieren, Dateien anpassen? Die Einbindung derartiger Karten setzt ein paar Grundkentnisse voraus. Da wir deinen Rechner nicht sehen können, ist es sehr mühsam und aufwendig, jedes Detail zu erklären.
 
OP
A

a-double-ya

Newbie
Ein paar Konsolenbefehle kenne ich.

Wie finde ich heraus welche 9.0 Version ich habe?

Verstehe, dass es etwas aufwändiger wird aber wäre wirklich klasse, wenn ihr mich trotzdem unterstützen könnt.

Wie wäre es, wenn ihr mir die Befehle sagt ich sie ausführe und die Ergebnisse poste? Dann könnte es doch Schritt für Schritt vorangehen.

Danke im Vorraus :)
 
Du brauchst eine Personel oder Profesionel Version, da nur auf den CD's die zusätzlichen Pakete sind. Hast du ne CD aus einer PC-Zeitschrift fehlen die und du brauchst nen Internetzugang unter Linux, um sie vom FTP-Server zu installieren.
Du brauchst auf jeden Fall die Kernelquellen, PCMCIA-Paket, wirless-tools, und gcc, libc, glibc und noch ein paar lib's, die aber meist automatisch von YAST ausgewählt werden. Installier alles erst mal.
Ich habe eine andere Karte, aber vieleicht kann ich dir trotzdem helfen. Wie heist die ACER genau.
 

Bonsai

Advanced Hacker
a-double-ya schrieb:
Wie finde ich heraus welche 9.0 Version ich habe?
CD oder DVD entmounten und aus dem Laufwerk nehmen, LESEN, oder (wenn es eine gebrannte Version ist, kannst Du das Paket make im Yast installieren? Wenn ja, dann gleich gcc mitinstallieren!
 
hi,

habe erst letzte woche meine acer wlan karte unter linux zum laufen gebracht. der einfachste weg ist (meiner meinung nach) ndiswrapper zu installieren (ist auf der linux cd drauf - ansonsten hilft http://ndiswrapper.sourceforge.net weiter -> installationsanleitung liegt dort auch bei). ndiswrapper ist ein projekt, das es erlaubt, windowstreiber auf linux zu installieren.

den neusten treiber für die acer wlan 11b bekommst du unter:
http://www.realtek.com.tw/downloads/downloads1-3.aspx?Keyword=rtl8180
nimm dort den windows xp treiber.
wie man nun den treiber installiert steht sehr ausführlich und einfach in der datei INSTALL, die ndiswrapper beiliegt.

ansonsten kann ich dir wärmstens den folgenden link empfehlen:
http://www.linux-club.de/viewtopic.php?t=7360

viel glück :wink:
 
OP
A

a-double-ya

Newbie
hey koebrunner!

Vielen Dank für Deine ausführliche, gute Anleitung. Ich werde gleich versuchen Deine Tips umzusetzen.
Wenn ich dann noch irgendwo hänge poste ich nochmals.
 
OP
A

a-double-ya

Newbie
Also bin nun schon viel weiter aber es fehlt wohl noch das letzte Quäntchen, damit mein WLAN endlich läuft...

Habe ndiswrapper korrekt installiert und den net8180.inf Win-XP Treiber eingebunden.

Siehe Shell Ausgaben:

ocalhost:/home/a-double-ya # ndiswrapper -l
Installed ndis drivers:
net8180 present
localhost:/home/a-double-ya # modprobe ndiswrapper
localhost:/home/a-double-ya #

modprobe wurde ausgeführt, ohne eine Fehlermeldung zurückzugeben. Dann sollte der Treiber ja korrekt geladen sein, richtig?

Doch nun gehe ich weiter vor:

Ich rufe die System log mit "dmesg" auf. Daraufhin erscheint folgender, lange Ausgabe:

localhost:/home/a-double-ya # dmesg
Linux version 2.4.21-99-default (root@i386.suse.de) (gcc version 3.3.1 (SuSE Linux)) #1 Wed Sep 24 13:30:51 UTC 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000dd000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000013ff0000 (usable)
BIOS-e820: 0000000013ff0000 - 0000000013ffec00 (ACPI data)
BIOS-e820: 0000000013ffec00 - 0000000014000000 (ACPI NVS)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
693MB vmalloc/ioremap area available.
0MB HIGHMEM available.
319MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 81904
zone(0): 4096 pages.
zone(1): 77808 pages.
zone(2): 0 pages.
IBM machine detected. Enabling interrupts during APM calls.
ACPI: RSDP (v000 PTLTD ) @ 0x000f6ec0
ACPI: RSDT (v001 PTLTD RSDT 01540.08784) @ 0x13ff5c49
ACPI: FADT (v001 IBM TP-X21 01540.08784) @ 0x13ffeb65
ACPI: BOOT (v001 PTLTD $SBFTBL$ 01540.08784) @ 0x13ffebd9
ACPI: DSDT (v001 IBM TP-X21 01540.08784) @ 0x00000000
ACPI: Skipping APIC setup
Building zonelist for node : 0
Kernel command line: root=/dev/hda3 vga=0x314 desktop splash=silent
bootsplash: silent mode.
Initializing CPU#0
Detected 597.401 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 1179.64 BogoMIPS
Memory: 320172k/327616k available (1590k kernel code, 7056k reserved, 605k data, 160k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383f9ff 00000000 00000000 00000000
CPU: Common caps: 0383f9ff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 06
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20030619
PCI: PCI BIOS revision 2.10 entry at 0xfd94f, last bus=7
PCI: Using configuration type 1
Looking for DSDT in initrd ... not found!
ACPI-1121: *** Error: Method execution failed [\_SB_.PCI0._INI] (Node cdfa1240), AE_AML_NO_RETURN_VALUE
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: System [ACPI] (supports S0 S1 S3 S4 S5)
ACPI: PCI Interrupt Link [LNKA] (IRQs 9 *11)
ACPI: PCI Interrupt Link [LNKB] (IRQs 9 *11)
ACPI: PCI Interrupt Link [LNKC] (IRQs 9 *11)
ACPI: PCI Interrupt Link [LNKD] (IRQs 9 *11)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
ACPI: Power Resource [PSIO] (on)
ACPI: Power Resource [PSER] (off)
ACPI: Embedded Controller [EC] (gpe 9)
schedule_task(): keventd has not started
PCI: Probing PCI hardware
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
00:00:01[A] -> IRQ 11 Mode 1 Trigger 1
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
PIC: IRQ (11) already programmed
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
Limiting direct PCI/PCI transfers.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
apm: overridden by ACPI.
PISCH: Plug In Scheduler Interface (Version 6)
Starting kswapd
bigpage subsystem: allocated 0 bigpages (=0MB).
kinoded started
VFS: Disk quotas vdquot_6.5.1
aio_setup: num_physpages = 20476
aio_setup: sizeof(struct page) = 48
vesafb: framebuffer at 0xf5000000, mapped to 0xd481f000, size 4096k
vesafb: mode is 800x600x16, linelength=1600, pages=3
vesafb: protected mode interface info at c000:57aa
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
bootsplash 3.0.9-2003/09/08: looking for picture... no good signature found.
Console: switching to colour frame buffer device 100x37
fb0: VESA VGA frame buffer device
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
Redundant entry in serial pci_table. Please send the output of
lspci -vv, this message (115d,000c,8086,2408)
and the manufacturer and name of serial board or modem board
to serial-pci-info@lists.sourceforge.net.
register_serial(): autoconfig failed
Real Time Clock Driver v1.10e
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
RAMDISK driver initialized: 16 RAM disks of 64000K size 1024 blocksize
loop: loaded (max 16 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 00:07.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x1800-0x1807, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0x1808-0x180f, BIOS settings: hdc:pio, hdd:pio
hda: IBM-DJSA-220, ATA DISK drive
blk: queue c03bf900, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 39070080 sectors (20004 MB) w/1874KiB Cache, CHS=2584/240/63, UDMA(33)
ide-floppy driver 0.99.newide
Partition check:
hda: hda1 hda2 < hda5 > hda3 hda4
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
cryptoapi: loaded
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 244k freed
VFS: Mounted root (ext2 filesystem).
reiserfs: found format "3.6" with standard journal
reiserfs: enabling write barrier flush mode
reiserfs: using ordered data mode
reiserfs: checking transaction log (device ide0(3,3)) ...
for (ide0(3,3))
Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Trying to move old root to /initrd ... failed
Unmounting old root
Trying to free ramdisk memory ... okay
Freeing unused kernel memory: 160k freed
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
reiserfs: enabling write barrier flush mode
LVM version 1.0.5+(mp-v6a)(22/07/2002) module loaded
reiserfs: enabling write barrier flush mode
Adding Swap: 514072k swap-space (priority 42)
reiserfs: enabling write barrier flush mode
reiserfs: enabling write barrier flush mode
NTFS driver 2.1.4a [Flags: R/O MODULE].
NTFS volume version 3.1.
NTFS volume version 3.1.
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
ds: no socket drivers loaded!
unloading Kernel Card Services
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
ds: no socket drivers loaded!
unloading Kernel Card Services
raw1394: /dev/raw1394 device initialized
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 13:50:22 Sep 24 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0x1820, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
uhci.c: USB Universal Host Controller Interface driver v1.1
mice: PS/2 mouse device common for all mice
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
Yenta IRQ list 04b8, PCI irq11
Socket status: 30000820
Yenta IRQ list 04b8, PCI irq11
Socket status: 30000006
cs: cb_alloc(bus 2): vendor 0x10ec, device 0x8180
PCI: Enabling device 02:00.0 (0000 -> 0003)
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0820-0x08ff: clean.
cs: IO port probe 0x0800-0x080f: clean.
cs: IO port probe 0x03e0-0x04ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x0100-0x03af: excluding 0x170-0x177 0x370-0x377
cs: IO port probe 0x0a00-0x0aff: clean.
ACPI: AC Adapter [AC] (on-line)
ACPI: Battery Slot [BAT0] (battery absent)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ACPI: Sleep Button (CM) [SLPB]
ACPI: Processor [CPU] (supports C1 C2 C3, 8 throttling states)
ACPI: Thermal Zone [THM0] (35 C)
IPsec Security Association Database (SADB): initialized.
IPsec Security Policy Database (SPD): initialized.
IPsec PF_KEY V2: initialized
IPv6 v0.8 (usagi-cvs/IPsec6 based StS) for NET4.0
IPv6 over IPv4 tunneling driver
cpufreq: Intel(R) SpeedStep(TM) for this chipset not (yet) available.
amd64-cpuf: version 1.00.06 - August 13, 2003
amd64-cpuf: Not an AMD processor
powernow: AMD processor not detected.
parport0: PC-style at 0x3bc [PCSPP,TRISTATE]
lp0: using parport0 (polling).
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux video capture interface: v1.00
SCSI subsystem driver Revision: 1.00
Intel(R) PRO/100 Network Driver - version 2.3.27
Copyright (c) 2003 Intel Corporation

e100: selftest OK.
e100: eth0: Intel(R) PRO/100 Network Connection
Hardware receive checksums enabled
cpu cycle saver enabled

prism2_init: prism2_cs.o: 0.2.1-pre9 Loaded
prism2_init: dev_info is: prism2_cs
e100: eth0 NIC Link is Up 100 Mbps Full duplex
eth0: no IPv6 routers present
ndiswrapper version 0.8 loaded
ndiswrapper adding rtl8180.sys
PCI: Setting latency timer of device 02:00.0 to 64
wlan0: ndiswrapper ethernet device 00:02:72:44:64:4e using driver rtl8180.sys
wlan0: no IPv6 routers present
localhost:/home/a-double-ya #

----------------------------------------------------

nun folgt:

----------------------------------------------------
localhost:/home/a-double-ya # iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:""
Mode:Auto Frequency:2.412GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:11Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:2432 B Fragment thr:2432 B
Encryption key:eek:ff
Power Management:eek:ff
Link Quality:100/100 Signal level:-95 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

localhost:/home/a-double-ya #


Wenn ich nun die ESSID, WEP und den Mode einstellen möchte so speichert er die Werte nicht:

----------------------------------------------

localhost:/home/a-double-ya # iwconfig wlan0 essid SMC
localhost:/home/a-double-ya # iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:""
Mode:Auto Frequency:2.412GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:11Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:2432 B Fragment thr:2432 B
Encryption key:eek:ff
Power Management:eek:ff
Link Quality:100/100 Signal level:-95 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

localhost:/home/a-double-ya #


Nach der Eingabe der ESSID steht dort immernoch keine?!

Der WEP Key wird gespeichert, wenn ich diesen eingebe.


Was fehlt nun noch?
 
OP
A

a-double-ya

Newbie
Nach einem Neustart hat er wieder kein wlan0 gefunden auch wenn ich alle Schritte noch einmal durchgegangen bin.

Bei "iwconfig" wird wlan0 wieder NICHT angezeigt also kann ich auch nichts konfigurieren. Woran hapert es? Er hat es ja nun schon einmal gefunden.
 
versuche mal folgendes in yast:

- netzwerkgeräte -> netzwerkkarte -> eth0 rausschmeißen
- Realtek RTL8180L -> konfigurieren (bzw. ändern -> bearbeiten, wenn sie schon als konfiguriert eingetragen ist).
- bei besondere einstellungen -> erweitert -> hardwaredetails und dort als modulname ndiswrapper eingeben
- bei einstellungen für den funkverkehr kannst du dann nochmal essid und wep-schlüssel eingeben (achte darauf, ob dein accesspoint hex oder ascii verwendet - das hat bei mir anfangs zu problemen geführt)
- wenn die karte noch nicht konfiguriert war (siehe punkt 2) kannst du bei den hardwaredetails angeben, dass es sich um eine drahtlose verbindung handelt.

was ich anschließend gemacht habe:
in der datei /etc/sysconfig/network/ifcfg-wlan0 habe ich ganz oben den eintrag DHCLIENT_PRIMARY_DEVICE='yes' eingefügt. danach habe ich eth0 wieder reingenommen.

p.s. die wep-verschlüsselung würde ich erst mal weglassen, bis alles funktioniert. wenn du eine verbindung hast, kannst du sie ja aktivieren - so kann man zumindest einen fehler vorerst ausschließen
 
OP
A

a-double-ya

Newbie
Puuuuh, geht immer noch nicht. Habe im YAST folgenden konfiguriert:
--------------------------------------------------
Bereits konfigurierte Geräte:

Intel EtherExpress PRO/100+ MiniPCI
Als eth0 mit DHCP konfiguriert

Realtek Ethernet controller
Als eth-pcmcia mit DHCP konfiguriert

Drahtlose Netzwerkkarte
Als wlan0 mit DHCP konfiguriert
---------------------------------------------------

Die Realtek erkennt er aber ich habe da nicht die Möglichkeit auf "Drahtlos" zu stellen. Deshalb habe ich eine 3. Karte manuell hinzugefügt und als drahtlose eingefügt. Soll ich da welche löschen?

in der datei /etc/sysconfig/network/ifcfg-wlan0 habe ich ganz oben den eintrag DHCLIENT_PRIMARY_DEVICE='yes' eingefügt

==> Habe ich auch gemacht und neu gestartet.

----------------------------------------------------

Folgenden Ausgaben nun:

localhost:/home/a-double-ya # ndiswrapper -l
Installed ndis drivers:
net8180 present
localhost:/home/a-double-ya # iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

localhost:/home/a-double-ya # ifconfig
eth0 Protokoll:Ethernet Hardware Adresse 00:10:A4:8B:18:DF
inet Adresse:192.168.2.135 Bcast:192.168.2.255 Maske:255.255.255.0
inet6 Adresse: fe80::210:a4ff:fe8b:18df/64 Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:369 errors:0 dropped:0 overruns:0 frame:0
TX packets:410 errors:6 dropped:0 overruns:0 carrier:6
Kollisionen:0 Sendewarteschlangenlänge:100
RX bytes:190625 (186.1 Kb) TX bytes:60931 (59.5 Kb)
Interrupt:11 Basisadresse:0x1840 Speicher:f4010000-f4010038

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:62 errors:0 dropped:0 overruns:0 frame:0
TX packets:62 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:4052 (3.9 Kb) TX bytes:4052 (3.9 Kb)

localhost:/home/a-double-ya #

---------------------------------------------------

Jetzt findet er bei "iwconfig" wlan0 mal wieder nicht. Wieso??? Und wenn er es findet kann ich mit dem Befehl

iwconfig wlan0 essid "XYZ"

die essid nicht ändern. Er führt den Befehl aus jedoch steht später bei ESSID=""

mal wieder nichts drin. Sehr merkwürdig.
 
OP
A

a-double-ya

Newbie
Inhalt von ifcfg-wlan0:
-----------------------------------
DHCLIENT_PRIMARY_DEVICE='yes'

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE=''
WIRELESS_ESSID='SMC'
WIRELESS_KEY='F355E55F50'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
-----------------------------------

Ist hier noch was zu ändern? Remote_IpAddr= IP meines Routers?

Überschneiden sich nicht die Angaben im Yast mit denen,die ich über die Konsole ausführe?

Sollte ich nicht mal alle Netzwerkkarten im YAST löschen?
 
OP
A

a-double-ya

Newbie
Wenn ich

"ifup wlan0"

ausführe scannt er DHCP ................. bekommst aber keine IP vom Router. Merkwürdig ist auch, dass die Kotrolleuchten an meiner PCMCIA Wlan Karte noch nicht einmal aufgeflackert sind unter Linux. Eine grüne heißt Betrieb und die Gelbe TRAFFIC.
Kann es sein, dass die Karte keinen Strom bekommt??? Wie kann man sowas einstellen unter SuSE?

Und vor allem, wie sorge ich dafür, dass mittels

iwconfig wlan0 essid SMC

die ESSID gespeichert wird und nicht wieder ESSID:"" ohne einen Eintrag dasteht.
 
hm, schade, bei mir hat das so einwandfrei funktionert.

ich kann dir vielleicht einmal schildern, was ich nun versuchen würde:
vorab noch: ich habe kein dhcp gemacht, sondern habe fixe ip adressen vergeben.

- über YaST -> netzwerkgeräte -> netzwerkkarte ALLE netzwerkkarten entfernen. (realtek, eth0 und die dritte karte, die du mit angegeben hast)
- YaST wieder starten und in netzwerkgeräte -> netzwerkkarte NUR die realtek karte konfigurieren.
- dort dann die einstellungen treffen, die ich bereits gepostet habe (modulname: ndiswrapper, essid, drahtlose verbindung, ...). lass wep vorerst noch weg. ach ja. könnte vielleicht noch wichtig sein: als konfigurationsname habe ich wlan0 angegeben.

mehr habe ich nicht gemacht. ich habe zum testen gerade vorhin noch meine karte rausgeschmissen und genau so wieder eingebunden - und es hat wieder funktioniert.
 
OP
A

a-double-ya

Newbie
YaST wieder starten und in netzwerkgeräte -> netzwerkkarte NUR die realtek karte konfigurieren.

--- Die lässt sich aber nur als eth-pcmcia einstellen. Ist grau ausgeblendet und lässt sich nicht verändern, deshalb habe ich ja eine 3. Karte zusätzlich eingebunden als wlan0 und "drahtlos"


- dort dann die einstellungen treffen, die ich bereits gepostet habe (modulname: ndiswrapper, essid, drahtlose verbindung, ...). lass wep vorerst noch weg. ach ja. könnte vielleicht noch wichtig sein: als konfigurationsname habe ich wlan0 angegeben.

--- wie gesagt konfigurationsname lässt sich nicht ändern.

Steht bei Dir die Realtek Karte drin und Du kannst den Konfigurationsnamen beliebig wählen und auch in wlan0 umbennenen?
 
a-double-ya schrieb:
--- Die lässt sich aber nur als eth-pcmcia einstellen. Ist grau ausgeblendet und lässt sich nicht verändern, deshalb habe ich ja eine 3. Karte zusätzlich eingebunden als wlan0 und "drahtlos"
Lässt sich pcmcia deaktivieren? habe bei mir eben gesehen, dass sich das unter erweitert -> hardwaredetails deaktivieren lässt - und bei mir ist es sogar deaktiviert (ist mir bisher noch gar nicht aufgefallen ;) ). funktioniert aber anscheinend nur dann, wenn man (wieder mal) die karte dort löscht und dann wieder einbindet.
 
OP
A

a-double-ya

Newbie
Hilft alles nichts.

iwconfig wlan0 ESSID DeineID
so kann sich das Spiel auch auf den key runterbrechen:
iwconfig wlan0 key 101010.... bla bla bla

Die Befehle habe ich schon längst probiert. KEY speichert er ab, no problem. Aber die essid wird nicht gespeichert egal, wie oft ich den Befehl in die Shell tippe.

Beide Lampen leuchten nicht. Die Karte hat noch nicht einmal Strom bekommen, weil keine der Lampen je geleuchtet hat. Ich bin ratlos, vielleicht läuft diese Karte mit Linux einfach nicht.

Oder letzter Rat: Weißt Du wie ich der Karte Strom zuführe?
 
Oben